Jump to content
Welcome Guest!

Join us now to get access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, and so, so much more. It's also quick and totally free, so what are you waiting for?

fishman

Hyperspin Movies

Recommended Posts

Ok i found old youtube videos from hyperspin 1.0 for movies but nothing current. Is there any current tutorials so i can set up my movie collection with hyperspin? And to create xml for movies and can it be in mp4 format?

Share this post


Link to post
Share on other sites

I wasn't even aware this was possible. Adding movies to an xml manually sounds incredibly tedious. I think most people just have HS load kodi... I am opposite, I have Kodi launch HS when I want to play a game, and return to kodi after I exit HS.

Sent from my SGH-I467M using Tapatalk

Share this post


Link to post
Share on other sites

Tutorials are in the works....however, in the meantime, you could use Don's HyperSpin tools (the beta version) and use Create New Hyperlist.exe to to scan all your movie file names with extension mp4 within your designated folder.  It will the spit out a database containing you movie file names.  If you do not use RocketLauncher, you use HyperHQ to launch your video player.  With RocketLauncher, they might have a prebuilt module to launch movie players, however; someone with RL exp will have to chime in here.  Attached is Don's HyperSpin Beta tools (in which ill be uploading to the downloads section soon)

Don's HyperSpin Tools Beta.zip

Share this post


Link to post
Share on other sites

idk anything about rocket launch but I do have this set up with hyper launch. basically the same as setting up any other system I use a free program called vlc to play my movies so in hyper hq and hyperlaunch hq I have vlc set as my emulator and rom paths point to where all my movies are, rom extensions are mkv,mpg,m4v,mp4,avi,vob,flv, probably a few more I cant remember

 

Heres a vlc module that works in hyperlaunch. extract it in HyperSpin>HyperLaunch>Modules

 

big thanks to zerojay btw for making this module, I got it off some post on the old site a while back. no clue if it will work in rocket launch, or if rl even uses modules for that matter lol. I guess its to for me to upgrade my setup!

VLC.zip

Share this post


Link to post
Share on other sites

Thank you for the VLC module.  I've successfully setup my 'Movies' wheel and think that all of my settings are correct.  However, VLC launches in windowed mode (despite the WIN setting in HyperHQ) and I have to manually close it with my mouse once a video finishes playing.  I've attached screenshots of this happening, including HyperHQ and Rocketlauncher settings with the VLS module.  Can someone review and let me know if they see something wrong?  I'd expect my movie to fade in and play seamlessly with VLC and then fade back to HS when finished.  Thx.

post-66280-0-76887600-1438460098_thumb.jpg

post-66280-0-15876000-1438460105_thumb.jpg

post-66280-0-90916700-1438460107_thumb.jpg

Share this post


Link to post
Share on other sites

You're awesome, that fixed it.  When I play a video it now shows the LOADING screen and plays the video, then fades back to HS.  I notice that the voice saying "Loading Complete" starts when my video starts, so there is overlap with the audio.  Is there a way to stall the video for a second or deactivate the "Loading Complete" sound for my movie wheel only?

Share this post


Link to post
Share on other sites

I have the strangest thing whereas my video will load fine in VLC player if I have 1 extension listed in the settings:  rom extension = mp4.  But when I add more than one, say:  rom extension = mp4, avi, divx    then VLC will error out and not load the video stating 'file not found'.  Can anyone give me any ideas please.  This has me stumped for a week now.  :wallbash:

The only thing I haven't tried is modifying the Hyperlaunch.ahk file.

Share this post


Link to post
Share on other sites

I'm old school and haven't kept up.  Rocket Launcher came along after my system was setup.  Is this my only option, or would modifying my ahk solve this?

Share this post


Link to post
Share on other sites

mp4, avi, divx  should be mp4,avi,divx  in hyper hq

no spaces

and in hyperlaunch should be

mp4|avi|divx  

also, i would recomend checking out kodi (formerly known as xbmc) u can have it automatically download all the boxart for you saves alot of effort

i wish i would have known about it along time ago

Share this post


Link to post
Share on other sites

 I use Kodi on my TV.  This is for my arcade cabinet which I choose to have music videos on a hyperspin menu. This (mp4|avi|divx) may solve my problem, but can you please tell me where/what I would put that into Hyperlaunch.ahk?  I am using either VLC Player or Media Player Classic.  Thanks for the input! 

Share this post


Link to post
Share on other sites

Will Rocketlaunch work with version 1.2.0 (and will it mess with my other settings)?  .....it's just that, after much work, my machine is working perfectly (other than adding multiple file extension for video), so I prefer not to upgrade if possible.

Share this post


Link to post
Share on other sites

Will Rocketlaunch work with version 1.2.0 (and will it mess with my other settings)? .....it's just that, after much work, my machine is working perfectly (other than adding multiple file extension for video), so I prefer not to upgrade if possible.

It won't work with 1.2 unfortunately. You'll need HS 1.4.

I'd still suggest giving it a try. Just make sure to make a copy of your existing setup first.

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

You're awesome, that fixed it.  When I play a video it now shows the LOADING screen and plays the video, then fades back to HS.  I notice that the voice saying "Loading Complete" starts when my video starts, so there is overlap with the audio.  Is there a way to stall the video for a second or deactivate the "Loading Complete" sound for my movie wheel only?

 

I just set up the fades on my install as well.  Now I have the same "Loading complete" voice playing.  I'd like to disable that voice.  Anyone know how to do this?

 

Thanks!

Tom

Share this post


Link to post
Share on other sites

I just set up the fades on my install as well.  Now I have the same "Loading complete" voice playing.  I'd like to disable that voice.  Anyone know how to do this?

 

Thanks!

Tom

 

Open RocketLauncherUI, select Global (if you want to disable it for all systems) or the specific system you want to disable it for, select the Settings tab, and in the 7z group set Play Sounds to false.

Share this post


Link to post
Share on other sites
MEmu = vlc
MEmuV = v2.1.0
MURL = http://www.videolan.org/vlc/index.html
MAuthor = zerojay
MVersion = 2.0.1
MCRC =
iCRC = 6ECFA124
MID = 635038268923820499
MSystem = "VLC, Videos, Movies, TV"
;----------------------------------------------------------------------------
;
;----------------------------------------------------------------------------
StartModule()
FadeInStart()

settingsFile := modulePath . "\" . moduleName . ".ini"
Fullscreen := IniReadCheck(settingsFile, "Settings", "Fullscreen","",,1)
PlayAndExit := IniReadCheck(settingsFile, "Settings", "PlayAndExit","",,1)
Parameters := IniReadCheck(settingsFile, "Settings", "Parameters",,,1)

Fullscreen := (Fullscreen="true" ? (" --fullscreen") : (" --no-fullscreen"))
PlayAndExit := (PlayAndExit="true" ? (" --play-and-exit") : (""))


Run(executable . Fullscreen . PlayAndExit . " " . Parameters . " """ . romPath . "\" . romName . romExtension . """", emuPath)

WinWait("VLC ahk_class QWidget")
WinWaitActive("VLC ahk_class QWidget")

FadeInExit()
Process("WaitClose", executable)
7zCleanUp()
FadeOutExit()
ExitModule()


CloseProcess:
FadeOutStart()
WinClose("VLC ahk_class QWidget")
Return

here u go pulled from a Spanish site

Share this post


Link to post
Share on other sites

Does anyone know the android exe= line for movies on hyperspin? I have downloaded android vlc playe, generated an xml for all the star wars films, have all art running for each one, just need that final line to link it all together.

Any help would be much appreciated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×