Jump to content
Welcome Guest!

Join us now to get access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, and so, so much more. It's also quick and totally free, so what are you waiting for?

Alderik

Help With Hardware On Arcade Cabinet

Recommended Posts

Hi im new in the forum.

I am contstructing an Arcade Cabinet Machine. My idea is play arcade games from Nes to Naomi. Naomi is the top of game i want to play.

I have a pc gammer to test with gtx970 and 16gb rams and Naomi Runs great but i think this is tooo much in money and hardware for only recreative of this type

My question is what is the best hardwar fot the lowest cost to play Naomi with Full graphics  on the best fps.

RAM? VIDEO? and MICRO?

Sorry for my english i speak spanish and i do my best

Thanks for all for this comunity its look pretty cool

Share this post


Link to post
Share on other sites

Nes isn't an arcade system. I assume you mean that you want to play systems from the early to mid eighties up until the mid 2000's?

Geforce GTX 570 or AMD equivalent would be the minimum for the later generations.
8Gb of RAM would probably be enough and any cpu with at least a dual core and clocked at 3.5Ghz (overclocking to over 4Ghz at least would be a must)

If you plan to include PS2/Gamecube games than the graphics card would be a bit on the low side but those are the absolute minimal requirements if I were to make such a build myself. I would probably go with a GTX950, not high-end by any means but surely better than the absolute minimum.

FPS isn't really a big deal when emulating, as long as you consistently keep the framerate the same as how it was on the hardware you are fine which is mostly 60FPS

Your English is fine, I've seen way worse and some people don't even try.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Maligno555
      Hola amigos, les relato mi problema.
      Todo estaba perfecto, tenia mi setup de mame funcionando en Hyperspin
      hasta que comenzó a ocurrir como pueden ver he jugado bastante este titulo. luego del fade me salio este error, presiono escape y me doy cuenta de que el juego inicia pero quedo detrás del fade y no en fullscreen, cierro la ventana de mame regreso a Hyperspin trato de iniciar el juego otra vez y funciona. me di cuenta de que ocurre cada vez que abro un juego por primera vez (desde que enciendo la computadora). esto no pasaba antes, hice la prueba de quitar el fade y ocurre igual, siempre funciona a la segunda oportunidad. alguna idea?




       
       
×