Jump to content
Welcome Guest!

Join us now to get access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, and so, so much more. It's also quick and totally free, so what are you waiting for?

jevansoh

Keyboard and Joystick randomly become unresponsive

Recommended Posts

If you just have one or two systems, then you don't need to use MainMenuChanger at all. 

MMC is for folks like me who have 75+ systems (or at least several...more than 2) who want multi-level menu support.

For instance, instead of HyperSpin showing all the wheels at once, I now have categories that show up as my main menu...I have All systems, (So I can still see all of them at once if I want), Arcades, Consoles, Handhelds, Computer Systems, and Pinball.  Then when I go to one of those categories, I see just the relevant entries. 

It makes for a much tidier and neater appearance instead of scrolling through 75 wheels to find what you want.

I don't think it'd be useful for you at all with just two wheels, though.

Thanks,

--J

Share this post


Link to post
Share on other sites

How do you remove an entry?  I want to try what you suggested because I don't use those two keys anyway.  Right now they're populated with "u" and "v" respectively, but I tried pressing delete and backspace and it just saves those keys as the new hotkeys.  How do I remove them completely to make the entries blank?

Share this post


Link to post
Share on other sites
3 minutes ago, jevansoh said:

How do you remove an entry?  I want to try what you suggested because I don't use those two keys anyway.  Right now they're populated with "u" and "v" respectively, but I tried pressing delete and backspace and it just saves those keys as the new hotkeys.  How do I remove them completely to make the entries blank?

Just click “set” you’ll then get the red txt “press a key” then close HyperHQ.  Open it again and the box will be cleared.  Then do the same again to clear the other one...

Share this post


Link to post
Share on other sites
9 minutes ago, jevansoh said:

If you just have one or two systems, then you don't need to use MainMenuChanger at all. 

MMC is for folks like me who have 75+ systems (or at least several...more than 2) who want multi-level menu support.

For instance, instead of HyperSpin showing all the wheels at once, I now have categories that show up as my main menu...I have All systems, (So I can still see all of them at once if I want), Arcades, Consoles, Handhelds, Computer Systems, and Pinball.  Then when I go to one of those categories, I see just the relevant entries. 

It makes for a much tidier and neater appearance instead of scrolling through 75 wheels to find what you want.

I don't think it'd be useful for you at all with just two wheels, though.

Thanks,

--J

Wonder how I could merge the two weeks into 1?   Someone mentioned an app a while back but I can’t remember what it is?  It’s one that searches all systems when you type for a specific game etc but I looked at the tutorial video and it looked complicated.....    I’ll remember in a min what it was ?

Share this post


Link to post
Share on other sites

That worked like a charm.  Thanks!

As for merging two wheels, I'm not familiar with anything that does that.  If you remember, let me know.  Sorry I can't be of more help.

Share this post


Link to post
Share on other sites

Ok so annoyingly mine did it again!  Ffs.  

So ive now removed the skip up skip down keys altogether and this seems to have cured it but I’ll test some more. 

Only thing is I can’t now skip through the wheel A-Z but that doesn’t bother me. 

I’ll report back if it does it again or I know for sure it’s cured it. Pretty sure it has...

Share this post


Link to post
Share on other sites

What do you mean you can't skip through the wheel a-z?

I can still skip forward/backward and hold down the arrow to choose by letter.  Is this what you mean?  That functionality shouldn't have changed by removing what we removed.

Share this post


Link to post
Share on other sites

It didn’t the first time as I’d just removed the skip numbers but mine froze again so I removed also the skip up/down 

now I can only rotate the wheel up and down as usual and not skip letters as it seems to lock up when scrolling the wheel up or down and pressing left or right at the same time. 

Ive tried moving the wheel again vigorously up/down entering and exiting from games really quick and it doesn’t seem to lock up now so it looks like it’s cured it which I’m ok with.  I’ve got the wheel moving quite fast so it doesn’t take long to scroll through all the games anyway. 

The only controls I’ve got set now on hyper hq are rotate wheel up/down, enter, exit etc.  

I’ll keep my eye on it.  

Share this post


Link to post
Share on other sites

Can I install this and basically leave hyperspin as it is?  I only have 1 wheel as I’m only using mame 

ive followed the option 3 written tutorial... 

ive gone down as far as “create a subwheel”.   Haven’t gone any further as I don’t want any subwheel or anything, just one wheel with mame which I’ve done and named it Arcade...  started up Hyper HQ and it’s there in the drop down menu  

Will this be running now?  I’ve notice the games startup and shutdown much faster

Share this post


Link to post
Share on other sites

Hmmm.. I honestly don't know.  I don't think it will have anything to do, with only one wheel.  It's really meant to create "sections" for multiple wheels.  But I don't see why you can't have just one wheel.  I honestly just don't know for sure.  Someone else will hopefully chime in.

Share this post


Link to post
Share on other sites

With only one wheel you will never get the refresh of HS you are looking for... as it is shut down and restarted as you change wheels.

Sent from my SM-A520W using Tapatalk

Share this post


Link to post
Share on other sites

Dam, that’s a shame.  Was hoping this would cure it.   

Must be another way...   Is this a bug with hyperspin itself?  Wondered if it was maybe a rocket launcher issue.   I know you can turn hyperlaunch off in hyperhq.   Or is that something completely different.  

Is hyperspin kept open in the background when a game is running and not shut down and restarted every time?  

Just clutching at straws here I guess

Share this post


Link to post
Share on other sites

Just wondering wondering...  does everyone set the emulator exit key in rocket launcher?  If so which key?

just noticed mine wasn’t set to anything.  I’ve set it to ESC and let it run for hours, then started loads of games up and exiting them one after the other, moved the menu around a lot and can’t get it to lock up so wondering if rocketlauncher wasn’t exited correctly and was causing some sort of conflict and making hyperspin controls lock up?

As it seems to happen after exiting games 

Share this post


Link to post
Share on other sites

My exit emulator key has always been set to ESC.  If it isn't set, I can't exit emulators at all.  I tried removing the key and I literally cannot exit at all, so I'm surprised you can without it.

Share this post


Link to post
Share on other sites

Yeah I am now you’ve said that. 

I think from memory I removed it as I had an issue a while back where it was freezing on exit so I found a thread on here which gives you the exit script to modify in rocketlauncher and that stopped it. But it looks like I never set the exit key back up

Share this post


Link to post
Share on other sites

Ok so an update...   I set the exit emulator key as above to ESC (same as hyper hq and mame) 

it hasn’t as yet Locked the controls up at all!

but..  I’ve noticed that the controls on the player 1 joystick (mapped to cursor keyboard keys) started becoming occasionally erratic.  RIGHT on the joystick wouldn’t work intermittenty at the time I noticed this,  it worked, then it didn’t, then it did two clicks etc.  Nightmare for side scrolling games!  

After checking joystick switches, wiring, led status on the iPac, all GND wires etc, everything is fine. Tested this over last few days and it kept doing it randomly so I’ve disabled “keyboard delay” as this problem only happened with the player 1 joystick, not player 2 and as the keyboard delay function only affects the player 1 joystick I wondered if this would make any difference and it has!  

So far so good.  Left it running for hours with a game running and also in attract mode and no lock ups of the controls and hopefully that’s also sorted the intermittent erratic joystick problem.  

Anyone else had this joystick problem?   Can’t seem to find anything conclusive  

 

 

Share this post


Link to post
Share on other sites

Anyone else find a solution to this?  

Windering if this has been fixed in the new version as it’s driving me crazy.  

Also,  has anyone noticed if this problem still happens if attract mode is switched off?  

Share this post


Link to post
Share on other sites

STILL messing with this as there’s no pattern to it as it seems to freeze randomly.  

Checked all the artwork files and themes to try and see if there’s any dodgy files in there as gigapig suggested on another post it could be either a bad video clip, artwork file or something that’s causing it but only found 1 video clip that wasn’t mp4 so deleted it and a theme that was huge compared to the rest (can’t remeber which game it was, just sorted them into size order and it came up) so delete that  

but so far hasn’t seemed to make any difference.  I can’t even make the lockup happen when I want to, It happens when other people are playing so I’ve no idea if they’re pressing multiple buttons that may cause it but I’ve tried banging all the buttons randomly when starting a game, scrolling the menu and exiting...   and I can’t get it to do it.    I’ve disabled some of the background in hyper hq and disabled the game wheel sounds too...  hasn’t really made a difference.  

Wondered if there was just too much artwork and sound going off at once in the menu for the pc to handle.  

Wondered about disabling RL but not sure how you do this?

Share this post


Link to post
Share on other sites

I kept having this random issue with it locking up, usually when i would exit a game and go back to hyperspin then after a few seconds of scrolling, nothing would respond and i would have to alt+f4 to get out of hyperspin.

So I started writing down everytime it happened and exactly what i was doing at the time. No matter what i couldnt reproduce it when i wanted to, it seemed random. I did however notice it only happened on certain systems. I compared the systems it happened with the systems it didnt and i had a lightbulb moment. In RocketLauncher UI there is a setting for each system called "Suspend Frontend" and "Hide Frontend" on the systems where the issue occurred these were set to true. I set them to false and now it hasnt happened for about 3months. I tried to find this thread a few weeks ago to update it but couldnt find it. 

Would love for someone else to test this or if its just coincidence but it does make a lot of sense.

Share this post


Link to post
Share on other sites

I’ll try this now!   

So I go into RLUI and set these two to false...   

ill take a look and report back.  I’m using one system and that’s mame.  What do you have as you exit key?  I’m using ESC

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×