Jump to content
Welcome Guest!

Join us now to get access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, and so, so much more. It's also quick and totally free, so what are you waiting for?

cataclysm67

JOY2KEY issue on certain keys

Recommended Posts

Hi,

Has anyone experienced JOY2KEY not working on certain keys ?

example, I have setup a game profile for a game and left & right are set ok, but it just won't work with up & down

Up & down both work on the keyboard and also when playing the game, but for some reason Joy2Key just won't allow control of these keys.

All other buttons work fine. I had to set left and right to use number pad 4 & 6 for left and right, unfortunately numpad 8 & 4 down't work for up and down.

Any ideas, is there a setting in Joy2Key I am missing as I have had this issue on a few ancient systems previously?

ps, I have set JOY2KEY to use admin rights and also the emulator of the game (its an old apogee gameset)

Share this post


Link to post
Share on other sites

Is that a different program than JoyToKey?

You meant 8 and 2 right?

The numpad numbers need the numlock on to work... but I guess 4 and 6 wouldn't work either if it was off... 8 and 2 do work when pressing them on keyboard?

Is there a reason why you need to use the numpad numbers? You could always make P1 WASD, and P2 regular arrow keys.

 

Share this post


Link to post
Share on other sites

Hi,

Unfortunately these settings seem to be hard coded into the old emulator it uses and it has no ini file to edit or anything, so I need to use up & down.

It basically was a question of finding the keyboard keys that worked for each game and then mapping to Joy2Key.

I was saying that even though left & right arrows worked on the keyboard in game , it didn't on Joy2Key so I tried numpad 4 & 6 on Joy2Key and it worked (yes number lock on)

The set I downloaded came with xpadder settings previously and worked fine, but I was trying to get all my setup set for Joy2Key.

Not the end of the world as Apogee is an old system with 6 games, but each one works fine on all keys except up & down, very odd !!

Share this post


Link to post
Share on other sites

Makes sense to just have a program profile set up in J2K for that emu and you're done.  Provided the background process is properly set up in J2K, it's pretty much guaranteed to work.  If it's a multi-system emu (MAME, for example) where this mapping would overlap other machines, you could set up system-specific key remapping in Rocketlauncher and that might work.  I've found this doesn't ALWAYS work though, especially for PCLoader games that seem to completely override the remapping .ahk.  I hear a lot of people bail on J2K, but it's always worked great for me, and it's not like you NEED to use it for very many emus. 

Share this post


Link to post
Share on other sites

I had a similar issue some time ago with MAME and JoyToKey.
I learned that MAME uses rawinput as default to read multiple devices and to reduce lag, and since JoyToKey emulates strokes per assignation, MAME was not recognizing them.

Solved it by opening mame.ini, finding the line " keyboardprovider auto" (without the quotes), and changing "auto" for "dinput" to force it.

Hope this helps.

Share this post


Link to post
Share on other sites

I had a similar issue some time ago with MAME and JoyToKey.
I learned that MAME uses rawinput as default to read multiple devices and to reduce lag, and since JoyToKey emulates strokes per assignation, MAME was not recognizing them.

Solved it by opening mame.ini, finding the line " keyboardprovider auto" (without the quotes), and changing "auto" for "dinput" to force it.

Hope this helps.

 

Nice one Kondorito, that worked perfectly.

Such a simple change, so much for auto meaning auto :)

Share this post


Link to post
Share on other sites

Similar issue on RocketLauncher with default.

If you set global default to true for say bezels it does not always work, so you then have to set the actual system to true and hey presto it works !!

Very strange.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×