Jump to content
FrankyRizzo

Windows 10?

Recommended Posts

So my computer fried.  I built a new one and put windows 10 on it.  Has anybody tried Hyperspin on Win10 yet?  Just curious about potential bugs... I guess one of the biggest problems could be emulator support.  

Share this post


Link to post
Share on other sites

So my computer fried.  I built a new one and put windows 10 on it.  Has anybody tried Hyperspin on Win10 yet?  Just curious about potential bugs... I guess one of the biggest problems could be emulator support.

On mine HyperHQ runs until try to select a drive in browser windows within HyperHQ

Share this post


Link to post
Share on other sites

People do have it "working" in win10 so it must be doable. Still on win7 here and hearing all this stuff doesn't entice me to upgrade any time soon. You can try editing the hyperhq cfg file directly in notepad... but it seems like something more is going on.

Sent from my SGH-I467M using Tapatalk

Share this post


Link to post
Share on other sites

My Windows 10 has not come through yet, so how are you guys installing it? Is it a fresh install or an in place upgrade from 7 or 8.

 

The fact that HyperHQ crashes suggests something is missing from your HS install.

Share this post


Link to post
Share on other sites

On mine HyperHQ runs until try to select a drive in browser windows within HyperHQ

 

Run HyperHQ as administrator and / or set the compatibility mode to Windows 7.

 

Both fixed the HyperHQ crashing issue on my Windows 10 PC.   (it would crash when selecting a ROM directory - I don't use HyperLaunch / Rocketlauncher...)

Share this post


Link to post
Share on other sites

Why don't we have a "Windows 10" thread pinned?

 

If you want one other than this, create it perhaps in the support section,give it a catchy informative title, send me a link and I'll pin it.

Share this post


Link to post
Share on other sites

I fresh installed windows 10 a week or so ago and 2008 and 2010 c++ won't install so some emulators wont open. I am going to re install another version in a couple minutes to see if that fixes it.

 

Edit: I was running Windows 10 enterprise as the default system admin. I reinstalled with Windows pro using a regular user account set as admin. C++ 2008 and 2010 installed fine this time.

Share this post


Link to post
Share on other sites

Hyper HQ crashes as well for me on Windows 10 - specifically it crashes when editing the roms and video path boxes.

 

Worked fine when it was installed on Windows 8.1.

 

Edit - setting compatibility mode to Windows 7 seems to fixed it but the cursor flashes like mad when in the roms or video path boxes.

Share this post


Link to post
Share on other sites

Hyper HQ crashes as well for me on Windows 10 - specifically it crashes when editing the roms and video path boxes.

 

Worked fine when it was installed on Windows 8.1.

 

Edit - setting compatibility mode to Windows 7 seems to fixed it but the cursor flashes like mad when in the roms or video path boxes.

 

As an alternative you could edit the "System Name.ini" (found in the settings folder) and add the path etc manually.

 

EG.

[exe info]
path=
rompath=G:\Mame Roms\
userompath=false
exe=
romextension=zip
parameters=
searchsubfolders=false
pcgame=false
winstate=HIDDEN
hyperlaunch=true

Share this post


Link to post
Share on other sites

I update to Windows 10 (from 7) this weekend. Everything is working well... it was an easy upgrade.

 

I had the HHQ crash happen once, but never again. I'll set it to compatibility mode if it happens again, but otherwise all systems are a go.

Share this post


Link to post
Share on other sites

Ah so its windows 10 causing the crash, thought it was because I'm using network drive for the ROMs was causing it.

Share this post


Link to post
Share on other sites

Run HyperHQ as administrator and / or set the compatibility mode to Windows 7.

 

Both fixed the HyperHQ crashing issue on my Windows 10 PC.   (it would crash when selecting a ROM directory - I don't use HyperLaunch / Rocketlauncher...)

 

Just finished installing W10 and the first thing I tried was HyperHQ which did indeed crash when setting the Rom directory.

Share this post


Link to post
Share on other sites

Just finished installing W10 and the first thing I tried was HyperHQ which did indeed crash when setting the Rom directory.

 

Try it again?

Share this post


Link to post
Share on other sites

Try it again?

 

Have you been in a fixed it? :)

 

I had tried it several times and set compatibility as fursphere suggested but still the same. I had no time to play with it really , I let it install while I was out and since been playing Angry Birds Fight ;)

Share this post


Link to post
Share on other sites

Set the Rom directory manually in the system ini file. Why is this such a big deal?

Because its a pain in the ass, and far quicker using hyperhq when your wanting to do multiple settings and want to do it all in one place

Share this post


Link to post
Share on other sites

Have you been in a fixed it? :)

 

I had tried it several times and set compatibility as fursphere suggested but still the same. I had no time to play with it really , I let it install while I was out and since been playing Angry Birds Fight ;)

 

Ya, my initial 'fix' didn't last long.  The crash almost seems system specific to be honest.  Some systems I can add the ROM directory just fine, others it crashes instantly.  

 

I'm still messing around with it, but manually editing the .INI files is by far the quickest method.

Share this post


Link to post
Share on other sites

The Windows application 'crash dump' data points to a compatibility issues with 'windows.storage.dll' file.  I'm guessing HyperHQ is calling the directly structure / explorer with some legacy method that Windows 10 just doesn't like.

 

Unfortunately, I don't think there is much we can do about this.  BadBoyBill is going to have to recode the application for Windows 10 support most likely.

 

I did notice that the Windows 10 upgrade removed all of my Windows Defender (previously Security Essentials) exclusions.  So I fixed that, noticing that the defender executable would spike the CPU when HyperHQ.exe launched.  

Share this post


Link to post
Share on other sites

Hi guys.

I'm debating on upgrading from 8.1 to 10 on my cab. I'm concerned about emulator compatibilities as well as the FE of course. I'm running the latest HS beta as well as the most current Rocketlauncher.

Some people are saying they haven't had any problems. Others aren't so lucky.

Gigapig, did you get everything working correctly now?

Badboybill, have you tried windows 10 yet? Thoughts?

Please give me your input hyperspinners. Are there any of you who have made the switch without any issues?

Thanks in advance

Junky

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...