Jump to content
Sign in to follow this  
Yourname942

[Question] Hard Drive Transfer

Recommended Posts

I plan on getting a 4tb hard drive. However, in the meantime I want to utilize my time and start from scratch to build up a Hyperspin library on my current Hard drive.

 

My question is:

As long as both hard drives have the same directory (lets say- Drive G for example) will everything work okay once I transfer all the files over to the second drive? Thank you.

Share this post


Link to post
Share on other sites

There are a bunch of variables. If you use relative paths (such as .\, ..\, ..\..\) when you build it will be much easier to move. If you use fixed paths (such as C:\HyperSpin, C:\HyperSpin\Emulators, C:\HyperSpin\Roms) it will be a lot more work to move. This will hold true for just about everything (such as where you are installing your emulators and roms).

 

My advice for your specific goal is to create a mapped drive that points to your existing drive (G: will just point to C: in your example) and give it the letter you will assign to your new drive and install everything to the mapped drive letter. When you get the new drive copy over your data, delete the mapping and assign that drive letter to your new drive. This would be very easy and just about fool proof even if you use fixed paths.

Share this post


Link to post
Share on other sites

I plan on having everything located on drive itself. So, say the 1st HDD was set as (G:) and the 2nd HDD is (F:) I would first start from scratch and have everything, including Hyperspin, within Drive (G:)

I would eventually copy everything from HDD1 to HDD2, then wipe HDD1, and then set the HDD2 as (G:).  Now with all the files being on Drive 2, wouldn't all the paths remain pointing to (G:)? [ ie. all paths in tact and everything working the same as it did on HDD1 ] 

Share this post


Link to post
Share on other sites

Yes, that should work fine since the drive letter isn't really changing. This is assuming that you have a C: drive and it's not changing. Depending on the emulators you are running, even though you might install them on a G: or F: drive some still have files in the Windows user profile (C:\Users\<username>).

Share this post


Link to post
Share on other sites

Take a look in C:\Users\<useranme>\AppData\Local\ and C:\Users\<username>\AppData\Roaming and see if any of the names of your emulators there. By default, Windows will hide these folders so you will need to turn that off to see them.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By zanaga
      Hola como estan?
      estoy teniendo un problema con menu, baje un pack de n64 y cuando lo instalo el dibujo de anterior/siguiente juego no aparece abajo en el medio sino que esta en todo el centro de la pantalla y no se como acomodarlo (Adjunto imagen del menu al que me refiero)
       
      El otro problema que tengo es que cuando instalo los juegos del pack famicon de 550 juegos solo me reconoce 79, es la primera vez que me pasa, rehago la database y solo reconoce 79.
       
      Muchas gracias por su ayuda

    • By hawkfanz
      I use rocketlauncher to start mame64 games in hyperspin but the first game on a fresh windows startup takes 20 seconds to start.  After closing this game the next game will open almost immediately. I know others have asked this question but I can’t find a solution. I have no anti-virus running, no windows defender, no rocketlauncher fades or bezels. I updated the mame64 version to the 209 no nag from 197 no nag with no change. Any help or suggestions would greatly be appreciated!!
    • By roguen1
      Hello , i don't know if this is the correct place to post this , but i have a problem for a while that i have never figured out whats cause it , and is the fact of that in the transitions , from start to end, it appear this horizontal lines all over the screen , and it's bit annoying , i have done everything to trying to resolve this issue (update drivers , windows , download hyperspin again etc) and it still there , what could be? 
      (sorry if my english is bad)
       

×
×
  • Create New...