Jump to content
HyperSync, HyperList and FTP are now back online ×
Luvarim

Commodore Amiga Nvidia Shield TV

Recommended Posts

I confirm that all my amiga hdf and ADF are on my Shield internal memory not on my external disk or my nas.

Share this post


Link to post
Share on other sites

Hi, yes all my Amiga roms are working.

But i tried something like  350 games, for  only about 150 full  working.

Share this post


Link to post
Share on other sites

I never really got to testing these. Got sidetracked and not found time to go back to amiga

Share this post


Link to post
Share on other sites
On 9/19/2017 at 10:56 PM, thatman84 said:

I never really got to testing these. Got sidetracked and not found time to go back to amiga

I'd be interested to hear how people are doing their setups. I've still not done my Amiga wheel yet.

I have UAE4ARM, setup a profile, installed Workbench and sorted out the encrypted kickstarts. The WHDload game zips had to be decompressed in the Amiga OS, using windows to extract would break some of the games. Maybe that's why Pouteur has issues with so many games if they are WHD zips, if he gives me some examples that aren't loading I'll see if my copies are running in Workbench.

I might well abandon the system for the Shield TV. I have FS-UAE on my PC & laptop which was a breeze to setup in comparison. It does a much better job emulating and fitting the image to the screen too, I can always just Gamestream it from my PC to the Shield TV I suppose.

All the best guys, I look forward to seeing how things develop.

Share this post


Link to post
Share on other sites
1 hour ago, Honosuseri said:

I'd be interested to hear how people are doing their setups. I've still not done my Amiga wheel yet.

I have UAE4ARM, setup a profile, installed Workbench and sorted out the encrypted kickstarts. The WHDload game zips had to be decompressed in the Amiga OS, using windows to extract would break some of the games. Maybe that's why Pouteur has issues with so many games if they are WHD zips, if he gives me some examples that aren't loading I'll see if my copies are running in Workbench.

I might well abandon the system for the Shield TV. I have FS-UAE on my PC & laptop which was a breeze to setup in comparison. It does a much better job emulating and fitting the image to the screen too, I can always just Gamestream it from my PC to the Shield TV I suppose.

All the best guys, I look forward to seeing how things develop.

Check out the RetroPie Amiga WHDLoad Group facebook by Dom Creswell. That has all the info and experts. His config maker program has been updated to work for the shield configs. You point it at the whd folder, set the kick and rompaths and it makes per game configs for you. You can then launch uae4arm by pointing HS to your .uae config files

 

Its just the database and artwork to sortout after that

Share this post


Link to post
Share on other sites
14 minutes ago, thatman84 said:

Check out the RetroPie Amiga WHDLoad Group facebook by Dom Creswell. That has all the info and experts. His config maker program has been updated to work for the shield configs. You point it at the whd folder, set the kick and rompaths and it makes per game configs for you. You can then launch uae4arm by pointing HS to your .uae config files

 

Its just the database and artwork to sortout after that

Thank you BUT I don't use Facebook anymore and won't be going back to it.

It's great there is a config file maker as it makes life easier. You've made it sound like the zip files reside in the WHD folder and will be extracted on the fly. I'll put it this way...Batman the Movie (WHDload) as one example would NOT play unless I extracted it within the Amiga OS. If someone tells me they have it working with this method from Mr. Creswell then I'll investigate further when I have time.

Thanks again, I do have the Database and artwork already from my PC setup.

Share this post


Link to post
Share on other sites
On 9/22/2017 at 5:24 PM, thatman84 said:

Thank you, I have already seen that. It doesn't really help as there are no instructions for what we want to use it for. I know you suggested the Facebook group BUT I don't want to use Facebook. I do think it would be wise if the info was available here as logically this is where people will come to look for answers/support to get things working...with all the effort you've put into guides etc. I'm sure you'd agree.

SO! Can somebody please lookup/provide the settings.ini launch intent commands I will need for UAE4ARM (exe I have, parameters is more crucial). I have the .uae files made for the RPI and I have converted one manually (Batman The Movie), I've created the folders and added the files that should be needed on the Shield. Currently Hyperspin is just loading into the emulator rather than launching the game. I'm unsure if it's the missing parameters line or that I've made a mistake editing the .uae file that's doing this.

Personally I'm ok with this as is. I can just manually make a "Workbench" entry for the Amiga HyperSpin game wheel, then use the Shield as an "Amiga" to launch the WHDload games in Workbench as I have been doing. Obviously ideally we want to showcase the games and launch them directly from HyperSpin though.

Thanks in advance for any help given

Share this post


Link to post
Share on other sites

Im real rusty but i will post u what i can. It may all depend on the game files. There was an update to uae4arm that allowed for external laumching which i guess is public now. I have a beta apk.

You may want to google Ultimate Amiga for the exact "assets" they use!.

Also there is a bootloader needed not sure how that works @bippym guided me through the whole setup.

 

YES i agree a guide here would be great. I just dont know it enough to write one. And knowone else will (probably)

Share this post


Link to post
Share on other sites
52 minutes ago, thatman84 said:

Im real rusty but i will post u what i can. It may all depend on the game files. There was an update to uae4arm that allowed for external laumching which i guess is public now. I have a beta apk.

You may want to google Ultimate Amiga for the exact "assets" they use!.

Also there is a bootloader needed not sure how that works @bippym guided me through the whole setup.

 

YES i agree a guide here would be great. I just dont know it enough to write one. And knowone else will (probably)

Yes thank you, I have already been to Ultimate Amiga and done the homework. The "assets" don't use the HyperSpin naming convention so are different to what I have been using but whatever, I just want to see if this method works. I already have the version with launch intent enabled, there is talk of it being added (bippym requested it even) but I've not seen the exact commands to use....if you could provide the exe & parameter lines from your setup that would help no end.

I've put the bootloader folder on my HDD, I've edited the .uae to point to the where all the necessary folders are on the Shield. HyperSpin is launching UAE4ARM just not loading the game. Batman is showing on the wheel so it's finding the .uae file, I'm hoping it's just the parameter line I need to add to the .ini file.

Thanks again.

Share this post


Link to post
Share on other sites

this is all my folder layouts for reference.

I never properly sorted all my kickstarts but most games launch fine

Config file 1943.uae

59c81cffc8bb4_Screenshot(231).png.104875ada05bb2f31845a69629a3775c.png

 

59c81d0198709_Screenshot(232).png.1a48d14b24f5e5d9796e9c7b6069c84c.png59c81d033fd1f_Screenshot(233).png.f24282aa065801a3d3582f39e9e33d9d.png59c81d05e0d1a_Screenshot(227).png.09e678cc525522934a007ccd8562754f.png59c81d079aaf7_Screenshot(228).png.65b31af699aa73bb783d5708177e6dff.png59c81d093deea_Screenshot(229).png.e018c034e53f207902cc4c5ca1cf15dd.png59c81d0ad558c_Screenshot(230).png.701bee309afb3001eeb170878d1c2f6b.png

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, thatman84 said:

this is all I use in hyperspin

 

Commodore Amiga AGA.ini

Thank you!

I had that exe and I see you use no parameter. I've compared my edited .uae to your example, can't see I've done anything wrong there or with the folder structure. I did read something about resetting UAE4ARM to default settings for launch intent. I could try that but no doubt it will wipe away the profiles I made that launch Workbench *sighs*.

RIGHT SO! I've checked the Amiga .xml we can download from HyperList here. The names (and therefore artwork) match to the actual WHDload zips, not the WHDload folder mode (that's what you are using). I had extracted the WHDload zips in Workbench (so they don't corrupt), meaning I have the WHDload folder mode "roms" as well as the original zips.

I think I will run the config creator on the RPI with the WHDload zips I have, then these .uae files will ultimately be HyperSpin compliant hopefully. If they work (i.e load the game's WHDload zip) I will share them as Pouteur kindly shared his .uae files for loading .ADF and .HDF through RetroArch. Editing the .uae files slightly (or mimicking my folder layout) should be far easier than doing the database and artwork for other people.

Thanks again for your time and letting me see I was on track.

Share this post


Link to post
Share on other sites

As far as Amiga goes on android u CANNOT load a zipped game....the problem is, everything is named according to the zip file name...now once u extract a game u will realize the whdload folder containing all game info is named totally different from the zip folder itself.....so at this point ur only left with the option more or less to extract and rename all ur roms ...trust me it sounds crazy but it's very much doable.....another issue which I've put on hold is that not all games will have the same screen size....if u look at the uae cfg, for the hight u may have something like 240 or so.....that may be good for a game like dkong but for rtype u can go 1 setting larger.....amiga is one of the hardest systems 2 setup for Android with no easy trick or nuttin....ive started Amiga but then jumped on other projects (my problem is never being able to complete a project b4 I start another one...smh)....im now in the stages of learning Photoshop because I enjoy doing wheel art or boxart.....this video is old but as u can see, it shows how Amiga works and how the bootloader works....the small time it takes to load only happens when u load a game for the 1st time...afterwards it should load immediately

 

  • Like 2

Share this post


Link to post
Share on other sites

Thank you Sanchez! This is exactly why I asked where people were at with their setups.

I had mentioned my concern about the emulator being able to load the zips directly. I did say the folders are named differently to the zips once extracted, I also know that extracting them with 7zip, winrar etc is also a bad idea. I'd noticed the screen issue too when using the emulator, I used the vertical offset slider to centre the image better. Thank you for confirming my concerns, you've saved me a lot of time!

Honestly I can't see Amiga being used much on my Shield TV as I do have FS-UAE setup on my Laptop and PC which is a much better experience. I owned the Amiga, so for me & my friends the nostalgia kicks in more when using Workbench. I'll ditch making those .uae files (as it's not going to work) and I also won't bother renaming the rom folders. Instead I shall just create a Workbench entry manually and have that as the only "game" on the wheel, which loads UAE4ARM. I might well do the same for MS-DOS, as again for me the nostalgia kicks in when using the system as it was back in the day...with a command prompt.

Thank you both for your insights, I wish you all the best with your projects. I look forward to seeing your Artwork in the future Mike :)

Share this post


Link to post
Share on other sites

Thats sounds like i kinda cool way to do it to get the nostalgia.

 

If you do get a chance i would love to see a guide from you on this method with launching into workbench and the extraction process.

The amiga has totally intriuged me since starting the setup process. I would love to have it working

  • Super Like 1

Share this post


Link to post
Share on other sites
5 hours ago, thatman84 said:

Thats sounds like i kinda cool way to do it to get the nostalgia.

 

If you do get a chance i would love to see a guide from you on this method with launching into workbench and the extraction process.

The amiga has totally intriuged me since starting the setup process. I would love to have it working

I can upload a video of where I am at if you'd like?

It has dawned on me that it might be possible to extract the WHDload zips in the Amiga OS and for them to retain the name from the zip file,.That saves renaming them all as Sanchez mentioned. I don't understand this as surely it's just the .uae file that needs it's name complaint to the HyperSpin Database xml? The .uae files then give the commands to UAE4ARM on what files and folders to mount for each game. As long as the folder names match what's in the .uae it should load..no?

It takes a loooong time to do the extraction at "Amiga speed", I ultimately have what you have (WHDLoad Folder roms)...I just did it the hard way ;)

The WorkBench.uae file I have was actually created by UAE4ARM when I setup WorkBench (it's a custom preset), it just needs copying (to where your other game.uae files are) and editing (gui_mode=off, to auto boot into WorkBench). Thank you for your .uae example. I'm going to put a little more time into this I think. It'll be some stupid typo tripping me up...it's ALWAYS something silly ;)

I could stop now I suppose, it's a bit of a cop out just having WorkBench as the only "game" HyperSpin shows. BUT this will save HDD storage not having all the game media, it could help people out trying to keep within the 500GB capacity of the Shield TV Pro or smaller external HDDs. I may well try a similar "work around" for other troublesome systems (MS-DOS, SCUMMVM).







 

  • Like 1

Share this post


Link to post
Share on other sites

As promised...a video of where I am at so far.

It's quite long but I try and quickly cover the two methods I use, WorkBench and the WHDBoot loader with UAE4ARM. Workbench loads and I do have some games already running but I'm having some strange issues. I show creating the .uae files manually within UAE4ARM (so I can easily set the controls etc with the GUI), these .uae files load from within UAE4ARM and do work HOWEVER when renaming some of these .uae files to what the HyperSpin Database wants to see...some aren't working correctly. Odd as nothing has changed within the .uae file itself, only it's name and location to what HyperSpin needs it to be.

Hopefully it's of interest to some of you and maybe someone can help as I am getting very close to having this done now.

 

Share this post


Link to post
Share on other sites

Great video mate.

Im very tempted to drop my libretro docs project and get back to Amiga now :)

I will try and my setup going again. Would you mind dropping in a couple of UAE files and maybe write down your base controls? 

Share this post


Link to post
Share on other sites

Thx for the video! Still looking a bit too complex to setup for my own part, but im happy you are spear-heading the quest toward finding a working and practical Amiga HS setup!

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, thatman84 said:

Great video mate.

Im very tempted to drop my libretro docs project and get back to Amiga now :)

I will try and my setup going again. Would you mind dropping in a couple of UAE files and maybe write down your base controls? 

Thank you! I'm glad it was of help/interest to you :) I have edited a .uae example from the ultimate amiga collection to include "my controls" by adding the extra lines in as necessary. I am deliberately using the genuine kickstarts (from google play store's Amiga forever app) to keep this as above board as possible (I don't want to break forum rules). I know you are using different kickstart locations, so your .uae will differ from mine but kickstarts are not what's holding me up.

So, yes I can do that for you the .uae files are attached....

Port 0: Nubs as mouse. Port1: dpad as joystick
Autofire rate: Off. Mouse Speed: .5
Enable mousehack: Off. Tap Delay: Normal
Custom Control: Enabled
<A>: Joystick fire button 1. <X>: Joystick fire button 2
<B>: Return. <Y>: Space
<L>: Mouse Left button. <R>: Mouse Right button (Both of these are the shoulder buttons on the pad not the triggers)
Up: Joystick up. Down: Joystick Down
Left: Joystick Left. Right: Joystick Right

4 hours ago, lovebus5 said:

Thx for the video! Still looking a bit too complex to setup for my own part, but im happy you are spear-heading the quest toward finding a working and practical Amiga HS setup!

It's still early days, UAE4ARM for android only recently had launch intent added to it (that's what allows HyperSpin or other apps to launch UAE4ARM). So we can expect some niggles as we work things out, this method does seem the way to go though. Honestly I doubt I'll make a .uae file for every Amiga Game. Installing WorkBench honestly isn't too bad and as I can load any of the games through the "Amiga Desktop"...HyperSpin can be devoted to showcasing only the best of the games I actually would play.
 

2 hours ago, thatman84 said:

@Honosuseri if the issue continues with configs not loading correctly this is the place to report the issue.

 

https://github.com/lubomyr/uae4arm/commits/master

Thanks buddy!  Something is happening when I am copying the .uae file from the Android folder to HyperSpin's designated Amiga folder then renaming it to be HS compliant. Even if I move it back again (to the Android folder) it still doesn't work when being loaded from UAE4ARM directly. I can edit it again and save within UAE4ARM and that fixes it but although it's now named correctly...if I copy it out again... HyperSpin no longer sees it *sighs* It would be nice if UAE4ARM would let me capitalise when naming and saving *sighs*

This "method" for making them should work and it does for some games, though they appear to have shorter names...maybe it's a string length I am exceeding so the full folder path isn't being set? I have seen that they are constantly adding and updating the settings of the config maker and people are suggesting alternate WHDload older names. I'm not sure if it's to shorten the name to get them working or more that online scrapers will better recognise what game it's meant to be for downloading artwork. Who knows?

All the best 

Workbench.uae

Agony_v1.3_0960.uae

Batman - The Movie.uae

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the info/files I will take a look tonight.

as for the issue I noticed I have my uae4arm config file path set to the default. Maybe you could point Hyperspin to that folder instead of copying them out.

also I believe spaces and special characters are not supported for .uae file names to launch with uae4arm.

Share this post


Link to post
Share on other sites
59 minutes ago, thatman84 said:

Thanks for the info/files I will take a look tonight.

as for the issue I noticed I have my uae4arm config file path set to the default. Maybe you could point Hyperspin to that folder instead of copying them out.

also I believe spaces and special characters are not supported for .uae file names to launch with uae4arm.

I went one better and just set the UAE4ARM conf folder to where HyperSpin is looking. Any configs I make are then stored there but still need to be renamed as I can't capitalise letters when saving in UAE4ARM...it's seriously annoying. I do realise the config maker is supposed to be "tracking" games and making adjustments for each game to make them fit the screen better etc. BUT I don't have an RPI anymore.

I spent some time making up .uae's for the more popular games last night. I found it odd that I have better success with Workbench and WHDload than I do with the WHDbootloader. I enabled the Amiga DOS screen when loading now to see the errors...I'm getting "out of variable space" WHDbooter/messagedisplay.exe failed returncode 28" on the games that were "black screening".

I'm now trying with a different WHDload folder set (i.e exactly what you have) and seem to be having more luck (makes sense as they are part of the "package" I suppose). The fact "my original set" are loading just fine in Workbench had thrown me off a bit. These "new WHDload folders" appear to work well in Workbench too which is a bonus so I can utilise both methods of loading the games.

Once I have a decent selection I'll upload another video. Thanks again for all your insights.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...