Jump to content
djdaveoc

Mupen64+AE FREE for Nintendo 64 on Nvidia Shield?

Recommended Posts

I had way too many problems with RetroArch and gave up on that app. on the Shield.  I'm using individual emulators in Hyperspin to get my systems running.  I could not find an N64 emulator in Google Play on the Shield so I assume that means none of them are certified compatible with the Android TV OS.  I logged into my Google account on my PC and downloaded Mupen64+AE FREE and told it to install on my Shield TV console.  I see the app. listed on my device now.  Is it possible to use this app. in Hyperspin on a Shield TV console?  If so, what are the settings for the .ini file?  For example the equivalent of this for the NES system in the nes.emu by Robert B.

NES.emu - NES

exe=com.explusalpha.NesEmu/com.imagine.BaseActivity

parameters=

 

If that emulator can't work on the Shield, how is everyone else playing the N64?  I'd like to avoid RetroArch at all costs due to hating the interface and problems with config. files/controllers etc.

Thanks for any help in advance.

 
 

Share this post


Link to post
Share on other sites

I'm confused why you sent that link?  The emulator I asked about and its settings are not on that page.  I don't see anything about getting N64 to run on that page.

Share this post


Link to post
Share on other sites

Cool thanks.  Not sure why I couldn't find that.  Search never seems to work for me on this site.  It would be nice if someone could add all the settings for the different systems and emulators to the sticky posted article.  That way people wouldn't have to hunt around to find what are basic setup details needed by most setting up Hyperspin for Android.

Share this post


Link to post
Share on other sites
rompath=/storage/3839-3731/Hyperspin/Emulators/Nintendo 64/roms
userompath=true
exe=org.mupen64plusae.v3.alpha/paulscode.android.mupen64plusae.SplashActivity
parameters=
romextension=n64
searchsubfolders=true

That is what I have in my ini file for the N64 system.  When I try to launch a game I get a message saying the "exe=org" line is invalid for the emulator I'm using or something similar.  Anyone know why?  I'm using Mupen64+AE FREE (N64 Emulator) by Paul Lamb.

The number in my rom path is the one shown in ES File Explorer when viewing my SD card on the Shield.  I've installed the Android M update and thought that I read that I needed to replace "sdcard1" with that number in my rom path for Hyperspin to work again.

Share this post


Link to post
Share on other sites

I thought I had tried that exe line for Mupen but I guess not.  I'm assuming it works because now when I select a game it opens the emulator to the page where you can select a game, start a game, etc.  The game I choose on the Hyperspin wheel is selected and all I'd have to do is highlight play and press enter.  However I want this wheel/system to work as all my others do if possible.  Is there a way to get the game to just auto start in the emulator when selecting it in the Hyperspin wheel?  All the other systems I've setup work this way.

Thanks in advance for any help on what will hopefully be the last detail in getting N64 to work.

Share this post


Link to post
Share on other sites

Tried both what?  Anyone have Mupen working for N64 in Hyperspin Android?  Nobody knows how to get games to auto launch?  Come on people.  Share your genious with the rest of us.

Share this post


Link to post
Share on other sites

Download the nightly version, I'm sure there was an issue with the playstore version, or use it through Retroarch :)

Share this post


Link to post
Share on other sites

Download the nightly version, I'm sure there was an issue with the playstore version, or use it through Retroarch :)

my retroarch core doesn't work

Share this post


Link to post
Share on other sites

What's your (exe=) & (parameters) line??? You really need to start messing with Retroarch, and if you mess it up just uninstall and start again :) It used to really piss me off, but now I have most things running of it, and you can do so much extra things with it :) I want to start doing set up vids for it, just haven't had much time :/

Share this post


Link to post
Share on other sites

What's your (exe=) & (parameters) line??? You really need to start messing with Retroarch, and if you mess it up just uninstall and start again :) It used to really piss me off, but now I have most things running of it, and you can do so much extra things with it :) I want to start doing set up vids for it, just haven't had much time :/

my ini settings haven't changed not sure what's wrong it's just a messed up picture. Which nightly should I pick?

Share this post


Link to post
Share on other sites

I'd just pick the latest, just checked mine and it plays but RetroArch crashes if I try and enter the RetroArch menu :/ I'll take a proper look this weekend hopefully :)

Share this post


Link to post
Share on other sites

I'd just pick the latest, just checked mine and it plays but RetroArch crashes if I try and enter the RetroArch menu :/ I'll take a proper look this weekend hopefully :)

Which exe and parameters should I use for 64ae?

Share this post


Link to post
Share on other sites

What's your (exe=) & (parameters) line??? You really need to start messing with Retroarch, and if you mess it up just uninstall and start again :) It used to really piss me off, but now I have most things running of it, and you can do so much extra things with it :) I want to start doing set up vids for it, just haven't had much time :/

I tried mupen64 and still no screen. Now psspp crashes to.

Share this post


Link to post
Share on other sites

Personally I avoid retroarch.  I had so many problems with it.  Especially the config files.  The whole program is just incredibly confusing and would be much better with about 20% of the options.  It's the most non-intuitive program/emulator I've ever used. 

Not worth the time at all until they improve it and cut out most of the unneeded garbage.  It was easier to use a different emulator for each system than to use that.  At least on the Nvidia Shield TV console it's horrible.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...