Jump to content
bluelight

Question about keyboard delay in hyperHQ.

Recommended Posts

Hey guys,

 

I am using a minipac and just got my control panel build for an arcade. I tested things out last night and I noticed that my player 2 joystick has no keyboard delay on it compared to player 1. When using the player 2 controls to navigate through the wheels... it occasionally skips two or three wheels. If you push it down and hold it, it instantly starts spinning through the wheels vs player 1 which waits a second or two before actually starting to spin through the wheels.

 

I have tested my controls and stuff... it seems to be that "keyboard delay" only applies to player 1 in Hyperspin. Is this true? I noticed the selection for it under controls in HyperHQ is only on the player 1 side. I don't understand why it wouldn't apply to both but is there any fix for this? Its mildly annoying. Thanks.

 

 

Share this post


Link to post
Share on other sites

A possible solution is to run an AHK script at startup and map your P2 up and down buttons to use the same as P1. I know I tried something similar once and it did work. I can't remember exactly how I handled it but at the top of my head I can imagine there would be a problem with the P2 controls when running games. Maby there is a way do disable the script on every game launch. Then when comming back to Hyperspin, you can have a frontend profile that handles that mapping. I hope I'm making some sense here.

Share this post


Link to post
Share on other sites

A possible solution is to run an AHK script at startup and map your P2 up and down buttons to use the same as P1. I know I tried something similar once and it did work. I can't remember exactly how I handled it but at the top of my head I can imagine there would be a problem with the P2 controls when running games. Maby there is a way do disable the script on every game launch. Then when comming back to Hyperspin, you can have a frontend profile that handles that mapping. I hope I'm making some sense here.

 

I'm afraid that is over my head a bit as far as running scripts. I have heard of AHK scripts but have no experience what so ever creating or running them. What you said does make sense though, I just wouldnt know how to begin to implement them. I don't understand why Hyperspin would only have keyboard delay for player 1 controls, considering player 2 is really just another assignment for the same controls that player 1 uses. It doesn't make any sense to me... if there is no way to change it they definitely should implement this in a patch.

 

I guess for now I am just stuck with a slippery wheel when using the player 2 controls to select games, unless anyone else has anything to add?? :/

Share this post


Link to post
Share on other sites
On 3/12/2016 at 10:42 PM, bluelight said:

 

I'm afraid that is over my head a bit as far as running scripts. I have heard of AHK scripts but have no experience what so ever creating or running them. What you said does make sense though, I just wouldnt know how to begin to implement them. I don't understand why Hyperspin would only have keyboard delay for player 1 controls, considering player 2 is really just another assignment for the same controls that player 1 uses. It doesn't make any sense to me... if there is no way to change it they definitely should implement this in a patch.

 

I guess for now I am just stuck with a slippery wheel when using the player 2 controls to select games, unless anyone else has anything to add?? :/

Hey were you able to find the answer this? I have the same issue (a "slippery" player 2 joystick).

Share this post


Link to post
Share on other sites

Also looking for a solution to this, very difficult to scroll through the wheel with second player

Share this post


Link to post
Share on other sites

Hi. I know this is an old thread but I’ve been having some issues and wondered if anyone else has had the same as I think it’s linked to this keyboard delay...

for some reason, and this is an intermittent problem,  when either in a game (mame) or in the hyperspin menu,  my player 1 joystick that is mapped to the cursor buttons (I’m using an iPac4)  for whatever reason becomes erratic.  For example,  you move the joystick right, it moves, then it doesn’t, then it moves as though you’ve clicked it twice etc...   a real problem when in any game especially side scrollers. 

So ive tested everything,  wiring, switches, checked status of the iPac,  can’t find anything wrong. Checked the keyboard mapping,  all ok.   

So ive now turned off the keyboard delay as the problem only affects player 1 stick  and it doesn’t seem to do it anymore,  so looks possibly like it’s the keyboard delay?

I cant find anything or anyone who’s had this fault, wondering if anyone’s had the same problem and if they also found it to be the keyboard delay?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By alex2005
      Is it possible to set up videos (or themes) in Hyperspin to play a longer time?
      Currently I have some nice videos I would like to play for 30 seconds for instance, before the HS wheel starts running again.
      Is this a global setting? How can I change it on Hyperspin 1.4+ with Hyperlaunch (no rocketlauncher)?
      Thank you!
    • By xul
      Anyone buy Injustice 2 for PC yet that can speak towards how the player controls are layed out?  And is two player controlls with one keyboard possible - a la IPAC friendly?  If not, any work arounds created using vjoy/ahk or anything else?
      I may buy it tonight and see what's up... 
    • By nektarios
      Hi All,
      im trying to set the screen resolution by default to 1920 x 1080, ive gone into Mame and then into default options and set up the screen size. ive also gone into HyperHQ and set it to screensize full but for some reason, when ive loaded the rom i want to play, i need to hit ALT Enter on the keyboard to make it go full size.
      does anyone know how to set this up by default?


    • By smiley2000
      I always wanted a Arcade cabinet., So I decided to build my own.
       
      Here is my Homemade Arcade Bartop Arcade
      HP Z100 i5 Motherboard 2.66Mhz
      8GB Ram
      SANDISK 120SSD HD
      Keyboard Encoder: Howler Board (sucks!!)  (Changed to iPac Ultimate OI in March)
      Buttons and Joystick from Paradise Arcade
      Arcade Template from Gameroom Designs
      Found random EPS art files on google. Very hard to file
      25 watt Amplifier / Speakers and Led lights from Parts Express.
       
      Plus 8 Months of after work time and energy.



























×
×
  • Create New...