Jump to content

Hyperspin, Windows 10, X-Arcade Tankstick....

Recommended Posts

Hi All,


so, thanks to these forums and Youtube, I was able to get my Hyperspin MAME setup working on Windows 7, and it was near flawless.  I use an X-Arcade Tankstick for my controller, which basically emulates a keyboard input via USB.

I recently upgraded to Windows 10, and now whenever I launch Hyperspin and it goes to the first "wheel"  (console/platform selector) it just spins on it's own (randomly, like in demo mode) and my joystick can no longer control it.

However, when Hyperspin is loading, I press the "ENTER" key on the controller and it jumps over the intro....so it clearly received the command.  But once it hits the platform selector wheel, it's just like it's not there...nothing works.  Not even another wireless keyboard.  However, when I do a CTRL-ALT-DEL on the wireless keyboard, windows responds immediately (which is how I'm able to exit HS)


The Tankstick is working perfectly.  I've tested it in Windows directly, and the functions/buttons work perfectly.  It also worked perfectly back in Windows 7.


Tests performed so far, and still not working:

1.  Run hyperspin as Administrator

2.  Run Hyperspin in compatability modes (Win8, Win7)

3.  Reboot

4.  compatability troubleshooter (several settings...no joy).


I googled Win10 + hyperspin, but haven't really found anything significant...many ppl say it's working fine.


Hoping you all might be able to guide me in the right direction?  Thanks in advance!





Share this post

Link to post
Share on other sites

I believe the fix for this is disabling the joystick in HyperHQ. If that doesn't work try searching the forum here. I know that there are a bunch of threads on this topic.

  • Upvote 1

Share this post

Link to post
Share on other sites

The only time I ever seen the wheel spin on its own like that is when the joystick option is enabled in hyperhq.

Sent from my SGH-I337M using Tapatalk

Share this post

Link to post
Share on other sites

Thanks for the tips...but sadly that wasn't it.  The joystick setting was not enabled.

I decided to revert my system back to windows 7....and it went back to normal...working flawlessly again.  


Will have to troubleshoot it some other day.  Thank you both for your replies and willingness to help regardless.




Share this post

Link to post
Share on other sites

The only time I ever seen the wheel spin on its own like that is when the joystick option is enabled in hyperhq.

Sent from my SGH-I337M using Tapatalk

Same here, had the wheel spinning like crazy and I disabled the trackball

Sent from my SHIELD Tablet using Tapatalk

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By jevs
      Hi all.    very new to this, but a bit handy when it comes to building stuff. 
      A good friend of mine showed me his bartop machin that he was in the process of buillding and after looking at some of the games etc (running on pi) i was wowed.    decided to have a go myself as I was off work over xmas.....so it begins...
      Had a look around the web for the kind of machine I wanted to build but nithing really caught my eye so went with a standard kind of cabinet - no sizes or plans, just a little sketch on the back of a used envelope and away we go - only consideration I had to make was the screen size.   Popped to my local currys/pc world - had a look, wanted to have 4k - but whch size?  once its bought you cant go any bigger so I figured its all or nothing so picked up a 43" 4k LG smart tv. 
      Everything was build around it, so I only had to make sure the inside dimension of the cabinet was 40" had it all built and working in about 3 days - took another 5 days or so adding bits here and there...speakers and subwoofer, foot rail, hidden draw for keyboard /mouse etc.
      all worked out great - still learning config of hyperspin but will get there in the end
      Cant wait to build the MK2 now....
      video below  - compiled from pictures i took while maing the cabinet - all put together by apple iphone lol.  
      Jevs Arcade - youtube
      Taken this morning after fitting the footrail. pretty much finished now  hope you like!

    • By zanaga
      Hola como estan?
      estoy teniendo un problema con menu, baje un pack de n64 y cuando lo instalo el dibujo de anterior/siguiente juego no aparece abajo en el medio sino que esta en todo el centro de la pantalla y no se como acomodarlo (Adjunto imagen del menu al que me refiero)
      El otro problema que tengo es que cuando instalo los juegos del pack famicon de 550 juegos solo me reconoce 79, es la primera vez que me pasa, rehago la database y solo reconoce 79.
      Muchas gracias por su ayuda

    • By hawkfanz
      I use rocketlauncher to start mame64 games in hyperspin but the first game on a fresh windows startup takes 20 seconds to start.  After closing this game the next game will open almost immediately. I know others have asked this question but I can’t find a solution. I have no anti-virus running, no windows defender, no rocketlauncher fades or bezels. I updated the mame64 version to the 209 no nag from 197 no nag with no change. Any help or suggestions would greatly be appreciated!!
    • By roguen1
      Hello , i don't know if this is the correct place to post this , but i have a problem for a while that i have never figured out whats cause it , and is the fact of that in the transitions , from start to end, it appear this horizontal lines all over the screen , and it's bit annoying , i have done everything to trying to resolve this issue (update drivers , windows , download hyperspin again etc) and it still there , what could be? 
      (sorry if my english is bad)

  • Create New...