Jump to content
ArcadePC

my roms don't work

Recommended Posts

Hi, i'm pretty new to this "Hyperspin" and i have just gotten hyperspin and rocketlauncher on my laptop, but i can't get my roms working.

So i have installed Retroarch on hyperspin and configured the  genesis and the snes emulator.

I have done all this with the help of "Simply Austins" videos on youtube,

(  

)

and i have downloaded full romsets for genesis and snes, but they had wrong names.

So i did a bit of research and found Don's Hyperspin Tools.

 

I used the rename ROMs.exe to change the names of all my roms (genesis and snes) and put 7zip= true (in rocketlauncherUI) and tried to launch a game from rocketlauncherUI,

but it didn't work.

First i got a message saying that i didn't have any extensions for the roms (or something like that) and from some othe rom i got the message saying that hyperspin couldn't find the rom exc.

And then i don't know what i did, but all of a sudden when i launched a rom the screen went black and a little bit off the screen at the bottom there was something about inputs and 

controlles, and the the creen went totally black, the laptop was on but i couldn't do anything else than push the power button to shut it off.

 

And now that happens to me every time (exept for the controller thing).

So pleeeeease HELP me someone if u can, because i can't find anywhere what to do and im stuck.

 

And feel free to ask me any questions, i'll try to answer them as good as i can.

 

Thanx in advance.

Share this post


Link to post
Share on other sites

What version of RetroArch are you using? If you're using the one that you downloaded from the video I would recommend downloading the newest stable release from RetroArch's website as the one in the video is very old.

Share this post


Link to post
Share on other sites

First i got a message saying that i didn't have any extensions for the roms (or something like that) and from some othe rom i got the message saying that hyperspin couldn't find the rom exc.

 

I had an issue like this before. I would also recommend getting the newer RetroArch as well but i believe my answer in this forum post on RLauncher.com may Help out. Screen shots were uploaded too. Its the last post(as of now) on this forum post. The only thing different is you may have to make sure your "Extensions" in RLUI are also there too.

 

 

http://www.rlauncher.com/forum/showthread.php?2902-Games-start-in-RL-but-not-in-HS-%28anymore%29

Share this post


Link to post
Share on other sites

I had an issue like this before. I would also recommend getting the newer RetroArch as well but i believe my answer in this forum post on RLauncher.com may Help out. Screen shots were uploaded too. Its the last post(as of now) on this forum post. The only thing different is you may have to make sure your "Extensions" in RLUI are also there too.

 

 

http://www.rlauncher.com/forum/showthread.php?2902-Games-start-in-RL-but-not-in-HS-%28anymore%29

 

Your posts in there aren't really going to help. If you're using RocketLauncher none of the settings in HyperHQ matter other than Execution set to HyperLaunch and PC Game disabled. All of the other settings are only applicable to what shows up on the wheel or if you're launching games through HS without using RocketLauncher.

Share this post


Link to post
Share on other sites

Your posts in there aren't really going to help. If you're using RocketLauncher none of the settings in HyperHQ matter other than Execution set to HyperLaunch and PC Game disabled. All of the other settings are only applicable to what shows up on the wheel or if you're launching games through HS without using RocketLauncher.

Oh so im doing like double the work... for no reason?. Awesome.. Thats good to know lol thanks for the heads up

 

I better stop trying to help people until i understand lol. I thought i had a grasp at it bc it worked lol but i guess some of the info could of not even been entered and it still would of worked.

  • Upvote 1

Share this post


Link to post
Share on other sites

Don't you have to rename the files inside the zip files as well as the zip files?

If that is the case, just unzip every file and then use the renaming software. Then just select all the roms and right click on them wnd choose add to archive with winrar. Then just select put each file into separate archives in one of the pages.

Share this post


Link to post
Share on other sites

Don't you have to rename the files inside the zip files as well as the zip files?

If that is the case, just unzip every file and then use the renaming software. Then just select all the roms and right click on them wnd choose add to archive with winrar. Then just select put each file into separate archives in one of the pages.

Given the extremely small size of 16-bit cartridge roms, wouldn't it be simpler to just unzip them and leave them uncompressed? I imagine the space saved by compressing those is negligible at best. Dozens of megabytes maybe?

Share this post


Link to post
Share on other sites

Don't you have to rename the files inside the zip files as well as the zip files?

If that is the case, just unzip every file and then use the renaming software. Then just select all the roms and right click on them wnd choose add to archive with winrar. Then just select put each file into separate archives in one of the pages.

 

Don's will rename the files inside for you and zip or 7z them with the correct name as well.

Share this post


Link to post
Share on other sites

Ah...didn't know it renamed the files inside the archives as well, good to know.

 

Skyhighgam3r-> I agree...no point in zipping small games...actually I don't zip any games at all...I want them to launch immediately, HD space is cheap nowadays anyway.

Share this post


Link to post
Share on other sites

Oh so im doing like double the work... for no reason?. Awesome.. Thats good to know lol thanks for the heads up

 

I better stop trying to help people until i understand lol. I thought i had a grasp at it bc it worked lol but i guess some of the info could of not even been entered and it still would of worked.

 

Yeah, if you're using RL you only need the 2 things set that I mentioned in my previous post, which should be set by default. However, if you're using the Roms Only filter (to only show games you have on the wheel) you do need to have the rompath and extensions set correctly.

  • Upvote 1

Share this post


Link to post
Share on other sites

Yeah, if you're using RL you only need the 2 things set that I mentioned in my previous post, which should be set by default. However, if you're using the Roms Only filter (to only show games you have on the wheel) you do need to have the rompath and extensions set correctly.

 

GOTCHA!!! ok bc i am using that filter and i SWORE when i didnt have that added it wouldnt load the actualy defaul theme bc it wasnt locating the roms. makes sense. so i wasnt doing TOO much extra work as i thought originally then. lol I love these forums i literally learn something like EVERY single day lol. and so much more activity on HS then RL's website prob because a lot of the same ppl are here and there lol.

Share this post


Link to post
Share on other sites

Given the extremely small size of 16-bit cartridge roms, wouldn't it be simpler to just unzip them and leave them uncompressed? I imagine the space saved by compressing those is negligible at best. Dozens of megabytes maybe?

 

 

 

Skyhighgam3r-> I agree...no point in zipping small games...actually I don't zip any games at all...I want them to launch immediately, HD space is cheap nowadays anyway.

 

 

 

I would agree with you guys,  but most Cart base emulators load Zip compressed files.

 

you don't save much space but you only need one extension  

 

 

I don't use Retroarch,  but I was under the impression that it can load  7z compressed files

again i"m not 100% sure on this I only loaded a few systems in retroarch.

 

if this is the case you don't need to enable 7z support (globaly) in RL,  you only need to enable 7z for systems that need it (disc base systems).

Share this post


Link to post
Share on other sites

OK, sorry for not posting, and for being a little slow, but now i have replaced the old retroarch with retroarch 1.2.2 i think, and then in rlauncherUI in global emulators i changed the path to the new one but now i'm getting the following:

your LibRetro_GEN dll is set to genesis_plus_gx_libretro but could not locate this file: X:\Hyperspin\Emulators\New folder\cores\genesis_plus_gx_libretro.dll

 

So i think its the new retroarch thats missing some files or then i've forgotten to change some settings but i dont know what i wrong

Share this post


Link to post
Share on other sites

and in rlauncherUI in genesis, games, the rlauncherUI does find all my games that i've renamed and i can launch them there but then i get the messages

Share this post


Link to post
Share on other sites

OK, sorry for not posting, and for being a little slow, but now i have replaced the old retroarch with retroarch 1.2.2 i think, and then in rlauncherUI in global emulators i changed the path to the new one but now i'm getting the following:

your LibRetro_GEN dll is set to genesis_plus_gx_libretro but could not locate this file: X:\Hyperspin\Emulators\New folder\cores\genesis_plus_gx_libretro.dll

 

So i think its the new retroarch thats missing some files or then i've forgotten to change some settings but i dont know what i wrong

 

That means you haven't downloaded the core in RetroArch. To do so, open RA and select Online Updater -> Core Updater, and find that core in the list. You'll have to download the core for any system you want to use in RA.

Share this post


Link to post
Share on other sites

So in the "cores" file in retroarch (where hyperspin told me the problem was), there's no files in there.

Shouldn't all the emulators be there? Can i just copy the emulators from the old one to the new one?

And i noticed that the new retroarch was missing  alot of folders that the old one had.

Should i just swap them back or copy the missing files to the new one?

Share this post


Link to post
Share on other sites

So in the "cores" file in retroarch (where hyperspin told me the problem was), there's no files in there.

Shouldn't all the emulators be there? Can i just copy the emulators from the old one to the new one?

That's why I told you to download the cores through RA. Don't copy anything from your old install, everything you need should be included in the new version you downloaded (minus the cores).

Share this post


Link to post
Share on other sites

do i have to download all separetly?

 

I can't remember if you can download all of them with one click or not (I'm sure someone else will chime in). For now just download the genesis plus core to see if you can get this system up and running.

Share this post


Link to post
Share on other sites

ok, i updated it and tried the game and this came: 

could not find"3 ninjas kick back (USA)" inside the archive with any defined rom extensions. Check if you are missing the correct rom extensions for this rom for retroarch's extensions, enable rom_match_extensions or correct the file name inside the archive.

Share this post


Link to post
Share on other sites

That sounds like you have 7z enabled but the rom file inside the zip/7z isn't named to match the database. Set 7z enabled to false and try to run the game.

Share this post


Link to post
Share on other sites

That sounds like you have 7z enabled but the rom file inside the zip/7z isn't named to match the database.

well the game: 3 ninjas kick back (example) inside of the .7z file is named: 3 Ninjas Kick Back (USA).7z for some reason, so i changed the .7z to .gen as on the other roms and i got the same message

Share this post


Link to post
Share on other sites

well i tried what you said about changing it to false, and it seemed to work.

It showed xinput controller (and other text i didn't have time to read) and then went balck.

And now none of my buttons work and i cant do anything else than to shut it down.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×