Jump to content
Sign in to follow this  
hengey

Help with my X-Arcade Dual PLEASE

Recommended Posts

Hi all,

I think this is my very first post on here, though I'm sure there will be many more once its all working, I plan to contribute a lot of artwork you way also in due time :P

So far, i've got HyperLaunch/Spin etc all working, and that is all great, however I'm having some major issues when trying to config my X Arcade Dual with emulators.

I tried to config the controls via each emulator outside of HyperLaunch, but weird things like only one button on NullDC and the directions are working? and on Snes9X I can't configure the 2nd button that is assigned to ALT.

Also, i'm having problems where me pressing a button also effects the emulator or windows, i.e if I press what might be punch, it might also open the file menu...you know? I want to disable it effecting anything other than the game.

Is there a better way to sort this out? am I missing something really obvious? or is this a big problem?

Thank you.

Share this post


Link to post
Share on other sites
Hi all,

I think this is my very first post on here, though I'm sure there will be many more once its all working, I plan to contribute a lot of artwork you way also in due time :P

So far, i've got HyperLaunch/Spin etc all working, and that is all great, however I'm having some major issues when trying to config my X Arcade Dual with emulators.

I tried to config the controls via each emulator outside of HyperLaunch, but weird things like only one button on NullDC and the directions are working? and on Snes9X I can't configure the 2nd button that is assigned to ALT.

Also, i'm having problems where me pressing a button also effects the emulator or windows, i.e if I press what might be punch, it might also open the file menu...you know? I want to disable it effecting anything other than the game.

Is there a better way to sort this out? am I missing something really obvious? or is this a big problem?

Thank you.

Unfortunately I've not used an X Arcade. The issues you are describing really don't touch on Hyperspin as such. Have you had a chat on th X Arcade forums? You would get a lot more people who have specific knowledge of that product? You might get lucky and run into someone here that also has the same setup as you. The fact that it is happening outside of Hyperspin and causes issues with windows says to me that you need to look at the X Arcade config utility and see what specific keys are setup for. Example if one key is setup for ALT and another key F when you hit both keys you will cause the emulator File menu to open. That is most likely what your issue is. Easy fix but might take a bit of research on your part. So yeah look for the config utility (or whatever it is named) and edit the keys. Most of the posts I have read say those things work straight out of the box so I am hoping you are configuring the EMULATOR first and not the X Arcade first. :)

Share this post


Link to post
Share on other sites

Hi hengey! Maybe I can help. I have an X-Arcade Tankstick, it's virtually the same as the Dual, just with a trackball. I too had the same exact issues you had, I would press a button and a file menu would open or an emulator function would change, etc. For some reason that I'll never understand the X-Arcade people mapped some of the buttons on the controller to Shift, Tab, Alt, etc. There seem to be two solutions, you can remap the buttons on the X-Arcade to send different keyboard presses or you can use Auto Hot Key to re-map the buttons that way. For example, you would change the button on the X-Arcade that usually sends 'Shift' to send, 'R' instead.

So the method I used, which is certainly less than ideal was to remap the keys in the X-Arcade itself. You can use this link to check out how to do it: http://www.xgaming.com/support/questions/15/X-Arcade%E2%84%A2+Programming+Guide

The only downside to doing it this way is that every time you power down controller it defaults back to the regular keymapping. So you need to tap the two buttons on the back on the controller twice to reload the custom key map you programmed. As far as I know, there's no way to simply have it save the custom keymap and load it automatically every time. It's not a great method, but it works for me.

The other option which I toyed with for a little while is to create the custom keymap using Auto Hot Key. You would essentially be doing the same thing, just using software instead. You can find more info about how to do this elsewhere on the forums. I actually abandoned this solution so I wouldn't really be able to help if you choose to go this route.

I hope this helps! If you need anything else PM me and I'll do my best to assist. Please note that I'm not super active in checking the forums, but I would get back to you as soon as I could.

EDIT: I just remembered, another thing you could do might be to disable hotkeys in the emulators you are using. For some emulators pressing a button like ctrl will perform a function, but you may be able to turn those hotkeys off, just a thought.

Edited by rattleheadxyz

Share this post


Link to post
Share on other sites

Thanks for the amazing replies guys, am very greatful

Rattlehead, thanks, great to have another X-Arcader on here ha, am going to try both methods a little later and see if any help. Did you get your Tankstick working with NullDC though?

Polemicist, thanks for the reply, stupidly I didn't think to check the X-Arcade site haha.

Share this post


Link to post
Share on other sites

Thanks pal, am going to sit down later and try figure it out. If I get it all working i'll post the info on how to on here also.

Share this post


Link to post
Share on other sites

I think re-programming my X-Arcade is the way forward, but I need to plug a PS2 keyboard in the back of it to do so...and i've only got a USB one here at the mo...typical ha, eBay here I come.

Edit:

I also found this

But swapping the whole keyboard around might be good for HyperSpin and Emulators etc, but when you wanted to use your keyboard to edit game lists etc and just generally use Windows it would be a pain having everything all muddled up? wonder if you can save keyboard profiles and swap between them etc...might try this while waiting on PS2 keyboard.

Edit 2:

Also checking out this like you suggested http://www.autohotkey.com/

Edited by hengey

Share this post


Link to post
Share on other sites

Yeah I know. HDMI cables are the worst. Stores charged from $100 to $300 AU for a cable that I could get from uglycables on eBay or directly from the local Aussie store Shelby Acoustics for $45 including shipping. It was a joke.

Share this post


Link to post
Share on other sites

Yeah when I got my new TV they tried to charge me insane money for a HDMI cable that has a higher transfer rate for 3D etc, I found it for 10% of the price on eBay when I got home.

Share this post


Link to post
Share on other sites

I'm having a very weird problem...

I've got everything working fine in certain places, but not where it counts.

When I run the emulator all works fine keymap wise.

When I run a game through hyperlaunchHD all runs fine.

But then for some reason in HyperSpin the direction keys for P1 and Player 1 coin buttons change to the default?!

I can't figure out where Hyperspin could be changing whats in Hyperlaunch, or if I'm missing something in Hyperlaunch?

Share this post


Link to post
Share on other sites

Hmmm, that is strange. The rule of thumb, as I have understood it, has always been that if it runs correctly in HyperLaunch it will run the same in HyperSpin. Which method did you ultimately use to remap the keys?

Share this post


Link to post
Share on other sites

Ah actually, is working fine on emulator but NOT in HyperLaunch now.

I got the official CFG file from X-Arcade and put in the MameUI controllers folder and works, but something in HyperLaunchHD is overwriting it?

Also, do you guys have a Hyperlaunch folder with normal HL, then inside that you have the HyperLaunchHD dir with that inside there? just wanted to check that is right also.

But yeah, control overwriting? weird...

Share this post


Link to post
Share on other sites

I gotcha. Well, admittedly I'm still using the old HyperLaunch in my rig (it's 90% complete and I didn't see the need to upgrade) so I may have something different on my end, also, I'm at work now and can't check it out. But when I get home I'll take a peek and let you know.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...