Jump to content

Recommended Posts

Is there an installation script I can use instead of following the 31 steps manually?

Thank you

 

No.

 

The hyperspin install takes 3 steps.

The rocketlauncher install takes 14 steps.

Installing mame with rocketlauncher takes 9 steps.

Installing mame with hyperspin takes 3 steps.

 

Steps 30 and 31 are not actually steps; they are more like hints.

 

There are 4 programs used in the install with 4 different owners that would all need to allow their programs to be put in an install script. In other words don't expect any official one anytime soon.

 

By the way, there are typically more than just 31 steps to get hyperspin and other emulation frontends to the point of running games. This is just the tip of the ice object in the ocean.

Share this post


Link to post
Share on other sites

Really good guide. Only one point:

add advise to give to Hyperspin, HyperHQ, rocketlauncherUI and rocketlauncher  admin rights ("run as admin" in file properties).

 

I immediatly got my config working only after giving admin rights to quoted  *.exes

Share this post


Link to post
Share on other sites

Really good guide. Only one point:

add advise to give to Hyperspin, HyperHQ, rocketlauncherUI and rocketlauncher  admin rights ("run as admin" in file properties).

 

I immediatly got my config working only after giving admin rights to quoted  *.exes

 

Which operating system is this on?

What troubles caused you to give it admin rights?

Where did you install it?

Share this post


Link to post
Share on other sites

Which operating system is this on?

What troubles caused you to give it admin rights?

Where did you install it?

Windows 10 x64

Could not launch RL from HS without giving admin rights to both of them (= was unable to launch a game from HS)

Both on drive F: (not system drive) : hiperspin and rocketlancher folders

Share this post


Link to post
Share on other sites

Windows 10 x64

Could not launch RL from HS without giving admin rights to both of them (= was unable to launch a game from HS)

Both on drive F: (not system drive) : hiperspin and rocketlancher folders

 

Is drive F a local or network drive?

Share this post


Link to post
Share on other sites

Is Hyperlaunch still any good or do we need to run rocketlauncher?

 

That's the only thing I'm confused with.

 

Right now it is better to go with rocketlauncher because it has active development. HyperLaunch supposedly still has active support but to be honest I haven't seen any development on it ever since the creator of RocketLauncher left the HyperLaunch development team.

Share this post


Link to post
Share on other sites

Hey guys,

 

I had to reinstall everything this past weekend due to a problem, I followed this guide and I'm still having a problem with MAME, I downloaded the latest version 0.166 and the proper roms, when I run a game from mame ui all looks good but when I do it from RL I get this message:

 

post-66076-0-82318200-1445005028_thumb.jpg

 

So apparently MAME is launching but it's not actually running the rom I'm trying to. I have also set the settings to "rom only" as usual.

 

Any Ideas what could be the problem?

 

Thanks guys!

 

Share this post


Link to post
Share on other sites

No.

 

The hyperspin install takes 3 steps.

The rocketlauncher install takes 14 steps.

Installing mame with rocketlauncher takes 9 steps.

Installing mame with hyperspin takes 3 steps.

 

Steps 30 and 31 are not actually steps; they are more like hints.

 

There are 4 programs used in the install with 4 different owners that would all need to allow their programs to be put in an install script. In other words don't expect any official one anytime soon.

 

By the way, there are typically more than just 31 steps to get hyperspin and other emulation frontends to the point of running games. This is just the tip of the ice object in the ocean.

If i have the "HyperSpin 1.4 Mame 0.166 build v1.01", I don't necessarily had to go thru most of the installation steps here right.....besides configurations with RL?  Cuz i'd noticed after i'd unzip the 4 parts zip files.....all the files are in the right places. And HS FE works when i run it.....minus the roms.  I'm trying to do a fresh installation.

Share this post


Link to post
Share on other sites

If i have the "HyperSpin 1.4 Mame 0.166 build v1.01", I don't necessarily had to go thru most of the installation steps here right.....besides configurations with RL?  Cuz i'd noticed after i'd unzip the 4 parts zip files.....all the files are in the right places. And HS FE works when i run it.....minus the roms.  I'm trying to do a fresh installation.

If you're doing a fresh install, then why would you want to skip steps? That makes no sense to me. Why wouldn't you want to do it all and do it right the first time?

EDIT: Ah, unless you mean you're using an install that is already partially completed for you?

Share this post


Link to post
Share on other sites

If you're doing a fresh install, then why would you want to skip steps? That makes no sense to me. Why wouldn't you want to do it all and do it right the first time?

EDIT: Ah, unless you mean you're using an install that is already partially completed for you?

I guess so? I think?  I'd downloaded the HS 1.4  build 0.166 with Mame included files from the Platinum downloads.  And it seems like HS & RL files was installed automatically when i'd unzipped it to my "C" drive.  I hope that's what the creator was trying to achieve. If not, then back to post #1 it is :)

Share this post


Link to post
Share on other sites

I guess so? I think?  I'd downloaded the HS 1.4  build 0.166 with Mame included files from the Platinum downloads.  And it seems like HS & RL files was installed automatically when i'd unzipped it to my "C" drive.  I hope that's what the creator was trying to achieve. If not, then back to post #1 it is :)

 

First off I created the two preset builds for Platinum users, they should be pretty much ready to go other than adding your ROM path and setting your controls in Mame. So I'm confused why you are posting here, are you setting up from scratch or do you have issues with the build?

If you have a problem with the build then please post on the thread for that particular build. Thanks.

Share this post


Link to post
Share on other sites

Sorry.  It was kinda half/half trying to understand the installation process now that i got the 0.166v....thanks for clearing that up.

 

EDIT:  Just found the discussions for Platinum members.  Didn't know it has its own separate talk.

Share this post


Link to post
Share on other sites

Hi to all .....
I'm new to the Site and would like a help .....

I have 8core with 16 ram PC ...... but I have 120 GB SSD .......

The problem is that installers simulators Cannes but you can not run them by HyperLanch ....... when you select NORMAL ....
 and of course the Path of simulator ......

It turns out I did not find the Path ...... C: \ HyperSpine \ HyperLanch \ MAME \ MAME.xml while there in the second disk D: ......
space reasons !!!
Copy and one same in C: with only the xml from the simulators but nothing ...

There's no way to build HyperLaynch sees to the second hard ie .... D: \ HyperSpine \ HyperLaunch \ MAME \ MAME.xml
 

Share this post


Link to post
Share on other sites

I'm stuck on step 9 where it says to rename Global Emulators (example).ini that's inside the RocketLauncher>Settings folder. That file doesn't exist or is not present. Has a new version come out and changed something but the original post wasn't updated? I feel as though I did everything else correctly up until this point.

Share this post


Link to post
Share on other sites

I'm stuck on step 9 where it says to rename Global Emulators (example).ini that's inside the RocketLauncher>Settings folder. That file doesn't exist or is not present. Has a new version come out and changed something but the original post wasn't updated? I feel as though I did everything else correctly up until this point.

Do you have a GlobalEmuators.ini file?

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Do you have a GlobalEmuators.ini file?

Sent from my iPhone using Tapatalk

Nope. I have a FrontEnds file, a FrontEnds(Example) file, and a RocketLauncherUI and RocketLauncherUI(Example) file. 

Share this post


Link to post
Share on other sites

Nope. I have a FrontEnds file, a FrontEnds(Example) file, and a RocketLauncherUI and RocketLauncherUI(Example) file.

Have you opened the setup utility RocketLauncherUI yet? If not, open it and it will check for updates. It should pull down missing files during that process.

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By zanaga
      Hola como estan?
      estoy teniendo un problema con menu, baje un pack de n64 y cuando lo instalo el dibujo de anterior/siguiente juego no aparece abajo en el medio sino que esta en todo el centro de la pantalla y no se como acomodarlo (Adjunto imagen del menu al que me refiero)
       
      El otro problema que tengo es que cuando instalo los juegos del pack famicon de 550 juegos solo me reconoce 79, es la primera vez que me pasa, rehago la database y solo reconoce 79.
       
      Muchas gracias por su ayuda

    • By hawkfanz
      I use rocketlauncher to start mame64 games in hyperspin but the first game on a fresh windows startup takes 20 seconds to start.  After closing this game the next game will open almost immediately. I know others have asked this question but I can’t find a solution. I have no anti-virus running, no windows defender, no rocketlauncher fades or bezels. I updated the mame64 version to the 209 no nag from 197 no nag with no change. Any help or suggestions would greatly be appreciated!!
    • By roguen1
      Hello , i don't know if this is the correct place to post this , but i have a problem for a while that i have never figured out whats cause it , and is the fact of that in the transitions , from start to end, it appear this horizontal lines all over the screen , and it's bit annoying , i have done everything to trying to resolve this issue (update drivers , windows , download hyperspin again etc) and it still there , what could be? 
      (sorry if my english is bad)
       

×
×
  • Create New...