Jump to content
Sign in to follow this  
qwerty89

HyperSpin for N64 in Nvidia Shield TV: not working after 5h of working on it

Recommended Posts

Hello everyone, this is my first post. My goal is to emulate N64 on myShield TV device, nothing else.

 

So, I've been trying for 5h to make HyperSpin work on my Nvidia Shield TV, and I'm about to give up. To start, I'm going to list all what I did so that we can eliminate a few error factors from me:

 

-I first tried to run Retroarch (nightly build from their website) with my N64 roms (I didn't forget to download N64 core, etc.), only to have the games start and start with a black screen and a few bit of game sound sometime. I later learned in the forums that the N64 core from Retroarch is down for now. 

-Then I went for HyperSpin. I watched Simply Austin videos on how to setup HyperSpin with Rocketlauncher, how to upgrade HyperSpin 1.3.3 to 1.4, his Setup video to run N64. So I had HyperSpin working perfectly on my computer with N64 games. 

-From that I changed the ini.files in the Settings for the ones of Android. I installed Retroarch and HyperSpin on my shield from Google Play store.

-I followed this guide (http://www.hyperspin-fe.com/topic/9226-how-to-set-up-hyperspin-on-the-nvidia-shield-beginners-guide/), copied the HyperSpin folder on my shield. It didn't work (roms not found)

-The N64 roms are not zipped, then I read about changing the path of the roms in the N64.ini files so that they match

 

And then I see that in the download section of this website there is 2 patches for android, and I'm getting really confused as to what I'm supposed to do because I see about 25 different things I'm supposed to change in a certain order to make it work.

 

So my question would be: how do I make N64 roms run on my Nvidia shield TV?

 

Thank you (a guy getting confused by the amount of information to make it run)

 

EDIT*** N64 roms are now working with Mupen64AE, you should use this until the core for the N64 is fixed for Hyperspin***

Share this post


Link to post
Share on other sites

Sorry I can't help more but You need the mupen64 emulator for your shield.

Unzipped roms and get them to work with the my pen emulator before moving on to hyperspin.

Share this post


Link to post
Share on other sites

I try both nightly and regular and they both load in menu. This crap is getting old.it also says can't load iso

Share this post


Link to post
Share on other sites

Not sure I understand about "can not load iso" N64 doesn't use disk images.

I'm getting same error

Share this post


Link to post
Share on other sites

I'm using mupen64 alpha from a few months ago, and it's working well. I haven't used the newest, but I'll check it out to see if I get the same error since I know everything else is setup correctly. You should definitely make the developer aware of the issue - they can't fix what they don't know is broken

Share this post


Link to post
Share on other sites

It would be best if retroarch would fix N64 core but it is broken right now.

In the meantime, you can use Paul's mupen64 emu but then you'll need to unzip roms (and change file extension in the .ini.

Share this post


Link to post
Share on other sites

It would be best if retroarch would fix N64 core but it is broken right now.

In the meantime, you can use Paul's mupen64 emu but then you'll need to unzip roms (and change file extension in the .ini.

now wonder I had mine zipped. Sting has his zipped though

Share this post


Link to post
Share on other sites

My ROMS are zipped and unzipping them isn't worth it to me RIGHT NOW.   I'm waiting for mupen64 to add .zip support OR for retroarch to fix their bug.

Share this post


Link to post
Share on other sites

I tried a few unzipped and it loaded. I just don't like the loading in menu and exiting in menu.

Share this post


Link to post
Share on other sites

I tested the latest mupen nightly and all is wel (noticed the addition of being able to add hi-res pack zips from within app)

Share this post


Link to post
Share on other sites

Hello guys and thanks for the replies. So to recapitulate:

 

- The N64 core from Retroarch is down, so we cannot use it right now

 

-I'm told to use Mupen64 (from the Google play store), however I cannot find it in the shield TV Google play store (is it available?). I can find it on my computer, but it doesn't appear with the Shield TV (same for Thatman84 apparently). Is it possible to copy the app on a usb key and transfert that to the Shield?

 

-If I install Mupen64, I need to change the ini files so it point to the correct location of the ROMs (thanks to Sting for the lines of codes and the video, but I need Mupen64 before) and unzip the ROMs (which I already did).

 

So if someone who has Mupen64 running on a Shield TV (very important here, not the tablet or gamepad), could someone write the general lines of what he did (copied Mupen64 from the computer to the Shield TV, changed this line, etc). 

 

Thank you!

 

EDIT: Oh wait, I can install Mupen64 on my shield from my computer. My bad. So I will install it and try your settings from your video, will give news!

Share this post


Link to post
Share on other sites

Good news, Mupen64AE build from the 17/04 worked perfectly, no change needed. Just installed the apk and copied my ROMs unzipped on my shield, made Mupen64 scan the right folder and it was working.

  • Upvote 1

Share this post


Link to post
Share on other sites

Looks like the retroarch mupen64 core is back working again. Haven't tested it yet. Video needs to be set to dynamic recompiler

Share this post


Link to post
Share on other sites

Tested and it works finally :) If anyone hasn't already, I'd update your Mupen 64 core, and then Never update it again :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By thatman84
      This is the start of the WIP guide and Amiga Project thread
      DONT REPLY TO THIS THREAD
      REPLY TO THIS ONE(clicky)
       
      For now this will become a tempory guide to UAE4arm setup with the Ultimate Amiga Raspberry Pi Project a helpful source of information in google
      Step 1 - Install Uae4arm (beta)
      You need to follow this link to sign up to be a beta tester to gain access to the apk that can launch games directly from Hyperspin.
      https://play.google.com/apps/testing/atua.anddev.uae4arm
      Link above taken from the English Amiga Board and the post below
      http://eab.abime.net/showpost.php?p=1158186&postcount=349
       
      Step 2 - Install Kickstarts
      WIP
       
      Database taken from this thread post
       
      More to follow
       
      Amiberry Android progress threads
      https://github.com/midwan/amiberry/issues/206
      https://github.com/midwan/amiberry/issues/241
    • By StevieMac
      Hey Guys I know this isn't really a Hyperspin problem but I was hopeing someone has set up their PS3 controller on the shield without the problems I'm having.

      I can get the pad working fine with everything plugged in or using Bluetooth (HyperSpin, KODI, etc) but the red lights are constantly flashing (trying to link to something?) if I turn off my Shiled the lights carry on flashing until the battery dies in the controller.
      Is this normal?
      When I turn on the Shield TV after the lights go out (the following day) I have to re plug in the controller using the USB & re connect it all over again which is a pain each time I want to use it as a normal navigation control.
       
      Thanks for the help
×
×
  • Create New...