Jump to content
SuperSlayer

HyperSpin won't launch NES games

Recommended Posts

Greetings,

 

I've run into an issue that I cannot seem to figure out. When launching a .NES game through retroarch (July 17 2016 build), there are no problems, the game launches fine. When I launch the game through rocketlauncher indicating to use retroarch as the emulator, again no problems. Through Hyperspin, I can select the Nintendo Entertainment System platform, be shown the list of existing games (no problems here so far) and after that, when I press enter on my keyboard, nothing happens. I suspect an AHK file issue but I cannot be sure. At first launch, I got an error message saying the nintendo entertainment system.ahk file did not exist, so i created one (copy actually from another ahk file present in the dir) and renamed to to exactly what it was looking for.

 

My HyperHQ NES settings are exactly in line with all my other working emulators, paths and such through Hyperspin.

 

please advise.

Share this post


Link to post
Share on other sites

If nothing happens when you select a game it means that HyperSpin isn't properly configured to use RocketLauncher. Ensure that you're using HyperSpin 1.4 and the Hyperlaunch_Path in your HyperSpin/Settings/Settings.ini is pointing to your RocketLauncher.exe. Also make sure that the Execution for all systems in HyperHQ is set to HyperLaunch.

Share this post


Link to post
Share on other sites

 Verified using HyperSpin 1.4, and correct paths, launcher settings and emulator settings. My other emulators all work fine through HyperSpin via RocketLauncher and straight from RocketLauncherUI. Any other ideas?

 

*i'll get a image up soon for verification*

 

My 'copied' AHK file with only the file name changed from Nintendo Entertainment System (Jnes 1.0.2 Acidnine 1.1).ahk to Nintendo Entertainment System.ahk

; Nintendo Entertainment System
; Jnes 1.0.2
; by Acidnine
; 1.1
;
; Notes:
;
; The main thing this emulator is lacking in is command-line
; customizability. Which is why I made this...
;
; Emulator has no exit bind. So it will use HL built in one.
;
; For full-screen settings open Jnes:
; Options -> Video -> Go full screen when rom is opened
;
;----------------------------------------------------------------------------

Run, %executable% "%romPath%%romName%%romExtension%", %emuPath%
Process, waitClose, %executable%
ExitApp

CloseProcess:
Process, Close, %executable%
return

Share this post


Link to post
Share on other sites

image.jpg

 

 

 

My settings.ini file.  The Hyperlaunch_Path was missing the 'RocketLauncher.exe' at the end, but as I said, other emulators work fine, so I added it and no change to the way NES is not working 

[Main]
Menu_Mode=multi
Single_Mode_Name=MAME
Enable_Exit_Menu=true
Enable_Exit=true
Exit_Default=yes
Exit_Action=exit
Version=1.0.0.0
Last_System=Nintendo Entertainment System
Hyperlaunch_Path=C:\Hyperspin\HyperLaunch\RocketLauncher.exe

[Resolution]
FullScreen=false
Width=800
Height=600
Scanlines_Active=false
Scanlines_Image=
Scanlines_Scale=2
Scanlines_Alpha=0.1

[Optimizer]
CPU_Priority=normal
Quality=HIGH
Image_Smoothing=true
Animated_Backgrounds=true
Inter_Backgrounds=false
Level1_Backgrounds=true
Level2_Backgrounds=true
Level3_Backgrounds=false
Level4_Backgrounds=false
Special_Backgrounds=true
Wait_For_Special=false
Animated_Artworks=true
Level1_Artworks=true
Level2_Artworks=true

[IntroVideo]
Use_Intro=false
Stop_On_Keypress=true

[Sound]
Master_Volume=100
Video_Volume=100
Wheel_Volume=20
Interface_Volume=100

[AttractMode]
Active=false
Time=60
MaxSpinTime=10
HyperSpin=false
Wait_For_Video=false

[Keyboard]
Key_Delay=true

[P1 Controls]
Start=13
Exit=27
Up=38
Down=40
SkipUp=37
SkipDown=39
SkipUpNumber=70
SkipDownNumber=86
HyperSpin=32
Genre=71
Favorites=76

[P2 Controls]
Start=69
Exit=81
Up=87
Down=83
SkipUp=65
SkipDown=68
SkipUpNumber=74
SkipDownNumber=77
HyperSpin=88
Genre=72
Favorites=90

[P1 Joystick]
Enabled=false
Joy=0
Threshold=40
Start=Button_1
Exit=Button_2
Up=Analog_Up
Down=Analog_Down
SkipUp=Analog_Left
SkipDown=Analog_Right
SkipUpNumber=Button_3
SkipDownNumber=Button_4
HyperSpin=Button_5
Genre=Button_6
Favorites=Button_7

[P2 Joystick]
Enabled=false
Joy=1
Threshold=40
Start=Button_1
Exit=Button_2
Up=Analog_Up
Down=Analog_Down
SkipUp=Analog_Left
SkipDown=Analog_Right
SkipUpNumber=Button_3
SkipDownNumber=Button_4
HyperSpin=Button_5
Genre=Button_6
Favorites=Button_7

[Trackball]
Enabled=false
Sensitivity=90


[Spinner]
Enabled=false
Sensitivity=90

[Startup Program]
Executable=
Paramaters=
Working_Directory=
WinState=
[Exit Program]
Executable=
Paramaters=
Working_Directory=
WinState=NORMAL

[LEDBlinky]
Active=false
Path=

[HiScore]
Active=false
Y=550
Delay=2
[HyperLaunch]
Last_System=Super Nintendo Entertainment System
Last_Rom=Mortal Kombat II (USA) (Rev 1)
Exit_Script_Key=~q & ~s
Exit_Emulator_Key=Esc
Toggle_Cursor_Key=t
MultiGame_Key=NumpadSub
MultiGame_Select_Key=Enter
MultiGame_Exit_Key=Esc
Path_To_Daemontools=
Path_To_CPWizard=
Fade_In_Interrupt_Keys=anykey
Keymapper_Path=
Keymapper_Profiles_Path=G:\HyperSpin\Keymapper Profiles\

Share this post


Link to post
Share on other sites

And my Nintendo Entertainment System.ini file under the HyperSpin\Settings\ folder:

[exe info]
path=G:\HyperSpin\Emulators\RetroArch\
rompath=G:\Games\NES\
userompath=true
exe=retroarch.exe
romextension=nes
parameters=
searchsubfolders=false
pcgame=false
winstate=HIDDEN
hyperlaunch=true
Per_Game_Modules=false
Skipchecks=false
Hide_Cursor=use_global
Hide_Desktop=use_global
Hide_Taskbar=use_global
CPWizard_Enabled=use_global
CPWizard_Delay=use_global
CPWizard_Params=use_global
Fade_In=use_global
Fade_Out=use_global
Fade_Color=use_global
Fade_In_Duration=use_global
Fade_Out_Duration=use_global
Fade_In_Delay=use_global
7z_Enabled=use_global
7z_Extract_Dir=use_global
7z_Delete_Temp=use_global
Keymapper_Enabled=use_global
Keymapper=use_global
MultiGame_Enabled=use_global
MultiGame_Background_Color=use_global
MultiGame_Side_Padding=use_global
MultiGame_Y_Offset=use_global
MultiGame_Image_Adjust=use_global
MultiGame_Font=use_global
MultiGame_Text_1_Options=use_global
MultiGame_Text_1_Text=use_global
MultiGame_Text_2_Options=use_global
MultiGame_Text_2_Offset=use_global
MultiGame_Use_Sound=use_global
MultiGame_Sound_Frequency=use_global
MultiGame_Exit_Effect=use_global
MultiGame_Selected_Effect=use_global
MultiGame_Use_Game_Art=use_global
MultiGame_Art_Folder=use_global

[filters]
parents_only=false
themes_only=false
wheels_only=true
roms_only=true

[themes]
use_parent_vids=true
use_parent_themes=false
animate_out_default=false
reload_backgrounds=false

[wheel]
alpha=.15
small_alpha=1
style=normal
speed=high
pin_center_width=500
horz_wheel_y=512
vert_wheel_position=right
y_rotation=center
norm_large=360
norm_small=230
vert_large=400
vert_small=240
pin_large=500
pin_small=200
horz_large=240
horz_small=150
letter_wheel_x=800
letter_wheel_y=384
text_width=700
text_font=Style4
small_text_width=260
large_text_width=400
text_stroke_size=6
text_stroke_color=0x000000
text_color1=0x00BFFD
text_color2=0xFFFFFF
text_color3=0x00BFFD
color_ratio=139
shadow_distance=0
shadow_angle=45
shadow_color=0x000000
shadow_alpha=1
shadow_blur=0

[pointer]
animated=true
x=975
y=384

[video defaults]
path=

[sounds]
game_sounds=true
wheel_click=true

[navigation]
game_jump=50
use_indexes=false
jump_timer=400
remove_info_wheel=false
remove_info_text=true
use_last_game=false
last_game=Super Mario Bros. 2 (USA) (Rev A)
random_game=false

start_on_favorites=false
[Special Art A]
default=false
active=false
x=512
y=720
in=0.4
out=0.4
length=3
delay=0
type=normal
start=bottom

[Special Art B]
default=true
active=false
x=512
y=740
in=0.4
out=0.4
length=3
delay=0
type=fade
start=none

[Special Art C]
active=false
x=512
y=384
in=0
out=0
length=3
delay=10
type=fade
start=none

[Game Text]
game_text_active=true
show_year=true
show_manf=true
show_description=true
text_color1=0xffffff
text_color2=0x0099cc
stroke_color=0x000000
text_font=Style1
text1_textsize=26
text1_strokesize=7
text1_x=32
text1_y=610
text2_textsize=36
text2_strokesize=8
text2_x=30
text2_y=640

Share this post


Link to post
Share on other sites

Are you actually using RocketLauncher or are you using HyperLaunch? They're 2 completely different programs. That's definitely not a RL module you posted and your path shows the RocketLauncher.exe inside a folder named HyperLaunch.

 

Also, something to note is that if you're using RL you don't need to set the Executable in the HyperHQ settings and you only need to set the Rom Path and Extensions if you're using the Roms Only filter.

Share this post


Link to post
Share on other sites

I'm using RocketLauncher version 1.1.1.1.  The mention of "HyperLauncher" in the settings.ini file is likely stale from previous versions of the packaged HyperSpin application as there is no HyperLaunch folder in my HyperSpin dir.

 

Below is my HyperSpin log file FWIW:

07:25:55 PM |  HyperSpin Started 
07:25:55 PM |  Going windowed mode 
07:25:55 PM |  Checking for updates 
07:25:55 PM |  Update Check Complete 
07:25:55 PM |  Startup program unavailable 
07:25:55 PM |  Error intializing joysticks 
07:25:55 PM |  Menu Mode is multi 
07:25:55 PM |  Loading Main Menu.xml 
07:25:55 PM |  Main Menu.xml successfully loaded 
07:25:56 PM |  Main Menu wheel loaded successfully 
07:25:58 PM |  Loading Super Nintendo Entertainment System.xml 
07:25:58 PM |  roms_only is true, checking files 
07:25:58 PM |  Main Menu.xml successfully loaded 
07:25:59 PM |  Super Nintendo Entertainment System wheel loaded successfully 
07:26:00 PM |  Launching Game 
07:26:00 PM |  Using HyperLaunch
07:26:00 PM |  Getting Launcher path 
07:26:00 PM |  Can't find HyperLaunch, defaulting to root HyperLaunch.exe 
07:26:00 PM |  Launcher located at G:\HyperSpin\HyperLaunch.exe
07:26:00 PM |  Running Launcher 
07:26:00 PM |  Launcher Command Line is: G:\HyperSpin\HyperLaunch.exe "Super Nintendo Entertainment System" "Street Fighter II Turbo (USA)"
07:26:52 PM |  Loading Main Menu.xml 
07:26:52 PM |  Main Menu.xml successfully loaded 
07:26:52 PM |  Main Menu wheel loaded successfully 
07:26:54 PM |  Loading Nintendo Entertainment System.xml 
07:26:55 PM |  roms_only is true, checking files 
07:26:55 PM |  Main Menu.xml successfully loaded 
07:26:55 PM |  Nintendo Entertainment System wheel loaded successfully 
07:26:56 PM |  Launching Game 
07:26:56 PM |  Using HyperLaunch
07:26:56 PM |  Getting Launcher path 
07:26:56 PM |  Can't find HyperLaunch, defaulting to root HyperLaunch.exe 
07:26:56 PM |  Launcher located at G:\HyperSpin\HyperLaunch.exe
07:26:56 PM |  Running Launcher 
07:26:56 PM |  Launcher Command Line is: G:\HyperSpin\HyperLaunch.exe "Nintendo Entertainment System" "Super Mario Bros. 3 (USA) (Rev A)"
07:26:57 PM |  Launching Game 
07:26:57 PM |  Using HyperLaunch
07:26:57 PM |  Getting Launcher path 
07:26:57 PM |  Can't find HyperLaunch, defaulting to root HyperLaunch.exe 
07:26:57 PM |  Launcher located at G:\HyperSpin\HyperLaunch.exe
07:26:57 PM |  Running Launcher 
07:26:57 PM |  Launcher Command Line is: G:\HyperSpin\HyperLaunch.exe "Nintendo Entertainment System" "Super Mario Bros. 3 (USA) (Rev A)"
07:27:11 PM |  Launching Game 
07:27:11 PM |  Using HyperLaunch
07:27:11 PM |  Getting Launcher path 
07:27:11 PM |  Can't find HyperLaunch, defaulting to root HyperLaunch.exe 
07:27:11 PM |  Launcher located at G:\HyperSpin\HyperLaunch.exe
07:27:11 PM |  Running Launcher 
07:27:11 PM |  Launcher Command Line is: G:\HyperSpin\HyperLaunch.exe "Nintendo Entertainment System" "Super Mario Bros. 3 (USA) (Rev A)"
07:27:11 PM |  Launching Game 
07:27:11 PM |  Using HyperLaunch
07:27:11 PM |  Getting Launcher path 
07:27:11 PM |  Can't find HyperLaunch, defaulting to root HyperLaunch.exe 
07:27:11 PM |  Launcher located at G:\HyperSpin\HyperLaunch.exe
07:27:11 PM |  Running Launcher 
07:27:11 PM |  Launcher Command Line is: G:\HyperSpin\HyperLaunch.exe "Nintendo Entertainment System" "Super Mario Bros. 3 (USA) (Rev A)"
07:27:12 PM |  Launching Game 
07:27:12 PM |  Using HyperLaunch
07:27:12 PM |  Getting Launcher path 
07:27:12 PM |  Can't find HyperLaunch, defaulting to root HyperLaunch.exe 
07:27:12 PM |  Launcher located at G:\HyperSpin\HyperLaunch.exe
07:27:12 PM |  Running Launcher 
07:27:12 PM |  Launcher Command Line is: G:\HyperSpin\HyperLaunch.exe "Nintendo Entertainment System" "Super Mario Bros. 2 (USA) (Rev A)"
07:27:14 PM |  Loading Main Menu.xml 
07:27:14 PM |  Main Menu.xml successfully loaded 
07:27:14 PM |  Main Menu wheel loaded successfully 
07:27:15 PM |  Exit program unavailable 
07:27:15 PM |  Quiting Hyperspin 
07:27:15 PM |  Bye! 

Applying your note about execution now results in HyperSpin being in a hung state. I have to kill the process through taskmanager.  I do notice however the command line preview reads below; is this correct?

 

Again, Execution is normal and i am using full path to rom as i am using the roms only filter since I only have  a few games.

"G:\HyperSpin\Emulators\RetroArch\retroarch.exe" "G:\Games\NES\RomName.nes" 

Below is a log after making the execution change:

08:16:01 PM |  HyperSpin Started 
08:16:01 PM |  Going windowed mode 
08:16:01 PM |  Checking for updates 
08:16:01 PM |  Update Check Complete 
08:16:01 PM |  Startup program unavailable 
08:16:01 PM |  Error intializing joysticks 
08:16:01 PM |  Menu Mode is multi 
08:16:01 PM |  Loading Main Menu.xml 
08:16:01 PM |  Main Menu.xml successfully loaded 
08:16:02 PM |  Main Menu wheel loaded successfully 
08:16:03 PM |  Loading Nintendo Entertainment System.xml 
08:16:03 PM |  roms_only is true, checking files 
08:16:03 PM |  Main Menu.xml successfully loaded 
08:16:04 PM |  Nintendo Entertainment System wheel loaded successfully 
08:16:04 PM |  Launching Game 
08:16:04 PM |  Not using HyperLaunch
08:16:04 PM |  Running in normal rom mode 
08:16:04 PM |  Excecutable is retroarch.exe
08:16:04 PM |  Command Line is: "G:\HyperSpin\Emulators\RetroArch\retroarch.exe" "Back to the Future (USA).nes" 

Still no change as the roms do not start through HyperSpin, but do through the RocketLauncherUI

Share this post


Link to post
Share on other sites

You need to properly set the path you your RL exe in the Settings.ini or HS will not use RL. Your log shows that the path isn't set correctly and because it's not correct it's reverting to using HyperLaunch to launch the games. Again, execution should be set to HyperLaunch, not Normal if you want to use RL. The command line for RetroArch using normal execution is not correct anyway, you need other parameters.

 

I would advise closely following the guide here to set things up correctly.

Share this post


Link to post
Share on other sites

Thank you HyperNewbie, that did the trick. I do not however understand why only my NES did not work, and my others do.  My Dolphin for gamecube, playstation, SNES and so on, even using the same retroarch emulator without touching the settings.ini path.

Share this post


Link to post
Share on other sites
On 7/31/2016 at 10:49 AM, agent47 said:

You need to properly set the path you your RL exe in the Settings.ini or HS will not use RL. Your log shows that the path isn't set correctly and because it's not correct it's reverting to using HyperLaunch to launch the games. Again, execution should be set to HyperLaunch, not Normal if you want to use RL. The command line for RetroArch using normal execution is not correct anyway, you need other parameters.

 

I would advise closely following the guide here to set things up correctly.

Hey mate can you please help me out here, I have the same problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Honosuseri
      As we celebrate 25 years of DOOM! John Romero has brought us SIGIL, an unofficial 5th chapter to the original game. So as Retroarch's Prboom core has now been updated to support it...figured I should really add it to my Doom Classics wheel...
      Threw together a Sigil theme, wheel art and video snap. I was pleasantly surprised, that the prboom core now played the midi music natively. Doom 1&2 originally required me to add the music tracks as mp3 files. 
    • By Honosuseri
      As you probably know there is a RetroArch core to play Daphne games BUT currently it's broken! I wish the developer luck getting the official core stable.

      Thanks to @Reznnate. We now have access again to the working test core (HERE: https://drive.google.com/open?id=1frcFNWPinSkfyafsBXsnfHd46_kS1yIY). We can install this .so file through a new feature in RA, an install core option under "load cores" has been added. I've put together a video to help you peeps understand the Daphne game files and the settings required to get the games playing through RA and Hyperspin. I hope it's of help to some of you....
       
       
×
×
  • Create New...