Jump to content
Linkseo

Please help. Cant use xbox 360 controller on hyoerspin menus

Recommended Posts

Ive set up hyperspin on a 2nd pc and for some reason i cant get my 360 controller to work the HP menu. It works fine in the games just not in hyperspin. No idea of what i did differently.

In hyperhq under the controls > joystick tab, everytime i check the box "joystick enabled" it becomes unchecked when i close and go back into hyperhq.

This is the only difference i can find between my 2 pcs.

Is there something i need to do to make the joystick enabled box to stick?

Hope someone can help me. Ive waisted waaay to many hours trying to figure this out :(

Share this post


Link to post
Share on other sites

ok now that i've had a chance to cool off and look into this again, it seems that something is very wrong my HyperHQ on my other PC. Not only is it not keeping the settings i make to controls, (enable joystick box does not stay checked when i reopen Hyper HQ) The stuff in the volume tab doesnt work either. I lower the volume on some settings then i close HyperHQ. when i reopen it the settings are back to default.

Is there an option somewhere in HyperHQ that forces everything to revert to default when i close it?

or can i remove hyperHQ and reinstall it again? not sure if it comes by itself.

worst case scenario is i have to try and reinstall Hyperspin along with everything else. I'd rather not do that.

Has anyone else had this problem that hyperHQ reverts back to default settings when you close it?

If anyone can provide some info on this it would be greatly appreciated.  :wallbash:  :thumbsup:

Share this post


Link to post
Share on other sites

Just checked. Its not. How i wish it was something that simple. I even tried running as administrator. Same deal. Settings keep reverting back to default when i close HyperHQ

Share this post


Link to post
Share on other sites

Not sure why it would be doing that but if you modify the ini directly the settings should stick. Also check to make sure you made an exception for your HyperSpin folder in any antivirus that's running on your machine.

Share this post


Link to post
Share on other sites

I'll check that tonight. Where can i find the ini for hyperspin frontend?

I dont think i made an exception for hyperspin on this 2nd pc. Hmm I'll check that tonight also. Hyperspin never seems to get blocked from launching though. Hmm

Thanks for the suggestions.

Share this post


Link to post
Share on other sites

Antivirus programs and Windows Defender can cause problems with HS and HyperHQ especially so you definitely want to have your HS folder as an exception. All of the ini files are found in the HyperSpin/Settings folder. Settings.ini contains the general HS settings and all of the ini files named after systems contain settings specific to that wheel/system.

Share this post


Link to post
Share on other sites

So apparently my settings.ini file was missing altogether. How this happened? I have no clue. But i downloaded HS again. The settings.ini file is now there and everything seems to be working including my 360.

Thanks to everyone in this great forum for the help.

Share this post


Link to post
Share on other sites

It was missing? I thought you said you checked it and it was set to read/write?

Share this post


Link to post
Share on other sites

My ini file also mysteriosly vanished a couple of days ago. Very strange. I changed a setting in hyperHQ. Then the ini file ONLY contained that last setting. A while later, the ini file was gone. Not in the thrashcan or anything. Luckily I keep a backup.

Share this post


Link to post
Share on other sites

Technically mine didnt actually disappear. When i tried copying and pasting a settings.ini file from my other pc just to test it, it kept saying "do you want to replace it?" even though everytime i check its not there. Must be hidden. Weird.

Anyway i couldnt figure it out so i just redownloaded HS to get a new ini file.

Share this post


Link to post
Share on other sites
On 8/4/2016 at 11:52 PM, Linkseo said:

ok now that i've had a chance to cool off and look into this again, it seems that something is very wrong my HyperHQ on my other PC. Not only is it not keeping the settings i make to controls, (enable joystick box does not stay checked when i reopen Hyper HQ) The stuff in the volume tab doesnt work either. I lower the volume on some settings then i close HyperHQ. when i reopen it the settings are back to default.

Is there an option somewhere in HyperHQ that forces everything to revert to default when i close it?

or can i remove hyperHQ and reinstall it again? not sure if it comes by itself.

worst case scenario is i have to try and reinstall Hyperspin along with everything else. I'd rather not do that.

Has anyone else had this problem that hyperHQ reverts back to default settings when you close it?

If anyone can provide some info on this it would be greatly appreciated.  :wallbash:  :thumbsup:

go to joystick untick player 1 the click set joy id click ok then press any button on xbox 360 controller

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...