Jump to content
Sign in to follow this  
EnterNow

Mame64 HLSL Slowdown

Recommended Posts

Hi folks,

Just wondering if anyone has any advice re running Mame64 with HLSL enabled. I have it working, but when the effect is turned on, it's crippling the performance of Mame. Everything is perfect with HLSL switched off. Specs are:

Core2Duo 2.8Ghz

4GB DDR2 Ram

X1650 Pro

I see that the X1300/1900 cards are mentioned as not being able to run HLSL without severe frame-skipping, & that's fine, I'll upgrade the card. The problem is I don't know what level of card I need to be able to run HLSL properly? I don't want to spend money on something to discover it's not good enough etc. I'm looking now at a 1GB GDDR5 HD6670...would that be up to the job? Or if anyone else has any advice re gpu's, it'd be great. Cheers

Share this post


Link to post
Share on other sites

I am not familiar with your video card but you may want to check some MAME settings first. Unlike the rest of MAME HLSL actually uses the video card to do a lot of work. But settings are important. I would check your sync refresh setting. Usually having set to 1 is better. Also check your prescale settings in the HLSL section. A setting of 0 is auto but isn't always the best way to go. You may want to try a setting or 2 or 3 for both the x and y. This prescales the image and can mean less work for the GPU. You might want to give that a try first. Another consideration is the resolution you are running HLSL at. You can test in a window or full screen at lower resolutions.

Sent from my iPad Mini using Tapatalk HD

Share this post


Link to post
Share on other sites
I don't know about ATI cards much, but have 0 problems with my Nvidia GTX 760

Yeah I wouldn't think you would with a card like that :embarassed:

I am not familiar with your video card but you may want to check some MAME settings first. Unlike the rest of MAME HLSL actually uses the video card to do a lot of work. But settings are important. I would check your sync refresh setting. Usually having set to 1 is better. Also check your prescale settings in the HLSL section. A setting of 0 is auto but isn't always the best way to go. You may want to try a setting or 2 or 3 for both the x and y. This prescales the image and can mean less work for the GPU. You might want to give that a try first. Another consideration is the resolution you are running HLSL at. You can test in a window or full screen at lower resolutions.

Cheers for that, will take a look at the settings so. Even at that though, would it be fair to say if I'm having trouble running the likes of SF2 then even with a change to settings, my gfx card hasn't got much left in reserves & I should prob look at upgrading it?

Share this post


Link to post
Share on other sites

I have a 2gb card and noticed slowdown, but for some reason it's not the hlsl, it's the HL bezels. Dropping the resolution down used to solve it , but still experiencing it.

Share this post


Link to post
Share on other sites

I used a x1550 on my htpc and it definitively could NOT run HLSL. Now I have a 9800gtx+ inside it and HLSL is a viable solution.

A 6670 is in the same range of 9800gtx (gddr5) but some emulators don't like too much ATI. I'd say go with a nvidia gtx650, it will open a brand new world even in windows gaming when compared to x1650. A better videocard is an overkill for a core 2 duo (maybe better image quality but same speed in terms of FPS).

@horseyhorsey

Videoram does not count so much, many low-end videocard are packed in with impressive vram amount due to marketing strategies. Which videocard are you using?

Edited by dark13

Share this post


Link to post
Share on other sites
I used a x1550 on my htpc and it definitively could NOT run HLSL. Now I have a 9800gtx+ inside it and HLSL is a viable solution.

A 6670 is in the same range of 9800gtx (gddr5) but some emulators don't like too much ATI. I'd say go with a nvidia gtx650, it will open a brand new world even in windows gaming when compared to x1650. A better videocard is an overkill for a core 2 duo (maybe better image quality but same speed in terms of FPS).

@horseyhorsey

Videoram does not count so much, many low-end videocard are packed in with impressive vram amount due to marketing strategies. Which videocard are you using?

I should really go through some other versions of mame to test, no reason why it should perform as it does.

Share this post


Link to post
Share on other sites

@horsey

What model is your videocard? A low-end videocard CAN struggle with hlsl, it is entirely managed trought videocard's shader. If it is a decent videocard the problem may be HLSL setting, check this in you mame.ini:

yiq_enable 0

It MUST be that way. yiq_enable 1 can kill performance even on hi-end videocard

Share this post


Link to post
Share on other sites
@horsey

What model is your videocard? A low-end videocard CAN struggle with hlsl, it is entirely managed trought videocard's shader. If it is a decent videocard the problem may be HLSL setting, check this in you mame.ini:

yiq_enable 0

It MUST be that way. yiq_enable 1 can kill performance even on hi-end videocard

It's not the HLSL I have a problem with , it's the bezels in mame for some reason. I will have a look at that though , thanks.

Not mame bezels but hyperlaunch bezels for mame. I can run some emulators like the amstrad with random bezel backgrounds that change every second and that doesn't affect performance.

Share this post


Link to post
Share on other sites

I confirm I have the same issue, with MAME 0.151 and up.

I'm NOT using HLSL.

Without bezels, it runs fine.

With MAME 0.150 and bezels, it runs fine as well.

Where do you set that yiq_enable 0 ? MAME.ini?

EDIT : If it's in mame.ini I just added it and it doesn't change a thing. (performance-wise)

My config is a i5 + GTX 460

Edited by AxelTerizaki

Share this post


Link to post
Share on other sites
I confirm I have the same issue, with MAME 0.151 and up.

I'm NOT using HLSL.

Without bezels, it runs fine.

With MAME 0.150 and bezels, it runs fine as well.

Where do you set that yiq_enable 0 ? MAME.ini?

yes in the MAME.ini

Share this post


Link to post
Share on other sites

Yep, as I said I did put yiq_enable 0 in mame.ini and it doesn't change a thing, still audio sluttering happening during games.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...