Jump to content
Tanveer

SNES - Invalid System Name *Frustrating*

Recommended Posts

Hi guys,

 

I've been going back and forth with Hyperspin and this error message of "Super Nintendo Entertainment System" Invalid System Name or snes9x.exe is not working".

 

Everything works outside of Hyperspin so its not the emulator. Could someone direct me in the right direction?! Is there something wrong with my AHK files or the database files????

 

It's been 3 days and I still can't get around this issue! Any help would be appreciated :) 

 

 

Share this post


Link to post
Share on other sites

Does it launch properly from RocketLauncher, outside of HyperSpin?

 

Post a copy of your HyperSpin log (log.txt in your root HS folder) and I'd be happy to take a look.

Share this post


Link to post
Share on other sites

If I remember correctly that error message is a HyperLaunch error. What version of HyperLaunch are you using?

Share this post


Link to post
Share on other sites

10:48:36 PM |  HyperLaunch v2.25c
10:48:36 PM |  System Specs:
HyperSpin Dir: C:\Hyperspin
OS: WIN_7
OS Language: 0409
OS Admin Status: No
Monitor #1 (\\.\DISPLAY1): 900x1440 (900x1400 work)
HyperSpin Res: 900x1440
AHK Version: 1.1.07.03
10:48:36 PM |  HyperLaunch received "MAME" and "wrestwar"
10:48:36 PM |  INI Keys read
10:48:36 PM |  Checking paths
10:48:36 PM |  Finished injecting functions into module
10:48:36 PM |  Module is built
10:48:36 PM |  Running module:
 
;-----------------------------------------------------------
;Built in script
;-----------------------------------------------------------
#NoTrayIcon
DetectHiddenWindows, ON
SetTitleMatchMode, 2
SendMode, Event
0 = 2
exitEmulatorKey = Esc
emuPath = C:\Hyperspin\Emulators\Mame\
romPath = C:\HyperSpin\Emulators\MAME\roms\
romPathFromIni = C:\HyperSpin\Emulators\MAME\roms\
romExtension = .zip
romExtensionOrig = .zip
romExtensions = zip
executable = mame.exe
systemName = MAME
romName = wrestwar
daemonToolsPath = 
skipchecks = false
fadeIn = false
fadeOut = false
fadeColor = 0x000000
fadeInDuration = 500
fadeOutDuration = 500
fadeInDelay = 0
fadeInInterruptKeys = {LControl}{RControl}{LAlt}{RAlt}{LShift}{RShift}{LWin}{RWin}{AppsKey}{F1}{F2}{F3}{F4}{F5}{F6}{F7}{F8}{F9}{F10}{F11}{F12}{Left}{Right}{Up}{Down}{Home}{End}{PgUp}{PgDn}{Del}{Ins}{BS}{Capslock}{Numlock}{PrintScreen}{Pause}
gameStartImgPath = C:\Hyperspin\Media\MAME\Images\GameStart\
moduleExtensionPath = C:\Hyperspin\Modules\Module Extensions\
7zEnable = false
7zExtractDir = C:\Users\PIRTPA~1\AppData\Local\Temp\Hyperspin\
7zExtractDirOrig = 
7zDelTemp = true
7zFormats = .zip,.rar,.7z,.gzip,.tar
7zFormatsNoP = zip,rar,7z,gzip,tar
mgEnabled = false
mgKey = NumpadSub
mgSelectKey = Enter
mgExitKey = Esc
multiGameImgPath = C:\Hyperspin\Media\MAME\Images\MultiGame\
mgBackgroundColor = FF000000
mgSidePadding = 0.2
mgYOffset = 500
mgImageAdjust = 1
mgFont = Arial
mgText1Options = x10p y30p w80p Centre cBBFFFFFF r4 s100 Bold Italic
mgText1Text = Please select a game
mgText2Options = w96p cFFFFFFFF r4 s50 Center Bold Italic
mgText2Offset = 70
mgUseSound = true
mgSoundfreq = 300
mgExitEffect = none
mgSelectedEffect = rotate
mgUseGameArt = false
mgArtworkDir = Artwork1
Hotkey, Esc, CloseProcess
;-----------------------------------------------------------
;Module script
;-----------------------------------------------------------
;----------------------------------------------------------------------------
; MAME
; MAME .140 
; by BBB
; 1.0
;
; Info:
; Since MAME needs to save hi scores and data on exit, then we can\'t force
; MAME closed with a hotkey. So make sure you have your own exit key setup
; in MAME first.  We will leave the CloseProcess section below blank, but
; it is still required.
;
;----------------------------------------------------------------------------
 
Runwait, %executable% %romName%, %emuPath%, Hide UseErrorLevel
 
if(ErrorLevel != 0){
  if (ErrorLevel = 1){
    Error = Failed Validity
  }else if(ErrorLevel = 2){
    Error = Missing Files
  }else if(ErrorLevel = 3){
    Error = Fatal Error
  }else if(ErrorLevel = 4){
    Error = Device Error
  }else if(ErrorLevel = 5){
    Error = Game Does Not Exist
  }else if(ErrorLevel = 6){
    Error = Invalid Config
  }else if(ErrorLevel = 7 || ErrorLevel = 8 || ErrorLevel = 9){
    Error = Identification Error
  }else{
    Error = Mame Error
  }
  MsgBox Mame Error - %Error%
}
 
ExitApp
 
;Required
CloseProcess:
   ;Doesnt have to do anything but make sure to have the line before and after this line.
return
 
hideDesktop(){
}
 
FadeInStart(){
}
 
FadeInExit(){
}
 
FadeOutStart(){
Suspend, On
}
 
FadeOutExit(){
}
 
7z(7zP, 7zN, 7zE, 7zExtractDir){
}
 
7zCleanUp() {
}
 
CheckFile(file,msg="",timeout=6){
IfNotExist, %file%
{
If msg
ScriptError(msg, timeout)
Else
ScriptError("Cannot find " . file, timeout) 
}
Return %file%
}
 
ScriptError(error,timeout=6){
MsgBox,48,Error,%error%,%timeout%
ExitApp
}
10:48:40 PM |  Module ended, exiting HyperLaunch normally

Share this post


Link to post
Share on other sites

That is what is in the hyperlaunch file. Let me know if this is the correct file.

 

Thanks for the help guys 

Share this post


Link to post
Share on other sites
12:58:38 PM |  HyperSpin Started 

12:58:38 PM |  Going FullScreen 

12:58:38 PM |  Checking for updates 

12:58:38 PM |  Update Check Complete 

12:58:38 PM |  Startup program unavailable 

12:58:38 PM |  Playing intro video 

12:58:39 PM |  Error intializing joysticks 

12:58:39 PM |  Menu Mode is multi 

12:58:39 PM |  Loading Main Menu.xml 

12:58:39 PM |  Main Menu.xml successfully loaded 

12:58:39 PM |  Main Menu wheel loaded successfully 

12:58:41 PM |  Loading Super Nintendo Entertainment System.xml 

12:58:41 PM |  Main Menu.xml successfully loaded 

12:58:42 PM |  Super Nintendo Entertainment System wheel loaded successfully 

12:58:44 PM |  Launching Game 

12:58:44 PM |  Running HyperLaunch.exe 

12:58:44 PM |  Command Line is: HyperLaunch.exe "Super Nintendo Entertainment System" "2020 Super Baseball (USA)"

12:59:39 PM |  Launching Game 

12:59:39 PM |  Running HyperLaunch.exe 

12:59:39 PM |  Command Line is: HyperLaunch.exe "Super Nintendo Entertainment System" "2020 Super Baseball (USA)"

12:59:44 PM |  Launching Game 

12:59:44 PM |  Running HyperLaunch.exe 

12:59:44 PM |  Command Line is: HyperLaunch.exe "Super Nintendo Entertainment System" "2020 Super Baseball (USA)"

12:59:49 PM |  Quiting Hyperspin 

12:59:49 PM |  Bye! 

Share this post


Link to post
Share on other sites

sorry to dig up a old post but this just started after an update and I am using znes

08:29:04 PM |  HyperSpin Started 
08:29:04 PM |  Going FullScreen 
08:29:04 PM |  Checking for updates 
08:29:04 PM |  Update Check Complete 
08:29:04 PM |  Startup program unavailable 
08:29:04 PM |  Error intializing joysticks 
08:29:04 PM |  Menu Mode is multi 
08:29:04 PM |  Loading Main Menu.xml 
08:29:04 PM |  Main Menu.xml successfully loaded 
08:29:05 PM |  Main Menu wheel loaded successfully 
08:29:11 PM |  Loading Super Nintendo Entertainment System.xml 
08:29:11 PM |  Main Menu.xml successfully loaded 
08:29:12 PM |  Super Nintendo Entertainment System wheel loaded successfully 
08:29:13 PM |  Launching Game 
08:29:13 PM |  Using HyperLaunch
08:29:13 PM |  Getting Launcher path 
08:29:13 PM |  Can't find HyperLaunch, defaulting to root HyperLaunch.exe 
08:29:13 PM |  Launcher located at C:\HyperSpin\HyperLaunch.exe
08:29:13 PM |  Running Launcher 
08:29:13 PM |  Launcher Command Line is: C:\HyperSpin\HyperLaunch.exe "Super Nintendo Entertainment System" "Aladdin (USA)"
08:29:20 PM |  Launching Game 
08:29:20 PM |  Using HyperLaunch
08:29:20 PM |  Getting Launcher path 
08:29:20 PM |  Can't find HyperLaunch, defaulting to root HyperLaunch.exe 
08:29:20 PM |  Launcher located at C:\HyperSpin\HyperLaunch.exe
08:29:20 PM |  Running Launcher 
08:29:20 PM |  Launcher Command Line is: C:\HyperSpin\HyperLaunch.exe "Super Nintendo Entertainment System" "Aladdin (USA)"
08:29:23 PM |  Loading Main Menu.xml 
08:29:23 PM |  Main Menu.xml successfully loaded 
08:29:24 PM |  Main Menu wheel loaded successfully 
08:29:26 PM |  Exit program unavailable 
08:29:26 PM |  Quiting Hyperspin 
08:29:26 PM |  Bye! 
 

Share this post


Link to post
Share on other sites

Assuming you're trying to use RocketLauncher with HS you don't have the Hyperlaunch_Path pointing to your RocketLauncher.exe in the HyperSpin/Settings/Settings.ini so it's defaulting to HyperLaunch.

Share this post


Link to post
Share on other sites

I believe you'll need to set that path I mentioned to point to your HyperLaunch.exe instead then.

Share this post


Link to post
Share on other sites

I'm not really sure what would cause it to stop working if it was working before you updated HS. But, HyperLaunch itself is outdated and it's been so long since I used it.

Share this post


Link to post
Share on other sites

update if anyone has this issue change Execution from hyperlaunch to normal , then Use Full Path to Roms: enabled and it should work 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By zanaga
      Hola como estan?
      estoy teniendo un problema con menu, baje un pack de n64 y cuando lo instalo el dibujo de anterior/siguiente juego no aparece abajo en el medio sino que esta en todo el centro de la pantalla y no se como acomodarlo (Adjunto imagen del menu al que me refiero)
       
      El otro problema que tengo es que cuando instalo los juegos del pack famicon de 550 juegos solo me reconoce 79, es la primera vez que me pasa, rehago la database y solo reconoce 79.
       
      Muchas gracias por su ayuda

    • By hawkfanz
      I use rocketlauncher to start mame64 games in hyperspin but the first game on a fresh windows startup takes 20 seconds to start.  After closing this game the next game will open almost immediately. I know others have asked this question but I can’t find a solution. I have no anti-virus running, no windows defender, no rocketlauncher fades or bezels. I updated the mame64 version to the 209 no nag from 197 no nag with no change. Any help or suggestions would greatly be appreciated!!
×
×
  • Create New...