Jump to content
Sign in to follow this  
phantasy

MAME Graphics (black screen) bug AND FIX!

Recommended Posts

I found two potential problems some users MAY encounter during Simply Austin's YouTube tutorial so I'd like to post my fixes.

 

DISCLAIMER: NO NEGATIVE REFLECTION SHOULD BE IMPLIED TOWARDS SIMPLY AUSTIN NOR TO HIS TIRELESS EFFORTS. HIS WORK IS TOP NOTCH AND CAN'T BE EXPECTED 100% OF THE TIME TO WORK 100% ON EVERY SYSTEM. I COULD NOT HELP YOU GUYS IF IT WEREN'T FOR HIM, SO BIG THANKS AUSTIN!!

 

 

Workflow:

 

Following his tutorials to the letter, I got HyperSpin 1.4, RocketLauncher, and HyperSync setup flawlessly. I went lifetime/platinum support membership of both HyperSpin and EmuMovies due to his HyperSync video!  I followed both MAME tutorials, but hit a slight snag at not using a 64bit OS on the install computer. Taking his advice, I went for the latest 32bit build of MAMEUIFX which, as my favorite, sadly is the final version at 175.1. Currently I see no reason to change or add a 176 build of an alt MAME derivative.

 

All tutorial steps went smoothly until the final two when loading a game resulted in a black/blank screen inside of the bezel, but with full control and audio.  This was right after I copied Austin's EXTRAS/OLD SCREEN subfolders of artwork,hlsl, and ini into my mame directory.  Also, sometimes all my games no longer worked! After a long process of elimination, I've come up with a fix for both:

 

 

BLACK or BLANK SCREEN FIX:

 

Please be careful when copying in the following files into your mame 'hlsl' directory and make sure you keep backup copies of your originals:


bloom.fx
post.fx

prescale.fx


Simply Austin's bloom.fx and/or post.fx (either together or even separately) broke my video output to a black screen. He was on an older version of MAME (1.53) and I am on 1.75.1 (MAMEUIFX final) but I know nothing about the behind the scenes workings of fx files. I copied back my originals and my picture returned.

His prescale.fx file is safe, but note it does update your bezel visual to blocks, rather than the MAME logo which you may merely take note of if you prefer one over the other.

The above three files are moved into a 'BAD' subfolder for now (sorry Austin) so I remember and that they don't override anything until more information is known.

 

 

GAMES NO LONGER WORKING - TROUBLESHOOTING:

 

When you copy Austin's new mame.ini file over to your ini folder, it will overwrite your ROM path settings from WITHIN your MAME emulator back to the default of just ROMS in your MAME directory. IF your rom path(s) are elsewhere, re-map them now or no games will load.  If you only have your roms in the default path (which I suspect is many users), his change will not cause you any notice. Also note that though his mame.ini replacement does not change rom path settings within HyperHQ or RocketLauncher, they need to be in harmony with your rom path settings in your main MAME build they look to. 

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By mamefan
      Hi. I have hundreds of Hypermarquee MAME gameplay videos here http://www.youtube.com/c/mamefan
      I also have a video showing how to get it working.
×
×
  • Create New...