Jump to content
ticmike

Adding A New Wheel To Hyperspin

Recommended Posts

Ok I hope youre all not getting few up of my Noob questions as I really do appreciate all your help.

My new question is adding a new Wheel to Hyperspin.

Ive downloaded Metalzoics Ghouls & Ghosts Wheel and ive got it showing on my main hyperspin, im just struggling to work out where all the files go.

These are all the files I have, just wondering where to put them all lol, again sorry if this is basic, I have tried to work it out myself.

Ive also uploaded screens of where im at in hyperspin.

GNG.jpg

GNG-main.jpg

GNG-once clicked.jpg

Share this post


Link to post
Share on other sites

Looks like ya 95% there, the folder "main menu theme & wheel" you need to put them in your hyper spin folder\Media\Main Menu you will see corresponding folders there  

  • Upvote 1

Share this post


Link to post
Share on other sites

Adding to the post of Samorite, System themes go into your Hyperspin\media\<systemname>\Themes and the gamevids go into Hyperspin\media\<systemname>\video
Pointer will be placed in Hyperspin\media\<systemname>\Images\Other
Bezel and Fade are Rocketlauncher media and go into your Rocketlauncher\media\Bezels\<systemname>\ and Rocketlauncher\media\Fade\<systemname>\ respectively. 
That should cover the lot for the media.

You will have to add all the none MAME games to RocketLaucher under <systemname> --> Games --> alternate emulators. Also don't forget to add the paths to all the rom locations, Mame would be a no-brainer, but there's also games from nes, snes, psp, ps2 etc... so don't forget to add their roms paths

  • Upvote 2

Share this post


Link to post
Share on other sites
38 minutes ago, Samorite said:

Looks like ya 95% there, the folder "main menu theme & wheel" you need to put them in your hyper spin folder\Media\Main Menu you will see corresponding folders there  

Just struggling on the Mian Menu now, I know what you are saying but the stuff in the folders doesnt seem to be right.

Share this post


Link to post
Share on other sites

You'd have to match the files to be the same as your systemname. I notice that you named it Ghouls & Ghosts.... therefore your main menu media has to be named exactly the same, including capitalisation.

This would also be followed through for your RocketLauncher media hence I used <systemname> because I wasn't quite sure how you named your system exactly.

  • Upvote 1

Share this post


Link to post
Share on other sites

If you look at Yeuskes post it much more in depth and gives you step by step instruction. as he said you need to point each emu and game in RL

Share this post


Link to post
Share on other sites
Just now, Yeuxkes said:

You'd have to match the files to be the same as your systemname. I notice that you named it Ghouls & Ghosts.... therefore your main menu media has to be named exactly the same, including capitalisation.

This would also be followed through for your RocketLauncher media hence I used <systemname> because I wasn't quite sure how you named your system exactly.

Yep ive been renaming as I go along.

Just not sure where this one goes (image below) as this file in the Wheels folder, doesnt seem to match all the others that are in the Hyperspin main menu folder (if you understand what im waffling about lol).

As this is my background image im getting on the main menu when in reality im sure it should look like the one in the wheels folder.

I do hope that made sense.

GNG-wheel.jpg

GNG-Backg.jpg

Share this post


Link to post
Share on other sites

The main menu theme seems to be correct from what I've got myself in the zip file; but I'm sure you didn't place the main menu video in the correct place yet because it uses the whole real estate of the screen in the xml file. When you put the vid in the correct place that will sort itself out.

I forgot to mention that you want to pick MAME as your default emulator too.

 

Compilation systems need a little bit more work than your standard system tho, I'd say you are nearly there.

  • Upvote 1

Share this post


Link to post
Share on other sites
26 minutes ago, Yeuxkes said:

The main menu theme seems to be correct from what I've got myself in the zip file; but I'm sure you didn't place the main menu video in the correct place yet because it uses the whole real estate of the screen in the xml file. When you put the vid in the correct place that will sort itself out.

I forgot to mention that you want to pick MAME as your default emulator too.

 

Compilation systems need a little bit more work than your standard system tho, I'd say you are nearly there.

Yep it was the main menu video i had not done, all sorted now,  just got to configure RL now, im scratching my head again at that.

I dont seem to be able to select MAME for ghouls and ghosts and theres no icon next to it in the long list.

When I try to pick a default emulator, it does not bring any Emulator options up to choose from.

GNG-rl.jpg

Share this post


Link to post
Share on other sites

you may have to add the emulator for each game independently, just done a quick vid on how to add a emu and game to a system. doesnt matter too much about  icon in left column, dont think ya need a default emulator neither just takes time and knowing what game + rom location + emulator   

 

  • Upvote 2

Share this post


Link to post
Share on other sites

The icon isn't there since it's not a default system in RocketLauncher, you can add one yourself if you add one in the RocketLauncher\RocketLauncherUI\Media\Icons or ....\Custom Icons, both work here
This is true for any custom/collection wheel you add to RL, you'd have to make one yourself.

You should be able to add MAME to the default emulator tho but I'm unsure if you need to check/uncheck a setting somewhere. It's been a while since I've added any compilation wheels myself. In any case you can go ahead and add the custom emulators for the games that don't require MAME to run.

Share this post


Link to post
Share on other sites

I have found the setting you need to change to be able to set MAME as default emulator. Pick Global from the list on the left --> choose RocketLauncherUI --> under General options disable Valid Emulator/Modules Only

This will save you some entries in the Alternate Emulators section under Games.

  • Upvote 1

Share this post


Link to post
Share on other sites
7 minutes ago, Yeuxkes said:

I have found the setting you need to change to be able to set MAME as default emulator. Pick Global from the list on the left --> choose RocketLauncherUI --> under General options disable Valid Emulator/Modules Only

This will save you some entries in the Alternate Emulators section under Games.

Brilliant, that sorted the problem.

Next is to create a roms folder and rename them as the audit isnt finding any games, think my MAME roms are named different than these ones, work fine in MAME but not on here so thinking the database may be named wrong?

Share this post


Link to post
Share on other sites

Games don't turn up in the audit if you have them set in the Alternate Emulator section, this is mentioned on the wiki of RL.

Try and launch them and they should work fine if you have set all the paths and emulators in RL, make sure that the database has the same files as your rom names too. It's best to rename the database to match your roms since it's a custom database anyways. Otherwise you run into problems for your main systems. But if you do any renaming you must match the media files to reflect your changes.

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...