Jump to content
lilcheeks

Hyperspin issues after enabling port audio on .182

Recommended Posts

I just updated to the latest MAME64 and updated my ROMs as well.  I tested out the update in hyperspin and everything was working as it should.  I then enabled the new port audio option (see below) in the .ini file and everything seemed to work great until i left a game.  Once i exited the game back to hyperspin, hyperspin would not have any sound and the snap videos would only play a few seconds and freeze.  I could switch games and select new games, but there wouldn't be any sound in hyperspin until i restarted hyperspin.  

So then i deleted my .ini file to see if it would work again, and it worked great.  So it seems like enableing port audio is causing some issues with Hyperspin.  Anyone else have this?

 

Edit: I just heard from someone on Reddit that they are using .182 with the same portaudio settings below and have no issues with Hyperspin.  Maybe there is a setting in Hyperspin causing this?  Was I supposed to do anything in Hyperspin after updating MAME64?

 

Here are the options i changed in the .ini to enable port audio.

# OSD SOUND OPTIONS
#
sound                     portaudio
audio_latency             1

#
# PORTAUDIO OPTIONS
#
pa_api                    "Windows WASAPI"    
pa_device                 default
pa_latency                0.003334

Share this post


Link to post
Share on other sites

having the same issue.  Not sure if it's of any use but I'm using the onboard sound card - realtek.

Share this post


Link to post
Share on other sites
7 hours ago, acidim said:

having the same issue.  Not sure if it's of any use but I'm using the onboard sound card - realtek.

Same here.

Share this post


Link to post
Share on other sites

Can someone please reply to this that is using .182, has portaudio enabled and is using hyperspin?  I want to know if this is an issue with all Hyperspin installs or is it just a few specific installs?  i don't see any other posts about Port Audio so its hard to tell if anyone is using it or not.  Feel helpless with this issue.

Share this post


Link to post
Share on other sites
20 minutes ago, Metalzoic said:

What is portaudio?

I'm no expert but it seems like a low latency audio option.  When I enable it, it sounds a lot better.  Here is what the official release stated:

We’ve received a contributed PortAudio output module and integrated it in this release. This provides a cross-platform low latency audio output solution. Performance should be similar to Steinberg ASIO on Windows 7 or later without the licensing issues, and better than SDL audio on Linux. It can be enabled by setting the sound parameter to portaudio on the command line or in an ini file. Of course, all the other audio output modules are still supported, so if you're happy with your current setup you don’t have to change anything.

Share this post


Link to post
Share on other sites

I am having same issue. MAME .182 with portaudio enabled. Onboard audio (realtek). Win7 x64.

If I launch MAME normally, I get audio using either "Windows WASAPI" or "Windows WDM-KS". If I launch MAME in Hyperspin using "Windows WASAPI", I get the same results as OP. If I launch MAME in Hyperspin using "Windows WDM-KS", I get no audio in MAME when launched but I have audio in Hyperspin when I exit MAME.

Share this post


Link to post
Share on other sites

same issue here, W7x64 and running Hyperspin + Mame 0.182 on a realtek audio device from the motherboard.

No matter what portaudio settings I use, the game will load and sound fine, but when i exit back to Hyperspin, the audio is lost.

Share this post


Link to post
Share on other sites

Are there any dev's that can confirm this will not work in Hyperspin without an update of some sort?  I was told by someone that Hyperspin doesn't reinitialize the audio, and it won't until an update is released.  Just curious how true that is.  As of right now I can't tell if this is a bug on a few systems, or a feature that hasn't been added yet.

Share this post


Link to post
Share on other sites

You won't get an answer from the HS dev, so I wouldn't wait for that. The same issue you're experiencing also occurred with ASIO MAME builds in the past, you would have to manually restart the audio service or you would lose sound in HS.

Share this post


Link to post
Share on other sites
14 hours ago, agent47 said:

You won't get an answer from the HS dev, so I wouldn't wait for that. The same issue you're experiencing also occurred with ASIO MAME builds in the past, you would have to manually restart the audio service or you would lose sound in HS.

Oh okay, thank you very much.  This tells me its just not a feature of Hyperspin so I won't worry about it.

Share this post


Link to post
Share on other sites

whats the best way to restart the audio service in hyperspin? would it be possible to add a line somewhere so that when exiting the game the audio would restart automatically?

i haven't touched the config for over two years, any guidance would help :)

Share this post


Link to post
Share on other sites

I am having the same issues when trying Windows WDM-KS and Windows WASAPI.  Using Windows MME or Windows Directsound fixed the issue for me.  I know they're not as great as the other 2 options, but at least I'm back up and running.  I'm using my motherboard's onboard audio from Realtek.

Share this post


Link to post
Share on other sites
On 12/2/2017 at 4:22 AM, yakk00 said:

I am having the same issues when trying Windows WDM-KS and Windows WASAPI.  Using Windows MME or Windows Directsound fixed the issue for me.  I know they're not as great as the other 2 options, but at least I'm back up and running.  I'm using my motherboard's onboard audio from Realtek.

thats good news :) do you mind sharing your mame settings? 

whats the difference between WDM-KS, WASAPI and MME or Directsound? 

Share this post


Link to post
Share on other sites
On 2/10/2017 at 6:40 AM, alex2005 said:

whats the best way to restart the audio service in hyperspin? would it be possible to add a line somewhere so that when exiting the game the audio would restart automatically?

i haven't touched the config for over two years, any guidance would help :)

I use RocketLauncher & added a some code to the end of the MAME module that would stop then restart the audio service whenever you exited a MAME game. The audio would actually come back on in HyperSpin the first time when closing a MAME game but would not come back if you played then exited another MAME game - so technically no real change.

Share this post


Link to post
Share on other sites

I have attached my groovymame mame.ini.  I'm not really sure what the differences are between the different Windows settings.  Hopefully a fix will come soon!

mame.ini

Share this post


Link to post
Share on other sites

thanks for the tips guys!

so far i tried two approaches, to add some lines in mame ahk to stop and start the audio service > this didnt work as it seems i did not have enough admin permissions in windows to stop the process from command line and do not know how to do it.

then tried the portaudio setting but the sound i get is blur, i guess my realtek card is not compatible with other settings (if at all). 

 

Just for info purposes the realtek i use is embedded on a gigabyte  GA-B85M-D3H motherboard. 

if i cant find a solution maybe i will try to buy a new soundboard, but that is a pain to set up in my bios as it does not allow me low resolution ( i need to take the pc out of the cabinet, etc etc).

 

Hopefully a fix comes soon at some point :)

Share this post


Link to post
Share on other sites
16 hours ago, yakk00 said:

I have attached my groovymame mame.ini.  I'm not really sure what the differences are between the different Windows settings.  Hopefully a fix will come soon!

mame.ini

your ini file made the trick!

i had the pa_latency too low i guess. Also setting it as "Windows MME" or "Directsound" made it work.

thanks so much!

anyone who has and can try both MME/Directsound and WDM-KS, WASAPI  could tell if any of these sound better than the others?

At least very happy to see its working now!

Share this post


Link to post
Share on other sites

I have tried all four of them. MME & DirectSound work nicely with HyperSpin but the pa_latency seems to be capped at 0.017 - any lower & the audio does not work properly. WASAPI & WDM-KS have much better pa_latency at 0.00334 & 0.001 but they do not work with HyperSpin (at least on my system).

The MME/DirectSound both work with HyperSpin & are better than stock audio settings so this is the way to go for now if you are having issues with WASAPI/WDM-KS in HyperSpin.

Share this post


Link to post
Share on other sites

WDM-KS didn't work for me (2,00ms) ..... WASAPI did (3,33ms)
MME (18,67ms) did also work.
Standard audio settings was !! 91ms !! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×