Jump to content
blansmith

Mame help for shield tv

Recommended Posts

I need some help getting mame setup for a shield tv.

I already have hyperspin working with NES, SNES, N64, SMS and Sega Genesis

The way i have it setup is on the root of shield is my hyperspin folder. In hyperspin I have a folder called Emulators, Folders named with each system, then a folder called roms, then the roms ie. hyperspin\emulators\Sega Genesis\roms

All of the roms i have for these systems have one file with the same file type for all roms for each system. ie: all Nintendo 64 roms are .z64 file extension. Also all of the roms are clearly labeled with the game name.

then in my settings folder in hyperspin there are .ini files for each system.  Inside the .ini i set up the rompaths correctly, with the retroarch exe and the rom extensions = to the file extensions in my rom folder. I also have the cores setup with the correct core that was downloaded through retroarch.

There are also database files for each system with one xml document for each system.

all of these systems and games work fine in hyperspin.

Now for Mame. I downloaded two sets of Roms, one called .180 which is full of a ton of zip files and also hbmame which was 16 different zip files full of what looks like a lot of the same stuff in each zip. When i unzip the zip files for what i think are the games they look nothing like my other roms for the systems.

1. Am i supposed to have a folder named MAMA under emulators then roms and dump all of these zip files in there? (i did try this and i couldn't get anything to work after)

2. The Database file under MAME is full of different xml documents like bowling games, boxing games ext.  Is this correct? My other systems have just one xml there with a list of all games.

3. The MAME .ini file also came with .mame4droid for the exe instead or retroarch, is that correct, or should it be the retroarch settings?

4. I feel like I must be missing something big with the mame setup. Doesn't seem like the others.

Any help in pointing me the right direction would be much appreciated.

 

Sorry for dragging on, just want to make sure i am clear.

 

Thanks.

 

 

Share this post


Link to post
Share on other sites

I find MAME a struggle but I wil do my best to help you out.

anything MAME should be zipped .zip, I think retroarch supports 7z but I don't use it for MAME as zip is the standard. (This includes FBA emulators aswell I think as they are sort of a version of MAME)

i have no clue on HBMame but it's another derivative of MAME that allows for different and hack type games.

1. Your MAME roms can be anywhere BUT by default retroarch will need them in the retroarch "system/mame/roms" folder (you will need to create the "MAME/roms" folders. The retroarch system folder contains any bios files needed for all consoles that you run. If you don't want them there you will need to get a MAME.ini file from the windows MAME emulator and edit the rompath line to reflect your location. 

With your .180 romset your best to use retroarch as their current MAME core (Arcade (MAME)) core in online updater is version .181. Arcade (mame2016) uses the MAME version on .174

mame gets updated monthly but retroarch updates less often. The emulator version should match the romset version so all the names and bios files have best compatibility.

my Atari 5200 guide covers some of the MAME rompath and MAME.ini stuff but is different 

2. You can delete all other xml files other than MAME.xml in the database folder. The are for use with the genre feature of windows HS which is not supported on android

 

3. Using mame4droid (red one) is an easier setup and a bit friendlier than retroarch BUT it does not support as many games because it's based on a MAME version that's years old specifically .139. This romset is readily available if you want but the artwork and database is hard to find. I have a very good xml for it but never finished matching the wheel artwork. If you want it let me know

When you first boot it up it will ask you for the location of you romset. It uses a default location if not which I forget now but it's probably in the root of your shield under "mame4droid/roms" 

4. Your only missing some experience and many wasted hours of searching for answers on google :) 

people say MAME is easy but personally to set it up well it's far from easy. You can just slap the stuff in and get things working but getting it smooth takes some learning. I am nowhere near good at it

hope that helps

 

Share this post


Link to post
Share on other sites

So i have this working in retroarch, but I can't figure out how to add coins to the games or how to press enter, does anyone know how to do this on the nvidia shield controller? Also still struggling to get it working with hyperspin. Something with the path to the roms. My roms are normally in my hyperspin folder under emulators. I put the mame roms in the retroarch folder like you said, but now it doesn't seem to like the path in the settings ini. 

the normal path for all of my roms looks like this in settings rompath=Emulators/Sega Genesis/roms. Its like the settings already assume the roms are in the hyperspin folder since i didn't need to put the full path which would be Hyperspin/Emulators/Sega Genesis/roms

the paths i have tried are 

Android/Data/com.retroarch/System/Mame/roms

sdcard/Android/Data/com.retroarch/System/Mame/roms

storage/emulated/o/Android/Data/com.retroarch/System/Mame/roms

Any help would be appreciated.

 

Thanks.

Share this post


Link to post
Share on other sites

Mine usually start storage/emulated/0

All case sensitive and 0 = zero

i have the Pro model with 500Gb hard drive 

 

Share this post


Link to post
Share on other sites

I have MAME 0.182 set working on RetroArch but although many games work perfectly I am finding games likes Galaga, Galaxian and a few other classics just won't play

It goes to load the game then comes up with RetroArch stopped error

I am using 16GB NVIDIA SHIELD TV (2017 version) and all my games are on a 3tb external hdd (all other roms from 64 systems work perfectly) also tried loading roms from retroarch on internal and same result.

Just wondering if I am missing a setting in RetroArch (using latest nightly version) and mame core (0.182) RetroArch runs all other systems fine.

Any ideas ?

 

Thanks in advance

 

Share this post


Link to post
Share on other sites

Sorry I am of no help with this stuff. This is maybe a MAME question.

i wonder what MAME needs to run those games. It may not be a retroarch problem at all or it could well be. Have you tested the set on a pc

Share this post


Link to post
Share on other sites

yes, everything working fine on pc version

checked on mame 0.182 and retroarch and both run the games fine, so its either settings in retroarch or retroarch for android as pc version is ok

as i say many games work fine, but these are classics that you would think would work

Share this post


Link to post
Share on other sites

also is there any way to use artwork on retroarch on mame and put the artwork on an external drive ?

meaning can it point to external drive instead of internal ?

 

Thanks

Share this post


Link to post
Share on other sites
1 hour ago, cataclysm67 said:

also is there any way to use artwork on retroarch on mame and put the artwork on an external drive ?

meaning can it point to external drive instead of internal ?

 

Thanks

I expect so, not tested myself but if you have a mame.ini file in the retroarch system/MAME folder you can specify paths for all kinds of things. I use them to have my roms on a NAS. Give it a shot. 

Grab the MAME.ini from you PC MAME emulator folder and edit that. 

Share this post


Link to post
Share on other sites
23 hours ago, cataclysm67 said:

also is there any way to use artwork on retroarch on mame and put the artwork on an external drive ?

meaning can it point to external drive instead of internal ?

 

Thanks

Yes create an artwork folder in RetroArch system/mame folder. They have to be zipped. If you are using mame 2014 then you have to name folder system/mame2014/artwork

Share this post


Link to post
Share on other sites

Hi,

Tried that but no luck, using latest MAME core 0.182 romset on latest nightly RetroArch build. (I put MAME bezels zipped in RetroArch/System/Mame/Artwork)

All games seem to work fine, just wanted to add my MAME artwork if possible for RetroArch.

Ideally I wanted to put artwork on an external drive. Is that possible ?

 

Thanks

Share this post


Link to post
Share on other sites
23 minutes ago, cataclysm67 said:

Hi,

Tried that but no luck, using latest MAME core 0.182 romset on latest nightly RetroArch build. (I put MAME bezels zipped in RetroArch/System/Mame/Artwork)

All games seem to work fine, just wanted to add my MAME artwork if possible for RetroArch.

Ideally I wanted to put artwork on an external drive. Is that possible ?

 

Thanks

Yes that's where I have mine. I have all my RetroArch files on hard drive. On your hard drive you should have a folder called android. Inside that you should have data/com.retroarch/ files/system/mame/artwork. 

I have all my RetroArch BIOS files in system folder and all my mame systems and Roms. That way I don't use any of my shield memory

Share this post


Link to post
Share on other sites

Hey fellas, the one key bit of info is what is you system directory set to in retroarch?

i tried putting files on a nas drive as badhemi has is because once mounted it creates those folders. It did not work of the bat. I did not change my directory yet to see if it works but I don't see why it would not. If that's the case you should be able to have it anywhere your system directory is pointed at.

@cataclysm67 did you try using a mame.ini file in the retroarch system/mame folder? 

Set mame core options to enable read configurations

Share this post


Link to post
Share on other sites
On 1/30/2017 at 11:04 AM, thatman84 said:

Mine usually start storage/emulated/0

All case sensitive and 0 = zero

i have the Pro model with 500Gb hard drive 

 

Thanks for all of your help, i have mine all up and running along with Neo Geo. I ended up moving my roms to my hyperspin folder and thats what finally got it working. For some reason it didn't like the roms being in the retroarch folder. Either way I am all good now.

 

Thanks.

Share this post


Link to post
Share on other sites

still no luck, put all files where you said and also bios files.

Pointed RetroArch to system folder and added artwork to artwork folder, but it does not show up when game loads.

Also i had to create system/mame/artwork into the android folder. Should they have already been there ? How would I make RetroArch create them if so ?

Do i need to change the settings file ?

 

Thanks

Share this post


Link to post
Share on other sites
21 minutes ago, cataclysm67 said:

still no luck, put all files where you said and also bios files.

Pointed RetroArch to system folder and added artwork to artwork folder, but it does not show up when game loads.

Also i had to create system/mame/artwork into the android folder. Should they have already been there ? How would I make RetroArch create them if so ?

Do i need to change the settings file ?

 

Thanks

They need to be in the same system as Roms. Because they load together as one. Can't have Roms in shield and artwork in hard drive. Worse case place them in mame4droid artwork and use it

Share this post


Link to post
Share on other sites

It sounds like you need the MAME.ini file (from MAME pc emulator) 

like at the Atari 5200 guide I done. Set the artwork folder up like I did for the rompath.

Share this post


Link to post
Share on other sites

what mame options ? I have tried mame.ini in practically every folder that has been mentioned and still no good. also read and write options on mame.ini are enabled

I think i will leave it as I just dont get what you are saying.

 

Thanks anyway

Share this post


Link to post
Share on other sites
57 minutes ago, cataclysm67 said:

what mame options ? I have tried mame.ini in practically every folder that has been mentioned and still no good. also read and write options on mame.ini are enabled

I think i will leave it as I just dont get what you are saying.

 

Thanks anyway

Copy this mame folder to your RetroArch system folder inside place Your artwork in artwork folder. Load game then press green Nvidia button go to quick menu and look for options. Once in options enable read and write configurations. Then exit to save. Then try your games to see if artwork shows.

mame.zip

Share this post


Link to post
Share on other sites

If u want mame bezels 1.make sure they are proper mame bezels and not rocketlauncher type bezels and 2. Make sure u have them zipped in the artwork folder named exactly like the game its for....that folder should be in your mame folder next to roms folder like a normal pc setup...if not then u need to locate the mame.ini generated when u 1st open mame...not sure where it's located because my retroarch setup in identical to a normal pc setup where so all files and folders are together on my hdd.....as far as ur roms not playing it's because ur roms must be 2 old.....if u are using mame182 then u need a somewhat recent romset as maybe there have been upgrades to older roms making them unplayable....

  • Upvote 1

Share this post


Link to post
Share on other sites

I have copied mame folder to my retroarch system folder and added some artwork (artwork is correct as works in mame4droid) , turned on read and write in retroarch and saved but still no bezels.

I have also tried putting the mame folders next to my roms on my hard drive, still no luck

Also my MAME romset is 0.182 and works fine, I only wanted to have bezels on the games and ideally running from an external hdd instead of internal.

I will have to make do with bezels on the MAME4DROID set

Thanks for all the help

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Honosuseri
      As we celebrate 25 years of DOOM! John Romero has brought us SIGIL, an unofficial 5th chapter to the original game. So as Retroarch's Prboom core has now been updated to support it...figured I should really add it to my Doom Classics wheel...
      Threw together a Sigil theme, wheel art and video snap. I was pleasantly surprised, that the prboom core now played the midi music natively. Doom 1&2 originally required me to add the music tracks as mp3 files. 
    • By zanaga
      Hola como estan?
      estoy teniendo un problema con menu, baje un pack de n64 y cuando lo instalo el dibujo de anterior/siguiente juego no aparece abajo en el medio sino que esta en todo el centro de la pantalla y no se como acomodarlo (Adjunto imagen del menu al que me refiero)
       
      El otro problema que tengo es que cuando instalo los juegos del pack famicon de 550 juegos solo me reconoce 79, es la primera vez que me pasa, rehago la database y solo reconoce 79.
       
      Muchas gracias por su ayuda

    • By Honosuseri
      As you probably know there is a RetroArch core to play Daphne games BUT currently it's broken! I wish the developer luck getting the official core stable.

      Thanks to @Reznnate. We now have access again to the working test core (HERE: https://drive.google.com/open?id=1frcFNWPinSkfyafsBXsnfHd46_kS1yIY). We can install this .so file through a new feature in RA, an install core option under "load cores" has been added. I've put together a video to help you peeps understand the Daphne game files and the settings required to get the games playing through RA and Hyperspin. I hope it's of help to some of you....
       
       
×
×
  • Create New...