Jump to content
picabotwo

Hyperspin - Loses Focus Alt+Tab

Recommended Posts

Good evening,

I hope you all can help me out with some minor issues I have been having with my Hyperspin Arcade setup. I am using Hyperspin 1.4 and the latest version of Rocket Launcher UI (1.0.1.10). I recently ran rocketlauncher and it updated a whole bunch of files. Everything seems to be working but with one miner issue. I can launch Hyperspin, browse through menus, enter in and back out just fine. I can launch the emulators and games just fine (Keys and credits all work). I have it set to exit the emulator with a hold of the (1+3, or ESC). It shows the thanks for playing and goes back to Hyperspin, but loses focus. I cannot control Hyperspin until I alt + tab back into the program.

I am using joy2key as my mapper. On the rocket launcher UI I have tried disabling all of the hide features (taskbar, cursor) are all set to false. I have tried enabling the restore front end, restore and click, and disabled but nothing seems to work. The only two programs open after I escape the emulator is Joy2key and hyperspin. Any ideas?

Thanks for any suggestions.

Josh

RocketLauncher.zip

Share this post


Link to post
Share on other sites

There`s an option in rocket launcher when you exit an emulator it will add a mouse click on hyperspin to bring it in focus.. Will this help?

Share this post


Link to post
Share on other sites

I've got it turned on...  still does it. 

Thought of sonny ting the left mouse click on the iPad to down on player 1 joystick. That way by trying to navigate the wheel when it looses focus it would send a click to hyperspin. Don't think I've got anything mapped to left to right mouse

Share this post


Link to post
Share on other sites

I changed my exit emulator button to backspace.  Using ESC creates all sorts of problems.  I’m also now using model 2 emulator and this won’t work with ESC either as it exits back to a small window instead of going back to hypwrspin. 

Set all your emulators exit key to something other than ESC. I use backspace.  I did it in each emulator and also in global settings too to make sure.  

Also make sure you have restore frontend on exit set to - restore and click

ive got restore resolution on exit set to false

Also, after doing all this I did notice occasional that rocket launcher for some reason decides to change its settings all by itself. When it does this I get problems again so I did this-

find the setting folder in rocketlauncher UI and change the folder and all the files in it to READ ONLY.  Do this after you’ve done what your going to do when it’s running ok. Or you’ll have to change these back. 

I also this the same to my mame config file as occasionally for some reason all my control settings were getting reset?  This has stopped that too 

Let me know how you get on...

Edited by Martin0037
  • Upvote 1

Share this post


Link to post
Share on other sites

I use an ipac4

been an absolute nightmare doing my cab. Problem after problem. This was one of the most annoying when I exit a game back to hyperspin but then as it’s lost focus the controls don’t do anything. And it only did it occasionally.  Pain in the arse. 

Share this post


Link to post
Share on other sites

I’ve nearly scrapped the lot and gone to mala or something more simple.  My cab has took a lot to build as it’s got 4 player controls dual aim track light guns a trackball and a spinner with steering wheel.  Took forever to do. 

  • Super Like 1

Share this post


Link to post
Share on other sites

yea i use the ipac2 but when mine sits to long and sleeps i lose all controls and i need to restart hyperspin i love the hyperspin but not all the problems i havelol

Share this post


Link to post
Share on other sites

Sounds like one of the first problems I’ve had. Think that’s a windows problem but not sure  can’t remember how i fixed it, it may have been a setting in rocket launcher.  Make sure all the hotkeys also in rocket launcher arnt used.  There has to be a blank space on each setting not just the word “none” or you’ll get an error when you launch a game.

Make sure in Windows all the hotkeys and shortcuts are turned off. Don’t have anything at all running. Use a clean install of windows. 

Mine boots up straight into hyperspin. I don’t have any windows loading screens showing or anything. All you see is a screensaver for a few seconds then hyperspin starts. There’s YouTube tutorials to show you how to switch everything in windows off for gaming. It takes a while but worth it. I’ll see if I can find the link. 

  • Super Like 1

Share this post


Link to post
Share on other sites

ok cool cheers man yea i shell my windows with instant sheller also but i just seen some set ups on Android so just looking into that coz alot of problems with win7 a 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...