Jump to content
inwd

Help games won't start!?

Recommended Posts

I've installed HP 1.4.16 + latest RL and followed the official guides.  I think the RocketLauncher.exe path is correct. I run the games through RL fine but not HS I can select systems and games but can't start :/ Also the games list doesn't seem to update with games I placed in roms folder except for one game that has the title graphics. The games are correctly named and paths.

Here is my log anyway.

12:04:40 AM |  HyperSpin Started
12:04:40 AM |  Going FullScreen
12:04:41 AM |  Checking for updates
12:04:41 AM |  Update Check Complete
12:04:41 AM |  Startup program unavailable
12:04:41 AM |  Playing intro video
12:04:42 AM |  Menu Mode is multi
12:04:42 AM |  Loading Main Menu.xml
12:04:42 AM |  Main Menu.xml successfully loaded
12:04:43 AM |  Main Menu wheel loaded successfully
12:04:43 AM |  Loading Super Nintendo Entertainment System.xml
12:04:43 AM |  Main Menu.xml successfully loaded
12:04:44 AM |  Super Nintendo Entertainment System wheel loaded successfully
12:04:44 AM |  Launching Game
12:04:44 AM |  Using HyperLaunch
12:04:44 AM |  Getting Launcher path
12:04:44 AM |  Launcher located at D:\RocketLauncher\RocketLauncher.exe
12:04:44 AM |  Running Launcher
12:04:44 AM |  Launcher Command Line is: D:\RocketLauncher\RocketLauncher.exe "Super Nintendo Entertainment System" "2020 Super Baseball (USA)"
12:04:45 AM |  Launching Game
12:04:45 AM |  Using HyperLaunch
12:04:45 AM |  Getting Launcher path
12:04:45 AM |  Launcher located at D:\RocketLauncher\RocketLauncher.exe
12:04:45 AM |  Running Launcher
12:04:45 AM |  Launcher Command Line is: D:\RocketLauncher\RocketLauncher.exe "Super Nintendo Entertainment System" "2020 Super Baseball (USA)"
12:04:46 AM |  Launching Game
12:04:46 AM |  Using HyperLaunch
12:04:46 AM |  Getting Launcher path
12:04:46 AM |  Launcher located at D:\RocketLauncher\RocketLauncher.exe
12:04:46 AM |  Running Launcher
12:04:46 AM |  Launcher Command Line is: D:\RocketLauncher\RocketLauncher.exe "Super Nintendo Entertainment System" "2020 Super Baseball (USA)"
12:04:46 AM |  Launching Game
12:04:46 AM |  Using HyperLaunch
12:04:46 AM |  Getting Launcher path
12:04:46 AM |  Launcher located at D:\RocketLauncher\RocketLauncher.exe
12:04:46 AM |  Running Launcher
12:04:46 AM |  Launcher Command Line is: D:\RocketLauncher\RocketLauncher.exe "Super Nintendo Entertainment System" "2020 Super Baseball (USA)"
12:04:46 AM |  Launching Game
12:04:46 AM |  Using HyperLaunch
12:04:46 AM |  Getting Launcher path
12:04:46 AM |  Launcher located at D:\RocketLauncher\RocketLauncher.exe
12:04:46 AM |  Running Launcher
12:04:46 AM |  Launcher Command Line is: D:\RocketLauncher\RocketLauncher.exe "Super Nintendo Entertainment System" "2020 Super Baseball (USA)"
12:04:46 AM |  Launching Game
12:04:46 AM |  Using HyperLaunch
12:04:46 AM |  Getting Launcher path
12:04:46 AM |  Launcher located at D:\RocketLauncher\RocketLauncher.exe
12:04:46 AM |  Running Launcher
12:04:46 AM |  Launcher Command Line is: D:\RocketLauncher\RocketLauncher.exe "Super Nintendo Entertainment System" "2020 Super Baseball (USA)"
12:04:47 AM |  Loading Main Menu.xml
12:04:47 AM |  Main Menu.xml successfully loaded
12:04:48 AM |  Main Menu wheel loaded successfully
12:04:49 AM |  Exit program unavailable
12:04:49 AM |  Quitting Hyperspin
12:04:49 AM |  Bye!

If anyone can help out let me know!

 

Share this post


Link to post
Share on other sites

Works in RL, not in HS... sure sounds like the path to RL is wrong. Or possibly HS is not active and default frontend in RL??? Agent47 will know better than me.

If you just want the roms you actually have to show up in the wheel, you need to set the "rompath" and "extensions" fields in HQ, then select "rom only" checkbox on the navigation tab.

Sent from my SM-A520W using Tapatalk

Share this post


Link to post
Share on other sites

I think you're right! It's a path issue but I don't know what exactly!?

I checked paths under Global Controls in RL Default frontend Path D:\HyperSpin/Hyperspin.exe

Emulator path D:\Emulators\higanv106.exe

Rom path D:\Roms\Super Nintendo Entertainment System\

Extensions 7z|zip|sfc|gb|gbc

Latest database XML. Roms renamed checked and working through RL but can't get HS to launch any games :/

Selecting "rom only" checkbox on the navigation tab I can't select the system to show any games.

Share this post


Link to post
Share on other sites
I think you're right! It's a path issue but I don't know what exactly!?

I checked paths under Global Controls in RL Default frontend Path D:\HyperSpin/Hyperspin.exe

Emulator path D:\Emulators\higanv106.exe

Rom path D:\Roms\Super Nintendo Entertainment System\
Extensions 7z|zip|sfc|gb|gbc

Latest database XML. Roms renamed checked and working through RL but can't get HS to launch any games :/
Selecting "rom only" checkbox on the navigation tab I can't select the system to show any games.
That first path has a forward slash??? Just a typo?

Also you can't just "roms only" without putting in the path and extension. Remember HQ has nothing to do with launching games! These are set here to specify what shows up on the wheel. Thats all. Just put zip for extension.

Sent from my SM-A520W using Tapatalk

Share this post


Link to post
Share on other sites

It looks like HS is sending the correct command line so it's probably an issue involving permissions between HS and RL (running or not running one or the other as admin).

Share this post


Link to post
Share on other sites

SOLVED!  Thanks, I had to check admin permissions for both RL and HSL :0

Also for anyone else having issues with HSHQ running Win10 when selecting a different rom path crashing simply change compatibility to Win7.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...