Jump to content
thenoob

Adding a new sysyem, not working

Recommended Posts

Ok I must be doing something wrong.

i have an nvidia Shield, I just want to add Atari 2600 to my exsisting setup.

the XML is in the database folder, my Atari 2600.ini is in the Hyperspin/settings folder

i copied over the Atari 2600 default theme from my pc, all relative media from my pc,

still doesn’t show up on the main systems page.  

Where have I gone wrong? I know hyperspin and I’m puzzled why I can’t figure this out

 

Share this post


Link to post
Share on other sites

Thank you!!

now, if I’m putting my roms on a USB flash drive do I need to format it on the nvidia shield? I’ve got the proper model flash drive just don’t know if you have to format it before you put roms on it 

Share this post


Link to post
Share on other sites

Which version of the Nvidia Shield TV did you get? I let my shield re-format mine so I could treat it as internal storage versus external storage. It depends on what you are wanting to do. If you re-format it as internal storage, then if you have the 16GB model, your internal storage increases to the size of your external drive! But, the drive is now encrypted and can only be read by the specific Nvidia Shield TV that formatted it. I use my network to copy files to and from my Nvidia Shield TV. If you are wanting to unplug the drive and connect it to a computer to copy files to it, you may want to leave it as FAT and treat it as external storage. I'm sure smarter people in the forums can provide more insight to the pros and cons of both methods..

Share this post


Link to post
Share on other sites

I’ve got the tv pro 500gb

my sister just got the 16gb, want to copy my hyperspin setup to a proper USB flash drive

jusy don’t knot know if I can leave the factory format or have to format it on the Shield for Hyperspin to recognize it

Share this post


Link to post
Share on other sites

So I’m trying this again and still not working 

here’s a pic of the main menu XML file I edited to add Atari 2600

image.jpg

Share this post


Link to post
Share on other sites

I was almost there

atari 2600 loads, my media is all there, XML database is correct, they are in bin files

my Ini looks correct?

 

the Stella code is downloaded from retroarch.

i get a “warning attempting to load missing rom “ from hyperspin

 

image.jpg

Share this post


Link to post
Share on other sites

I fixed the space gap at the end of the parameter field of “so” and that didn’t work 

Share this post


Link to post
Share on other sites

I noticed you have core with a space and then .so

Shouldn’t have a space there..

And your structure says Emulators/Atari 2600/roms so it would expect to find them treating Hyperspin as your root.

Are they at for example

/sdcard/Hyperspin/Emulators/Atari 2600/roms?


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
Share on other sites

Yup I noticed that

got rid of that space still no dice

ive tried to scan my Atari folder inside retroarch with the bin files and it won’t scan. This is a perfect PD set that I use on my cabinet 

Share this post


Link to post
Share on other sites

As far as the structure goes

all the romsets/systems work fine and are in the same place so the structure should be fine?

Share this post


Link to post
Share on other sites

If everything is in the correct folders and the structure is fine, It would have to be related to either the extension or the database file that you have for Atari 2600.xml. When it says it is missing, may just be the name of the file isn't matching, or the extension that you have defined in the Settings\Atari 2600.ini file. You have yours looking for bin files for the roms, I use the zip extension.

Share this post


Link to post
Share on other sites

Ya it’s weird I’ve checked those

i edited the parameters on the Ini so it looks for bin (mine are unzipped)

maybe ill redoenload the system XML 

Share this post


Link to post
Share on other sites

Try adding bin and BIN

BIN,bin

missing rom trouble shooting

rompath (case sensitive everything exact)

file extensions (non caps and caps for certainty)

games renamed to exactly what's in the database xml file.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...