Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Announcement

    Sorry for the recent downtime. Still much to do but we have the site updated, secure and back online.  Expect more changes.

HyperSpin 1.5.1 Public Release


fr0stbyt3

Recommended Posts

Yep I agree as you guys know im a massive fan of hyperspin and have met some great people while being involved in the community. I think that hyperspin 2.0 will obviously be great but personally I would be more than happy with an easy theme conversion option from 4:3 to 16:9 which seems a bit laborious at the moment, and a tweak so that hypertheme could display and edit both 4:3 and 16:9 (damn hypertheme is a superb little util :-)). Joystick menu support would be cool for people that said I have my navigation sorted via joy2key. I am extremely happy with my setup and would really hope that even with a new release that this version is supported and added to, just little tweaks really.

Its solid and a superb frontend, yes there was a steep learning curve but once you get to grips with it the rewards are worth it.

Keep up the great work guys,

Fire10

  • Like 5
Link to comment
Share on other sites

Unbelievable how much negativity there still is. It's a huge reason why good people leave the project. It's exactly why this is my first post in quite some time. Thanks to everyone involved with the 1.5.1 update. Hyperspin has stood the test of time for me and I still run it on my cab for that reason. I am very appreciative of everyone's hard work here. Thank you!

 

 - J*

  • Like 7
  • Super Like 1
Link to comment
Share on other sites

57 minutes ago, Jumpstile said:

Unbelievable how much negativity there still is. It's a huge reason why good people leave the project. It's exactly why this is my first post in quite some time. Thanks to everyone involved with the 1.5.1 update. Hyperspin has stood the test of time for me and I still run it on my cab for that reason. I am very appreciative of everyone's hard work here. Thank you!

 

 - J*

It's not unbelievable at all, that's what happens when you promise something for years and years but don't deliver anything. That's why good people leave the community.

  • Like 4
  • Haha 1
  • Super Like 1
Link to comment
Share on other sites

Well, if there's support for animated wheels I guess I should release my supergrafx set (if i find it lol). It worked only on older HS build (when a .swf was renamed to .png HS red it, on later build it crashed the software)
 

 

  • Like 3
  • Super Like 2
Link to comment
Share on other sites

Apologies for drudging up the same old stuff, even though I never really post about it for the same reason. Good luck with HS 2.0, those who have been faithfully waiting all these years deserve it. This will prob be my last post/visit.

  • Like 2
Link to comment
Share on other sites

Ah, a question: does this build correct the bug with videos playing on background after a game is launched? Basically it happens when you launch a game with a "slow" RL .ahk and you move the wheel before the emulator actually launch. To avoid the bug i the video can be removed when HS is off-focus and reloaded when HS is in-focus, I haven't intensively tested the method but it seems to work well while loading videos from a .swf.

Link to comment
Share on other sites

6 minutes ago, dark13 said:

Ah, a question: does this build correct the bug with videos playing on background after a game is launched? Basically it happens when you launch a game with a "slow" RL .ahk and you move the wheel before the emulator actually launch. To avoid the bug i the video can be removed when HS is off-focus and reloaded when HS is in-focus, I haven't intensively tested the method but it seems to work well while loading videos from a .swf.

I wasn't aware of this bug. Please PM me and if you have a video of it happening, that would help greatly.

Link to comment
Share on other sites

44 minutes ago, dark13 said:

Well, if there's support for animated wheels I guess I should release my supergrafx set (if i find it lol). It worked only on older HS build (when a .swf was renamed to .png HS red it, on later build it crashed the software)
 

 

Yes please, those look awesome. I'm assuming they would work normally in the artwork4 folder also?

 

And to keep this thread on track, thank you for the quick fix. I have had the internet unplugged from my pc for the past week to avoid the windows update while I waited for this fix

  • Like 1
Link to comment
Share on other sites

Hey guys, thanks for all the great work. I do have one issue, though. This update kinda messed up the wheel positioning for my Dungeons & Dragons theme. I tried to re-position the wheel images but the images are skewed to the right and the middle image is way off center and sits closer to the right-hand images. When I first looked at it, the images were way out of whack.

BEFORE: (This is a much more desirable look for a horizontal wheel)D&D_before.png.af1be6602d0472c6c4fc878213de95cc.png

AFTER (The center image starts from the same top position as the small images and skewed to the right - this doesn't look correct)

D&D_after.png.c54cbb2e06c4b6a5dbd54aa1a0d2ff06.png

Link to comment
Share on other sites

1 hour ago, malarrya said:

Hey guys, thanks for all the great work. I do have one issue, though. This update kinda messed up the wheel positioning for my Dungeons & Dragons theme. I tried to re-position the wheel images but the images are skewed to the right and the middle image is way off center and sits closer to the right-hand images. When I first looked at it, the images were way out of whack.

BEFORE: (This is a much more desirable look for a horizontal wheel)D&D_before.png.af1be6602d0472c6c4fc878213de95cc.png

AFTER (The center image starts from the same top position as the small images and skewed to the right - this doesn't look correct)

D&D_after.png.c54cbb2e06c4b6a5dbd54aa1a0d2ff06.png

This is being looked at...Thanks for the report

  • Like 2
Link to comment
Share on other sites

I did notice something like that when I opened a theme inside hypertheme everything was out of position. Not sure which theme it was at top of my head.

 

Not all themes do it. I can try again tonight see If I can duplicate it and give more details.

 

Sent from my iPhone using Tapatalk

 

 

 

 

  • Super Like 1
Link to comment
Share on other sites

53 minutes ago, Krakerman said:

I did notice something like that when I opened a theme inside hypertheme everything was out of position. Not sure which theme it was at top of my head.

 

Not all themes do it. I can try again tonight see If I can duplicate it and give more details.

Please do... :) the more specific info the easier to fix normally

  • Like 1
Link to comment
Share on other sites

Please do... [emoji4] the more specific info the easier to fix normally

 

Will do. When 1.5.1 got released I quickly just tested a few things and I’d like to say might been the 1942 theme but not 100% certain. I will check a few tonight and see what happens.

 

 

Sent from my iPhone using Tapatalk

 

  • Like 1
Link to comment
Share on other sites

6 hours ago, malarrya said:

Hey guys, thanks for all the great work. I do have one issue, though. This update kinda messed up the wheel positioning for my Dungeons & Dragons theme. I tried to re-position the wheel images but the images are skewed to the right and the middle image is way off center and sits closer to the right-hand images. When I first looked at it, the images were way out of whack.

BEFORE: (This is a much more desirable look for a horizontal wheel)D&D_before.png.af1be6602d0472c6c4fc878213de95cc.png

AFTER (The center image starts from the same top position as the small images and skewed to the right - this doesn't look correct)

D&D_after.png.c54cbb2e06c4b6a5dbd54aa1a0d2ff06.png

Are you using .swf as wheel image? Check the documentation, while creating file in flash you need to set 1px*1px stage size and move the image you load on stage on negative values to get it centerd (es if your image is 640*480 set -320 on X and -240 on Y). I was having the same issue, then i RTFM :P

Link to comment
Share on other sites

i'm running into the same issue with SWF files, not all of us use Adobe to make wheel icons or swf files, I'm using Aurora 3D text and logo maker, and it's shifting all the SWF wheel icons to the right. Is there any way an offset can be created in the settings.ini for the menu?  The only application that i know of that you can make use a negative stage is adobe. 

Link to comment
Share on other sites

i'm running into the same issue with SWF files, not all of us use Adobe to make wheel icons or swf files, I'm using Aurora 3D text and logo maker, and it's shifting all the SWF wheel icons to the right. Is there any way an offset can be created in the settings.ini for the menu?  The only application that i know of that you can make use a negative stage is adobe. 
Can you pm me some sample files?

Sent from my Pixel 2 XL using Tapatalk

Link to comment
Share on other sites

14 hours ago, dark13 said:

Are you using .swf as wheel image? Check the documentation, while creating file in flash you need to set 1px*1px stage size and move the image you load on stage on negative values to get it centerd (es if your image is 640*480 set -320 on X and -240 on Y). I was having the same issue, then i RTFM :P

I don't use flash or SWF but have never had any issues.

Link to comment
Share on other sites

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...