Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Announcement

    Sorry for the recent downtime. Still much to do but we have the site updated, secure and back online.  Expect more changes.

HyperSpin 1.5.1 Public Release


fr0stbyt3

Recommended Posts

10 hours ago, Gothicplsur said:

Why does my anti-virus (It's Microsoft Essentials since I don't surf porn or stupid sites on my PC) Go ape shit and deletes the Hyperspin.exe and icon shortcut every time I reboot?

As already discussed in this thread you need to add Hyperspin as an exclusion so the dumbass AV doesn't dump it. 

  • Like 1
Link to comment
Share on other sites

All this moaning about anti virus, just set up an exception for the whole hyperspin folder in whatever anti virus your using. 

If anything gets deleted there's All ways a way to reverse the delete then just add an exception for where ever that file was stored..

Link to comment
Share on other sites

What I have taken away from this whole thread is that NO ONE READS THE WHOLE THREAD.  So please put a huge, unable to be missed Disclaimer on the download notice, the download and even on the actual zip file so that when you unzip it, you would have had several notices about the issue.  I cannot tell you how many times this very issue comes up in trouble shooting this software for people.

 

That being said, people are still not going to read the notices so it is probably a waste of time :D

Link to comment
Share on other sites

On 5/23/2018 at 11:42 PM, fr0stbyt3 said:

I've never heard of this before. Can you point me to a thread on it?

 


Sent from my Pixel 2 XL using Tapatalk
 

 

Yes!  @fr0stbyt3Here it is:

 

If you enable portaudio in MAME, sound will stop in hyperspin after returning to it after exiting a MAME game.  For now I've been going without audio in hyperspin because I prefer less input lag.  :)

Link to comment
Share on other sites

Thank you guys so much for keeping up with HyperSpin. I was worried it was lost when win10 got so weird. 

I upgraded to 1.5.1, and havent changed anything else, but now Hyperspin cannot find HyperLaunch. I have the directory in settings, but the log confirms it just cannot find HyperLaunch any longer. I have not switched to RocketLauncher yet - is this a requirement?

 

Again, Thanks a ton for the support

Link to comment
Share on other sites

24 minutes ago, doccabet said:

Thank you guys so much for keeping up with HyperSpin. I was worried it was lost when win10 got so weird. 

I upgraded to 1.5.1, and havent changed anything else, but now Hyperspin cannot find HyperLaunch. I have the directory in settings, but the log confirms it just cannot find HyperLaunch any longer. I have not switched to RocketLauncher yet - is this a requirement?

 

Again, Thanks a ton for the support

I had the same issue after upgrading.  You need to modify the HyperLaunch_Path in your Settings.ini.  At some point the path was changed to expect the path to the .exe, rather than the containing folder.

Try:

Hyperlaunch_Path=.\HyperLaunch\HyperLaunch.exe

 

Link to comment
Share on other sites

On 26/05/2018 at 6:44 PM, gigapig said:

I've become so pissed off with Windows 10 on my cab that I've  just wiped it and gone back to W7. Not looking forward to setting up the Ultrastiks again but I'm already happier.  

Yep me to. Windows 7 is the only system I use for all my cabs..can't stand windows 10

Link to comment
Share on other sites

I use Sophos AV and had the Hyperspin folder on exception for the past few years with no issues. With the latest Hyperspin build, Sophos freaks out and constantly removes the 3 main EXE files from the Hyperspin folder. I even told Sophos to exclude these specific EXEs and it still doesn't care. I'll just await an update that fixes all these issues. :)

Link to comment
Share on other sites

Does anyone know if it’s worth me updating?  I’m using win7 and no intension of using win10,  my pc is barebones, nothing else installed other than hyperspin and mame, no anti virus, no defender, nothing. Everything’s switched off that doesn’t need to be running and it’s really good....   apart from hyperspin menu freezing after a few hours and despite trying everything other than turning off attract mode (will try this later)  I can’t get rid of this problem,  also the player 1 joystick becomes erratic too.    

If the new version isn’t going to solve this is it worth me updating?

Link to comment
Share on other sites

4 hours ago, Martin0037 said:

Does anyone know if it’s worth me updating?  I’m using win7 and no intension of using win10,  my pc is barebones, nothing else installed other than hyperspin and mame, no anti virus, no defender, nothing. Everything’s switched off that doesn’t need to be running and it’s really good....   apart from hyperspin menu freezing after a few hours and despite trying everything other than turning off attract mode (will try this later)  I can’t get rid of this problem,  also the player 1 joystick becomes erratic too.    

If the new version isn’t going to solve this is it worth me updating?

I would say if it ain't broke don't fix it.

I can't say if there is anything in this release that fixes those issues to make it worthwhile, though I doubt it.

That said, all this involves is copying some updated executables over so I don't see why you couldn't try it yourself and roll it back if you have issues.

 

Link to comment
Share on other sites

9 hours ago, Martin0037 said:

Does anyone know if it’s worth me updating?  I’m using win7 and no intension of using win10,  my pc is barebones, nothing else installed other than hyperspin and mame, no anti virus, no defender, nothing. Everything’s switched off that doesn’t need to be running and it’s really good....   apart from hyperspin menu freezing after a few hours and despite trying everything other than turning off attract mode (will try this later)  I can’t get rid of this problem,  also the player 1 joystick becomes erratic too.    

If the new version isn’t going to solve this is it worth me updating?

As Rowr said really, back up your 1.4 exe or rename it and then try 1.5.1. My guess is that you will notice no difference, so no harm done. 

Link to comment
Share on other sites

Is anyone else getting an issue with rocket launcher? Hyperspin won't launch games after the update (or full install). The log file says it can't find hyperlaunch in the path. I have the rocket launcher exe renamed to hyperlaunch but it says it can't find it. I reset all the paths in hyperHQ but that did not work either. 

Link to comment
Share on other sites

11 minutes ago, dangerranger96 said:

Is anyone else getting an issue with rocket launcher? Hyperspin won't launch games after the update (or full install). The log file says it can't find hyperlaunch in the path. I have the rocket launcher exe renamed to hyperlaunch but it says it can't find it. I reset all the paths in hyperHQ but that did not work either. 

There is no renaming necessary you need to open the settings.ini found in the settings folder and add the full path to the Rocketlaucher exe. 

  • Like 1
Link to comment
Share on other sites

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...