Jump to content
HyperSync, HyperList and FTP are now back online ×
richie_jones

Odroid XU4 Mini Build

Recommended Posts

So ive decided to do a mini build based on the XU4.

So far ive got the base board and sides with components in place ready to wire up.

After some opinions on whats the best way for powering on and off.

Screenshot_20180720_213929_Gallery.jpg

Sorry for the crap diagram.

This is what im thinking...

Incoming supply is 12V 6amp , positive wire goes straight to the power switch on the front right side.  Its a latching switch..
This then comes out the switch and powers a 12volt to 5v usb power hub (Middle Circuit board) Shown Below

hub.jpg

This board will be used to power a 1tb ssd housed in the screen area. Plus the screen. Plus anything else needing 5v. I needed this as there are only 3 usb ports on the XU4

Back to the wiring. The 12v live then goes to a fan controller board, shown below.

fan.jpg

This controls the 2 50mm side fans and has a temp probe and a warning system. The XU4 likes to run hot.

The live then powers a DC/DC Buck Voltage Regulator Power Converter,

dc.jpg

The reason i`m using this is i only wanted 1 power supply cable into the cab. If that was a 5v supply ( Which the XU4 requires) i`d be limited in what extras i could fit, what fans i could use and the XU4 is pretty power hungrey also so i`m led to believe.
It should give out a nice clean 5v supply to the XU4 

Screenshot_20180720_213929_Gallery.jpg

Back to the picture again and the negative from the incoming 12v just daisy chains to each 12v board.

Now the XU4 just gets its juice from the output of the convertor set at 4.8ish volts.

The picade will be powered via its usb connection to the XU4.

One USB 3 port on the XU4 will go to a small usb hub for 4 more extra ports.


So the problem i`ve got is, you press the power switch and everything comes on. XU4 boots and loads up retropie.

When you want to stop playing you select shutdown from the menu and the XU4 powers down correctly.

But all the other boards will still be powered up because the power switch is still plugged in. Not really an issue but it would bug me.

The other scenario would be that someone presses the power switch whilst its running and powers it down and eventually the sd card becomes currupt..

So ideally i`d prefer a momentary switch on the power switch on the side., press this and it all boots, press again and it performs a proper shutdown.

i have no idea how to get that working. I`m presuming maybe two wires on the GPIO pins???

 

 

 

Share this post


Link to post
Share on other sites
8 minutes ago, richie_jones said:

Are the pictures working there not showing up on my phone. Look like broken links???

If we click on them it loads a page with the image. Circo has been on the case lately working on the website to fix issues, he's been laid up for months with a broken leg (as have I). Raise the issue on the site maintenance thread and I'm sure he'll look into it.



Nice looking little cabinet. Loved seeing the Lemmings walking off the blocks, that's a nice touch us Amiga fans can appreciate :)

Share this post


Link to post
Share on other sites

Thanks. Didnt explore the startup shutdown issue any more...I just select quit in emulation station wait a few seconds after the screen goes off the turn the power button off on the back..
Boots up when power button turned back on..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...