Jump to content
HyperSync, HyperList and FTP are now back online ×
samwyze

FPLaunch MOD: Pause and Loading screens...

Recommended Posts

Thanks blur,

exit is mapped to E, maybe cpu is bit slow (athlon 6000+3ghz), but i am happy with fade set to 25.

Was just playing about with settings really.

Share this post


Link to post
Share on other sites
Hyphycus did you just save the image from the page or download from the links?

I tried both ways.

Share this post


Link to post
Share on other sites

I am using the latest script, and have 2 problems / questions. If I hold my Exit Button down for 5 seconds its exiting hyperpin which I don't want it to do (I have it disabled in hyperpin config, is there something in the script overwriting this? Second If in Hyperpin and I hit my Start button and hold it, it freaks out after a while and sends a ton of repeats (can hear it playing a wave file for keyboard error or whatever)

Share this post


Link to post
Share on other sites

hey there guys,

I'm experiencing problem similar to a guy from few pages back. The dmd is always in the back, and when I try to bring it to front, it goes to the back whenever I click on the playfield. from what I read it was supposed to be fixed in wip3 but still no go for me. how can I set pinmame to be in front of the playfield?

thanks for hard work - launching and exiting tables is finally pretty:)

Share this post


Link to post
Share on other sites

This is an excellent add on for hyperpin, just wondering if it would be possible for a short sound to be played while the table loads ?? or even a voice clip saying "loading"

Share this post


Link to post
Share on other sites
I am using the latest script, and have 2 problems / questions. If I hold my Exit Button down for 5 seconds its exiting hyperpin which I don't want it to do (I have it disabled in hyperpin config, is there something in the script overwriting this? Second If in Hyperpin and I hit my Start button and hold it, it freaks out after a while and sends a ton of repeats (can hear it playing a wave file for keyboard error or whatever)

I think none of these problems doesn't have anything to do with fplaunch.

When you are in hyperpin fplaunch is not running so it can't change anything.

Share this post


Link to post
Share on other sites
hey there guys,

I'm experiencing problem similar to a guy from few pages back. The dmd is always in the back, and when I try to bring it to front, it goes to the back whenever I click on the playfield. from what I read it was supposed to be fixed in wip3 but still no go for me. how can I set pinmame to be in front of the playfield?

thanks for hard work - launching and exiting tables is finally pretty:)

you have dmd on playfield?

it's a known problem. it is not fixed in wip 3 but in my new version that i'm testing (wip 4)

you have to:

alt-tab to dmd

click on dmd

click on pf

then dmd should stay on top

i'm doing this in my new fplaunch script

other method is to just press f3

Share this post


Link to post
Share on other sites
you have dmd on playfield?

it's a known problem. it is not fixed in wip 3 but in my new version that i'm testing (wip 4)

you have to:

alt-tab to dmd

click on dmd

click on pf

then dmd should stay on top

i'm doing this in my new fplaunch script

other method is to just press f3

when i launch manually the table then then everything works as it should (dmd in front of the playfield). Sounds good, in that case I can't wait for wip4 as it is driving me nuts (getting up from the bad every time I select new table:))

regards and thanks again for all your work.

Share this post


Link to post
Share on other sites

aside from the hidden dmd, i have one more issue.

when i press and hold esc, I'm getting the exit screen and everything is great. Whats weird is that when I assign "esc" to a button in xpadder, then it does not work. What happens is the pause screen comes and goes repeatedly. Anyone experienced this? (probably a xpadder issue and not fplaunch unless its somwhere in the script that it looks for physical keyboard button press?

Share this post


Link to post
Share on other sites
aside from the hidden dmd, i have one more issue.

when i press and hold esc, I'm getting the exit screen and everything is great. Whats weird is that when I assign "esc" to a button in xpadder, then it does not work. What happens is the pause screen comes and goes repeatedly. Anyone experienced this? (probably a xpadder issue and not fplaunch unless its somwhere in the script that it looks for physical keyboard button press?

Yes I noticed this as well. I had to roll back to an older FPLaunch.exe to get it to work. I had a raft of issues I was trying to resolve at the time so I didn't even think to reassign the ESC key to see if the problem went away! On reflection I may have read something about it "somewhere".

I might try again once I'm happy that the 167 other problems I'm having are done with........

Share this post


Link to post
Share on other sites

found out solution to the xpadder esc key. After trying all different special holds and releases along with times and distance values, it turns out all we need to set is esc followed by "add cycle stop" whatever that means. Whats important, is that it works now just as esc keyboard key:) now, aside from dmd behind, all it working freaking great!

Share this post


Link to post
Share on other sites

Actually you don't have to map esc key to anything.

I use xpadder with joystick and I use button 1 for exit in hp, vp and fp without mapping it to esc.

In HP i set button one as exit button in pinball wizard section:

[Pinball Wizard]
Joy                 = 0 -> set your gamepad id (number 0,1,2,...)
Start               = 9
Exit                = 8 -> change this to 1 or whatever is your exit button.

In fp and vp you don't need to configure anything to exit button, actually you must not have anything mapped to exit button.

And for fplaunch you set exitemulator key to Joy1 in settings.ini

Sending esc key with xpadder can be a problem because of two reasons:

1. autohotkey could not be able to stop esc key - so esc key will come to fp and vp and close fp or open exit menu in vp which will break pause functionality

2. it is difficult to detect if virtual key is pressed - so long press for exit could stop working

Any way, deathevil it is not quite clear how did you added cycle stop, in xpadder configuration you add one cycle stop after esc in advance options?

Did it solved 1 and 2 or only 2? If it solves both - it's a great find!!!

Edited by blur

Share this post


Link to post
Share on other sites

Any way, deathevil it is not quite clear how did you added cycle stop, in xpadder configuration you add one cycle stop after esc in advance options?

Did it solved 1 and 2 or only 2? If it solves both - it's a great find!!!

yes, one cycle stop after esc in advanced options:)

it did solved 1 and 2 as I can exit vp and hyperpin with it:) I dont use FP so don't know if it works there too, but I don't see why it should not (since it works in vp).

your solution is great, but I prefer xpadder since I can assign id to spcific pad, and I have quite a few including arcade sticks etc. For someone with one pad that is best solution though.

regards

EDIT: pic for better understanding

unledqz.png

Edited by DeathEvil

Share this post


Link to post
Share on other sites

I've tried this cycle stop and it did not solved problem 2 for me.

I still have pause flashing so long key press doesn't work.

But i tried again fplaunch 1.2 from bbb and it works fine with long key press - so i will try to find what is different in my code. Code around it looks the same - probably the difference is in #statements - like #noenv and #maxthreadsperhotkey and so on. I will comment them all and try without them.

Share this post


Link to post
Share on other sites

have you tried to hold it for more than 4 seconds? I noticed that after starting hyperpin it takes about 4 seconds for exit feature to start working after which it works immidiately just as with the esc keyboard key. I know, sounds strange, and I'm not quite sure with the reasoning behind this...

Share this post


Link to post
Share on other sites

yeah i noticed that, after few seconds of pause flashing it starts to show exit321 screens, but then it shows them and exits even on short key press

that's not normal behavior, normal is to not show anything at first and then to show exit321 if it is long press and pause if it is short key press

anyway i was very angry and decided i have to find out what kills long press on esc key mapped to some button with xpadder

so i took my fplaunch 1.295 wip 4 and bbb 1.2 and compared it

i commented maybe 10 #statements, but nada, still nothing

so i took only command for checking keypress and started testing with that simple ahk script

it worked for esc key mapped from button with xpadder

so i started adding code around it

it broke when i added * for hotkey

* in front of key allows for any modifier (shift, alt or ctrl) to be pressed with esc, so that you can press pause while you hold ball on flipper

but if your flippers are not shifts then * is not needed - I use left and right arrows for flippers and it is convenient cause you can go left and right if some dialog box pops up

if you also map up and down arrow to nudge or magnasave you can even play baby pacman

so * had to go

after that i removed * from my fplaunch and it was still no go

so i commented all # statements, and it woked again

then i started to uncomment # statements one by one to see which one breaks long press functionality

and i found that it is #usehook statement

so if you remove #usehook statement and * from hotkey esc mapped to some gamepad button with xpadder will work just like esc from keyboard

i'm not sure about joy2key - still have to test it

unfortunatelly it will not work in fp - so for fp you will still need to use joy1 button

i will probably put these two fixes (for hidden dmd and for long keypress) in fplaunch and publish wip 4 version soon

Edited by blur

Share this post


Link to post
Share on other sites

thats some nifty elimination you got there going - glad you found the problem, and cant wait for wip4 (mainly for dmd as I dont use FP).

regards

Share this post


Link to post
Share on other sites

gee this problem with button working in bbb 1.2 and not working in 1.295 was bugging me for a long time :motz:

i'm also glad it is finally solved :party:

Share this post


Link to post
Share on other sites
Guest gstav

Hi blur!

Don't know if anyone have addressed this issue yet, but when I pause or exit a table when a solenoid/flasher (LEDWiz output is active) the output remains.

(even when you exit the HP to windows)

Not that fun when the shaker is on upon exit(!)

This happends with the 1.295 WIP 3, but it does not with the original FPLaunch.

Is it possible to kill all LEDWiz activity upon pause/exit for the next WIP?

Regards :D

Share this post


Link to post
Share on other sites

I can't test ledwiz cause I don't have it. And I can't put any ledwiz code in it cause script will be incompatible with most of the people that don't have it but you can put whatever code is missing and recompile.

I could maybe put some commented code for ledwiz folks to uncomment but can't test it or debug it. I can only debug it so that it works without problems without ledwiz.

Share this post


Link to post
Share on other sites
Guest gstav

I would love to test a FPlaunch like that Blur!

Shame I don't know any coding though! :(

But if you could insert some experimental commented coding in the new WIP I would be more than happy to uncomment it and try! :D

Thanks for all your hard work!! Appreciate it!

Cheers!

Share this post


Link to post
Share on other sites

Would be cool to get some LedWiz code in there somewhere.

Mainly for poeple having crees/shakers going on when exiting, and i would love to "sawtooth" that little pause button when paused ;)

Keep it up blur, love it! =)

Share this post


Link to post
Share on other sites
Hi blur!

Don't know if anyone have addressed this issue yet, but when I pause or exit a table when a solenoid/flasher (LEDWiz output is active) the output remains.

(even when you exit the HP to windows)

Not that fun when the shaker is on upon exit(!)

This happends with the 1.295 WIP 3, but it does not with the original FPLaunch.

Is it possible to kill all LEDWiz activity upon pause/exit for the next WIP?

Regards :D

in talking to Chriz, this is normal. In the case of having the ledwiz etc, you should actually be running the hpledcontrol exe for launching hyperpin and not the hyperpin exe.

Share this post


Link to post
Share on other sites

oki doki

here is wip 4 dowloand link

http://www.megaupload.com/?d=WYOL5D3D

and upload.com link:

http://uploading.com/files/e117534e/FPLaunch1.295wip4.zip/

and mediafire link:

http://www.mediafire.com/?akzu7f77ej97ar3

test it and let me know how it works

if everything is ok I'm updating manual on first page and my sig with link to new version

new features are:

- fixed dmd behind playfield

- fixed esc key mapped over xpadder or joy2key

(I've tested joy2key - works same as xpadder, so vp works, fp not)

- added link to fplaunch manual on start of ahk script - read the manual!

- added code map on start of ahk script

- put most of "external" code from rosve and bigboss to functions for better "visibilty"

- some small fixes on nag screens, error screens and so on

- and another addition for my dear friend bent:

for slamit bigscore keys left ctrl, right ctrl, f, g, i are all mapped to enter

(magnasave, flyer, genre and instructions keys) so you can use whichever key you have on your cab

so actually there is no new features but lots of bug fixes and reorganizations

Edited by blur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...