Jump to content
HyperSync, HyperList and FTP are now back online ×
samwyze

FPLaunch MOD: Pause and Loading screens...

Recommended Posts

Any idea when the new version will be released ? looks fantastic

Yep - in the future and definately not in the past :P

We're getting there - Neither Blur nor I have alot of time at mo (work, families etc...) but we haven't stopped, just slowed!

I'm thinking, after Future Pinball support is added we may just release it in it's unfinished state (example: service menu is non-functional, exit menu is being rewritten), as I believe users should be able to swap back to wip4 if there are major issues, without any hassle.

Share this post


Link to post
Share on other sites

Ok

THat triple strike was on my end. I didnt have script set to false.

Edited by bent98

Share this post


Link to post
Share on other sites

What's the best way to disable LEDs but still take advantage of this script?

I think the LED stuff is boggign down my machine quite a bit. Tables that I had no stutter in before are now almost unplayable with the LEDs. I'm going to be building a new PC and will add the LEDs back at that time.

Share this post


Link to post
Share on other sites

leds are not part of this script

i think ledcontrol is loaded from core.vbs

Share this post


Link to post
Share on other sites

Quick update:

Just when I had it looking good for my setup, I had to go test UVP and B2S. Damn focus issues back - LOL

Think I've got things wrapped up now though - gona be sending Blur a beta soon.

That's right BETA, well at least it's outa APLHA :P

Share this post


Link to post
Share on other sites
Sweet!

Dont forget the Slam it Bigscore fix Blur

If it was in wip4 it'll still be there - or was it a bugfix?

Share this post


Link to post
Share on other sites

bug fix - ahk stops on first :: comand

so you have to be very careful where you put it

it is already fixed, just waiting for menus to release it

Share this post


Link to post
Share on other sites
bug fix - ahk stops on first :: comand

so you have to be very careful where you put it

it is already fixed, just waiting for menus to release it

Cant wait for this release.

Come on guys. :)

Share this post


Link to post
Share on other sites
bug fix - ahk stops on first :: comand

so you have to be very careful where you put it

it is already fixed, just waiting for menus to release it

Don't quite understand - aren't the only hotkeys that use :: wrapped in #IfWinActive already in wip4?

Side note, the ahk_l has an #If command that can be use like #IfWin...,

so #If Any valid expression...,could be handy

Share this post


Link to post
Share on other sites

I don't know if this is a focus issue or what but many times when i start up the machine and launch the first table (any table) it starts the table but rendering table message remains. The table is started but the rendering message remains. I need to get out the keyboard and press alt tab to get the focus back to the table. I'm running version 294 wip so i dont know what the problem is.

It does not happen all the time but at least 60% of the time.

I also found that if i play my first game, say star trek 25 anniversary and shutdown the machine power it off then turn the machine back on and play star trek 25 anniversary, i dont have a problem with the rendering table message. This may just be a fluke but the rendering table / focus issue is becoming a pain in the but.

Share this post


Link to post
Share on other sites
I don't know if this is a focus issue or what but many times when i start up the machine and launch the first table (any table) it starts the table but rendering table message remains. The table is started but the rendering message remains. I need to get out the keyboard and press alt tab to get the focus back to the table. I'm running version 294 wip so i dont know what the problem is.

It does not happen all the time but at least 60% of the time.

I also found that if i play my first game, say star trek 25 anniversary and shutdown the machine power it off then turn the machine back on and play star trek 25 anniversary, i dont have a problem with the rendering table message. This may just be a fluke but the rendering table / focus issue is becoming a pain in the but.

I have the same, but only 10% of the time.

However pushing pause and then "enter" resolves lost of focus.

That way a can continue without fully having to exit the table or pressing alt-tab.

Share this post


Link to post
Share on other sites

legtod, numiah do you have nt compatibility mode set on vp exe?

numiah can you get focus with exit exit (pause and unpause) or just with pause enter, cause as i remember pause enter exits from the table?

sam yes :: was wrapped in #ifwinactive but still it makes ahk stop, something similar is reported for modules - if you put :: to early in the module code script just stops on that row

as for ahk_l i don't think it's a good idea to jump into it, thousands of bugs could appear

Share this post


Link to post
Share on other sites

The pause and unpause did bring focus back to the table.

Blur i will check.

Yup that did it blur, I set to nt compat and first lauch of table got the focus.

Edited by legtod2

Share this post


Link to post
Share on other sites

Hi Blur,

I'm not sure if anyone's mentioned this before or if it's just happening to me, but I do have the odd occasion when I exit a VP table where it will return to Hyperpin but it's no longer active. If I hit ALT-Tab there is a process called DieMWin (not 100% sure and I can't get it to happen now I need the details), and if I then hit Alt-F4 to kill that process it will return to normal and everything works as before. I'm using Windows XP, have NT Compatibility on Hyperpin.exe and have my Exit key mapped to 'E'. Not sure if you've seen this before or not. This is with the latest wip from this forum.

Thanks a lot,

Mick

Share this post


Link to post
Share on other sites

hyperpin doesn't need compatibility mode

only vp exe needs comp. mode (vpinball.exe and all others if you use them)

not sure if this could cause the problem - try to change it and see if problem happens again

Share this post


Link to post
Share on other sites
legtod, numiah do you have nt compatibility mode set on vp exe?

numiah can you get focus with exit exit (pause and unpause) or just with pause enter, cause as i remember pause enter exits from the table?

sam yes :: was wrapped in #ifwinactive but still it makes ahk stop, something similar is reported for modules - if you put :: to early in the module code script just stops on that row

as for ahk_l i don't think it's a good idea to jump into it, thousands of bugs could appear

Sorry, I indeed meant pause/unpause lol

edit : I run XP without any compatibility mode.

Share this post


Link to post
Share on other sites

That's why you have focus problems. nt comp. mode solves focus problems.

Share this post


Link to post
Share on other sites
hyperpin doesn't need compatibility mode

only vp exe needs comp. mode (vpinball.exe and all others if you use them)

not sure if this could cause the problem - try to change it and see if problem happens again

Thanks Blur so just to confirm:

1) Hyperpin.exe set as standard (no compatibility mode)

2) Visual Pinball exe - set as nt compatibility mode

By all others do you mean I should set UVP and FP to nt compatibility as well? I'll revert Hyperpin back to normal and let you know if I hit that issue any more. Thanks again for the help.

Mick

Share this post


Link to post
Share on other sites

yes for confirmation

and no for all others - i think uvp and fp don't need comp. mode

by all others i meant if you use vpinball.exe, vpinball908.exe, vpinbal905.exe and so on

cause with the inclusion of scripts from big boss it is possible to use many vp versions

Share this post


Link to post
Share on other sites
yes for confirmation

and no for all others - i think uvp and fp don't need comp. mode

by all others i meant if you use vpinball.exe, vpinball908.exe, vpinbal905.exe and so on

cause with the inclusion of scripts from big boss it is possible to use many vp versions

Thanks blur - updated VP settings to NT compatible and removed them from hyperpin.exe. Been playing for the last hour or so and haven't seen the issue so far - looking good. Thanks again for your help.

Mick.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...