Jump to content
HyperSync, HyperList and FTP are now back online ×
samwyze

FPLaunch MOD: Pause and Loading screens...

Recommended Posts

Quick question, not sure if it has been covered already... is there any way to make the exit button not do anything on a a short hit. I like how it exits but holding the exit button down but a quick hit brings up the exit VP screen and hitting it again does nothing, the only way out is to hold it down and exit. I am sure I have some thing configured incorrectly. Any insight would be appreciated.

Thanks!

Share this post


Link to post
Share on other sites

use some other key - not escape - there is no way to fix escape since it is hardcoded in vp - but this is all explained in fplaunch manual - did you read fplaunch manual?

Share this post


Link to post
Share on other sites
I seem to have delayed launching of a table sometimes. I know I hit my start button on the hyperPin screen and nothing seems to happen. I wait a bit and then hit a flipper button and I instantly get the loading animation on the screen and table launches. Any Ideas? Dont remember having this issue with WIP8, only WIP9. Great addition to HP Blur, thanks

put debugmode to file and check what you get in log, or post it here. i never had problems with loading of the tables

Share this post


Link to post
Share on other sites

I just updated to wip9 coming from wip7 as I had some troubles with launching newer tables as Genesis.

Everything works as expected.

Thank you for all your time and effort Mr. Blur.

It's really appreciated !

Share this post


Link to post
Share on other sites

Hey Blur - I know it's possible to use different versions of the VP executable but wasn't sure about FP? As always - thanks!

Share this post


Link to post
Share on other sites

Weird issue I'm having:

I'm using the latest WIP and everything was working fine for quite some time! But now when I load up hyperpin it seems to freeze on start up, I have to hit control alt delete to quit out and then load it up again and it's fine! Problem is I'm using a cab and don't want to have the key board handy every time I sart it up! What could be causing this? Im using windows XP!

Also, I've already tried to reinstall fplaunch and the other stuff that comes with it didn't work!

Anyone have any ideas on why it keeps hanging on start up or how I can fix this??!

Edited by ICPjuggla

Share this post


Link to post
Share on other sites

Having similar issues here as well. On first start up everything runs slow,but when I shut down hyper pin and start it up again it works fine as well. Must be some other programs running causing this . Damn Windows 7 . I did notice that cleaning up my xml file helped with the speed, that could be causing the lockup?

Share this post


Link to post
Share on other sites

looks like win 7 bugs, cause when you start hyperpin there is no fplaunch yet, so it could not cause freeze

try using xml with only one game in it.

Share this post


Link to post
Share on other sites


looks like win 7 bugs, cause when you start hyperpin there is no fplaunch yet, so it could not cause freeze

try using xml with only one game in it.

I'm using windows XP, I'll give it a try later tonight with only one table set up in the XML and let you know!

Share this post


Link to post
Share on other sites

I just installed the new FPlaunch. When I exit from a VP table, the DMD stays on my third screen and audio is still running in the background. I can start another table, but ultimately I will have to exit hyperpin and close the original table from within the VP editor. Any ideas?

Share this post


Link to post
Share on other sites

Make sure you don't have the VP editor already open when you launch HP. I've seen it cause this exact problem before.

Share this post


Link to post
Share on other sites

It wasn't. I have seen many previous posts about this. My .akh file matches the revised one. I'm running XP. There is no problem exiting a FP table. Only Visual Pinball...

****Edit**** I am up and running. I reinstalled the FP launch and for some reason, I have no issues.

Edited by golfboy01

Share this post


Link to post
Share on other sites

Hello,

Here's a little request for Hyperpin/FPLaunch

When the emulator starts, it displays the first alphabetical table available.

Would it be possible to have a random table displayed instead?

Share this post


Link to post
Share on other sites

That would be a cool feature. If I want to play something randomly I'll wait for it to spin and then play that table. You can change the lag too so that may be an option for you in the interim but I second this feature.

Share this post


Link to post
Share on other sites

Sorry what and how do I put it in debugmode (FPLaunch.ahk, Hyperpin, VP?) thanks

put debugmode to file and check what you get in log, or post it here. i never had problems with loading of the tables

Share this post


Link to post
Share on other sites
Hey Blur - I know it's possible to use different versions of the VP executable but wasn't sure about FP? As always - thanks!

*bump*

Share this post


Link to post
Share on other sites
*bump*

I thought you found the answer already since you say you "wasn't" sure - the answer is no, different exe for fp is not supported but you can edit the script and use same code as for vp to make it possible.

Share this post


Link to post
Share on other sites
Sorry what and how do I put it in debugmode (FPLaunch.ahk, Hyperpin, VP?) thanks

debugmode is option in settings.ini - it is all explained in FPlaunch manual on first page!

Share this post


Link to post
Share on other sites
Hello,

Here's a little request for Hyperpin/FPLaunch

When the emulator starts, it displays the first alphabetical table available.

Would it be possible to have a random table displayed instead?

not possible - fplaunch is not executed on start of hyperpin

Share this post


Link to post
Share on other sites

ok, that's why I put Hyperpin/FPLaunch in my request, because I don't know what would need to be updated ;)

How can I raise my request then?

Thx

Share this post


Link to post
Share on other sites
Hello,

Here's a little request for Hyperpin/FPLaunch

When the emulator starts, it displays the first alphabetical table available.

Would it be possible to have a random table displayed instead?

This is easilly done if you do a autohotkeyscript that when you start hyperpin it press the button to change tables by a random time.

Share this post


Link to post
Share on other sites

Well, I am thinking about having a random choosen table in the first table, without the spinning animation, without having to wait the spinning to finish

Share this post


Link to post
Share on other sites
This is easilly done if you do a autohotkeyscript that when you start hyperpin it press the button to change tables by a random time.

Actually it would be even better if you could just load the LAST table played. This is stored in the settings file anyway so why not use that? This at least makes the start up different and let's you carry on playing the last one you played.

Share this post


Link to post
Share on other sites
do you have ahk basic or ahk_l on your cab?

try to add:

COM_CoInitialize()

in com.ahk after com_init()

I have the same TTdax problem but i don't know how write the line. Is it like this?:

(i haven't the ahk basic or ahk_l on my hyperpin directory)

COM_Init()COM_CoInitialize()

{

Return DllCall("ole32\OleInitialize", "Uint", 0)

}

All my try doesn't work.

Thanks ;)

Edited by tetrafred

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...