Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Announcement

    Sorry for the recent downtime. Still much to do but we have the site updated, secure and back online.  Expect more changes.

Hypersync and the FTP are currently down to change servers. Thank you for your patience.

FPLaunch MOD: Pause and Loading screens...


samwyze
 Share

Recommended Posts

hey guys, glad to see this thing has been progressing since last time I checked:)

ok, so I tried the latest wip9, and 3 things are not working for me on win7 x64 SP1.

1) whenever I pause the game (using "p" or "e" or if holding "e" for exit), the whole thing keeps flashing and it looks like its slowly redrawing the options screen - very annoying. When it was flashing, I navigated to services and brought in to front which fixes the redrawing issue, but moves my dmd half way outside of screen. When I bring the dmd back where it was, the redrawing issue comes back. I don't know if that has anything to do with it, but I'm running 4Ghz i7 with beefy gpu, and the tables load real quick, so maybe your wait commands withing the script are being prematurely interrupted? I was also having either black table or regular table but blackening out whenever something was moving, but it was fixed by disabling desktop composition in compatibility for vpinball912.exe

2) accessing flyer/instruction cards works great from main menu, but errors out when trying to do that while in the game (someone posted snapshot of the error couple posts back).

3) pressing "e" on keyboard works as it should, but on my pad using xpadder it keeps going back and forth at blazing speeds (sometime ago I figured how to fixed it but dont remember anymore) if anyone knows a fix, please speak up.

Any help greatly appreciated

Edited by DeathEvil
update
Link to comment
Share on other sites

ok it has to do with vpinmame. When i call out the menu ("e") twice, then on the third time dmd vanishes, and the menu no longer flickers. If I bring the dmd to front then menu again flickers.

win7 64bit

visual pinball 9.12 & cabinet mame 2.5 (reports as 3.0)

running on single rotating display (dmd on top of fs table, no backglass or anything else)

Link to comment
Share on other sites

  • 2 weeks later...
I'm having some strange issues where FPLAUNCH.EXE is not closing when I exit a table.

I posted a new thread in the Support forum. Any help is really appreciated!

http://www.hyperspin-fe.com/forum/showthread.php?20420-FPLAUNCH-EXE-not-closing-after-I-exit-a-table-Have-to-use-task-manager-to-close-it&p=194728#post194728

Thanks!

Bill

The issue I am having definitely seems to be related to UVP. Here is what is happening:

I changed my exit key to 'k', but it made no difference. The problem seems to be only on tables that use UVP. For instance. Dolly. Load the table, exit back to HP. Everything is fine. Open it again, exit, now FPLAUNCH doesnt exit and I can't control HP until I end task on it.

It seems random for when it happens on the UVP tables. Sometimes they exit cleanly, other times they don't. I'm stumped and I'd rather not have to kill UVP on all the tables just to fix this.

Any ideas?

Bill

Link to comment
Share on other sites

Exit focus problem is not related to uvp, it happens randomly on all tables, uvp, non uvp, b2s, non b2s.

It is explained few posts before why it happens - and few ideas to fix it.

you can always set debug mode to file and check in log file what is happening.

by the way i will try your idea - to kill fplaunch.exe from vbs script and activate hyperpin.exe. maybe that will work better then triple checks in a loop that can freeze fplaunch.

Link to comment
Share on other sites

Found another very strange fix for the issue. At least so far it appears to work. If you drag the Windows taskbar to the backglass screen it seems to work correctly. Make any sense to you? I can't imagine why that would cause FPLaunch to exit correctly, but it seems to. Maybe that info could help create a permanent fix in a future version of fplaunch.

Bill

Link to comment
Share on other sites

i always have taskbar on backglass screen on the bottom - easier to work on backglass then on pf if you have to fix something in tables or hp

no wonder i'm not familiar with this bug

I'm going to use a 1080p 32" LCD for my backglass, didn't occur to me that at that size it would be easy to make the back glass the 'main' screen for tinkering. :beerglass:

Link to comment
Share on other sites

I tried 1.295 wip 9 and ran into all kinds of issues like HyperPin freezing on startup, sometimes it starts the old interface even though I replaced the files as per the manual. Also when it did work the rotation was 90 degrees out only in the menus. Any help would be greatly appreciated as 1.0 is really old school.

Link to comment
Share on other sites

Great!!!!!

Hi, from Argentine, Im using hyperspin with hyperlaunch 1.295 wip 9 all works fine in my cabinet with VP and FP, but i need remove this menu because i don´t use the short press, only i use the long press to exit of the table.

Somebody help me ??? sorry for my weak english,

the menu I want to remove is this.

post-54856-142870580374_thumb.jpg

Regards !!!!!!!!

Link to comment
Share on other sites

Hello,

First off 1000 pardons but I have not read through 104 pages of posts . I tried to skim through to find my answer but to no avail. I am having issues when trying to view instruction cards while running the table. I get the following error:

Function Name 'Menu'

Error: The COM object may not be a valid Dispatch Object!

First ensure that COM library has be initialized through COM_Init().

0

Will Continue?

Does anyone have a fix or know why this is happening. I am using windows 7. Thanks !

Link to comment
Share on other sites

I am having problems with loading in game instructions using new build. I keep getting an error about com file with the following statement, "The Com object may not be a valid dispatch object. First ensure that com Library has been initialized through Com_Init(). () Will continue Y or N ? " Any suggestions ? Flyers work as normal and all else as well. Thanks in advance,

I also have this problem with wip9

When I push the "i" key while browesing tables in hyperpin the instruction card pop up but when im in a game and try to view the instruction card by menu or with the "i" key i get the message above. So it must be a problem with fplaunch. All my instruction cards is in the swf format

Link to comment
Share on other sites

I also have this problem with wip9

When I push the "i" key while browesing tables in hyperpin the instruction card pop up but when im in a game and try to view the instruction card by menu or with the "i" key i get the message above. So it must be a problem with fplaunch. All my instruction cards is in the swf format

Lucky, I cant get them to pop up in any situation. What OS are you using? Im on Windows 7 x64. I find it hard to believe only 2 people have this problem :D

Link to comment
Share on other sites

I also have Windows 7 x64 Professional Edition

Hey there I think I figured out our ( or anyone elses) problem with this error. Make sure Adobe Flash is installed :argh:. It appears that in effort to install only the bare minimum on my pin machine, I over looked this crucial program haha. Good luck hope it works for you.

Link to comment
Share on other sites

Re: WIP9

When I envoke anything from the menu while in a game, it appears that whatever was envoked doesn't purge or shutdown correctly. For example, if I select a flyer during a game, with debugging on I get the "Flyer Closed" message which never goes away and I can tell that it is effecting the resources to some degree. Same goes for sizing a table in FP or Instructions etc. To get rid of the lingering process I need to again toggle the menu key again.

Link to comment
Share on other sites

Making text files from PINemHI and printing them to HyperDMD.

Is there any communication for when you're scrolling through the tables, so I can grab this text from tablename.

Run, %HyperDMD% -set Hyperlol

Loop, read, %A_Scriptdir%\hi\%tablename%.txt

{

Loop, parse, A_LoopReadLine, %A_Tab%

{

Run, %HyperDMD% -scene txt -Text1_Text %A_LoopField%

Sleep,3500

}

}

Link to comment
Share on other sites

Hi, from Argentine, Im using hyperspin with hyperlaunch 1.295 wip 9 all works fine in my cabinet with VP and FP, but i need remove this menu because i don´t use the short press, only i use the long press to exit of the table.

Somebody help me ??? sorry for my weak english,

the menu I want to remove is this.

post-54856-142870580849_thumb.jpg

Regards !!!!!!!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...