Jump to content
samwyze

FPLaunch MOD: Pause and Loading screens...

Recommended Posts

Ok the ledblinky lights with the music. I needed to have a registered copy of Ledblinky.

Everything works. Just wish I was able to get these slight windows titlebar gone. I did make it better by adjusting titlebar in the pinjukelaunch.ini.

I will make a tutorial when I finalize everything but it works perfect.

Anyone have wheel art for this?

Edited by bent98

Share this post


Link to post
Share on other sites

I got the artwork (both wheel and background) from deviantArt. Of course, I did a little modifying.

I remember having issues with B2S and Jukebox compatibility...

My backglass TV is 720p, but for some reason, windows will allow me to do higher resolution (1920x1080) - My guess is some kinda upscaling, like DirectDraw

One resolution would work with the Jukebox at fullscreen, then B2S's would be messed up.

One resolution would work with the B2S's and then the Jukebox would be messed up.

I finally got everything working at a lower resolution of 800x600.

When trying to get LedBlinky working, just work on ledblinky and getting it to work with an MP3.

I had issues setting it up, because I had muted out some unused (software) ports from within my Master Volumne Properties.

After opening up all the in and out ports, and got it working, I then went back and muted the ones that weren't needed.

After you can get the LedBlinky to work with an MP3, then work on getting the DWjukebox to work with it.

Edited by boogies2

Share this post


Link to post
Share on other sites

I tried mapping the shutdown to e but then jb would close leaving hp hanging. Shouldn't hp kill it no matter what the actual programs exit key is set to, ie FP and VP.

Share this post


Link to post
Share on other sites

Not sure Jason but this was only way I could get it to work. Oh and for me it didnt work with focus on internal, it needed to be set to external. Im running XP.

A couple off topic questions:

I noticed in the ini file there is something to print BG which is assigned to "u". I tired it and it doesnt work. Where does it save i to? The HP/Media/Images dir?

I was also wondering if anyone noticed this. I used to be able to pause my games in VP by pressing the exit key once. Now it doesnt work. FP still works but VP will pause game for a sec to bring up menu and then the game will continue with the pause overlays ontop.

Here is my config

exitScriptKey = ~q & ~s

exitKey = e

exitKey1 = g

enterKey = 1

enterKey1 = Enter

upKey = LShift

upKey1 = LShift

downKey = RShift

downKey1 = RShift

toggleCursorKey = t

hideCursor = true

hideDesktop = true

hideTaskbar = true

useLoadingScreen = true

useExitScreen = true

useExitAsPause = true

useExitMenu = true

fadespeed = 25

pauseFPKey = RButton

saveFPTables = true

editTableKey = !F4

printScreenKey = o

printBGKey = u

pfScreenNum = 1

bgScreenNum = 2

instructionsKey = i

flyerKey = f

hyperScale = 0.75

debugMode = file

ledwiz = true

toggleLedwizKey = 1

hyperpinexe = hyperpin.exe

focusSleep = 200

useFocus=external

Share this post


Link to post
Share on other sites

The U works within HP, and its great for creating B2S backglassartwork. The O key does the playfield artwork. I dont think either would apply for the jukebox, since its a little different.

Share this post


Link to post
Share on other sites

Well its doesnt work for me. When do you press "u" in game I assume? Where does it save image to?

Share this post


Link to post
Share on other sites

i've heard about this pause problem from Jaron - never had it on my rig so could not debug it

check posts that are reply to Jaron - and do what I said to him to help debug this pause problem

it looks to me like some major ahk_basic ahk_L incompatibility - or maybe something more trivial - we will see.

Share this post


Link to post
Share on other sites

One question - does vp gets focus and ball continues before or after menus are shown?

So when you press exit key - game stops for a sec, and then what happens first - is it - ball continues and then menus come up - or menus come up and then few seconds later (how many exactly?) ball starts moving and goes down the drain?

One video of what happens would be great - bent or jaron.

Share this post


Link to post
Share on other sites

once you press "e" the menu comes up and then the ball stops for 1.5-2 secs then continues to drain

CAn you also please tell me where the images are save when you press:

printScreenKey = o

printBGKey = u

Edited by bent98

Share this post


Link to post
Share on other sites

in their proper location in hyperpin media folder

on what tables do you get ball drain when you open exit menu - all tables, or just some of them?

how come you didn't see it before - did you changed something lately?

Edited by blur

Share this post


Link to post
Share on other sites

All VP tables have the issue. FP tables work fine. I suspect it stop working once you switch to focus AHK. I almost seems like it has something to do with the pause routines and naming changes you made in the settings .ini file.

Also, it would be cool if you added a camera sound when you press the O and U key like B2S direct server does so the user knows a screenshot was taken.

Share this post


Link to post
Share on other sites

you mean solenoid sound - yup - that's a good idea

about this exit menu focus problem - it can't be because of focus.ahk script because focus.ahk is called only on exit from the game, not on pause.

also naming changes are just replace of the names - so it can't be that

it could be something around pinemhi scores drawing - that's the only new thing about menus

it would be great if you could try first version of wip 10 prereleases to see if it also has a bug - link is in my last reply to Jaron, I asked him same thing but he ran away :)

funny thing is that it only happens on xp and only for few users, it never happened on my watch :)

does anybody lese has this problem also?

Share this post


Link to post
Share on other sites

But wait,

I remeber trying the first versions of the WIP 10 and it would have issues regaining focus in general. Once you added the focus 2 I could finally use the new WIP fplaunch but then I noticed the pause issue.

Share this post


Link to post
Share on other sites

that was not the first version, that was one version before last version

there were many versions before that in hiscores thread on vpu

check this link http://www.hyperspin-fe.com/forum/showthread.php?10935-FPLaunch-MOD-Pause-and-Loading-screens&p=225538&viewfull=1#post225538

there you will find few versions, test just the first one - "fplaunch with hiscores and support for different fp exe" and see if exit menu works ok

Share this post


Link to post
Share on other sites

Well bent it seems as though we are having our own independent issues. I can pause just fine in all my VP tables. I am using the latest version of FPL (with stock focus) and have pinemhi installed as well. When I hit exit (e) the ball freezes and it goes to the pause screen, both those happen instantly. As soon I "back" out the ball is released and away we go.

Edit: Win7 64bit

Edited by jasonsmith

Share this post


Link to post
Share on other sites

Blur I upgraded my cabinet PC hardware and while I was at it moved from xp to win 64. Now I'm running into the focus issues. Did a search and found the thread from May that is in the help forum. It does cover this exact issue but the thread kind of dies with nothing really resolved. Lots of different ideas thrown around there though. Right now I have the taskar bar hide set to Off in windows and running hyper launch in admin but not in compatability mode.

Share this post


Link to post
Share on other sites

Well I just read through the last 80 pages to refresh memory and see what is new. It looks like somewhere along the way the new builds stopped being linked on second page here and are now on VPU site? If so, I am probably using old build thinking I was on the new. Next thing, looks like new builds all require sep download and install of AHK? Or can I just paste new build files over my old wip 9 and I am good?

Share this post


Link to post
Share on other sites

I've just been pasting and replacing from wip 9 through all the latest updates. When you go to the new one for the first time it adds 6 new lines and disables a couple.

Share this post


Link to post
Share on other sites

just copy files over from first post in thread "fplaunch with jukebox and new focus" on vpu

you will need several other files - like pinemhi ini and exe from www.pinemhi.com

Share this post


Link to post
Share on other sites

Jaron there is a new version of fplaunch on VPU

it is named "fplaunch no pinemhi3" - it has pinemhi, name just means it is third debug version (no pinemhi, no pinemhi2 and no pinemhi3)

you should test it - it fixes exit menu bug in windows xp

you will also need focus files from previous zip

this will also be new wip 10 version - no new additions till next release - just wrapping it up

Edited by blur

Share this post


Link to post
Share on other sites

FPlaunch wip 10 is uploaded to VPU:

http://vpuniverse.com/forums/index.php/topic/315-fplaunch-1295-wip-10/

This is full version with all images, ahk files, exe files, wav files, even pinemhi 1.1 and sample of jukebox.bat are there.

Extract this to your hyperpin folder - images should go to media folder automatically.

New features are:

1.295 wip 10

+ highscores added tnx to dna disturber, bleasby and horseyhorsey

+ custom fp and vp exe (vp/fpexetables.txt in settings dir)

+ custom b2s settings from koadic added (CustomB2STables.txt)

+ toggleLedwizKey button added to menus - tnx to deegor

+ toLog added to every function

+ external ahk script focus.exe executed on exit to focus hp

+ exitemulatorkey changed to exitkey

+ pausekey changed to exitkey1

+ exitemulatorKey2 and 3 changed to enterkey and enterkey1

+ upkey1 and downkey1 added - so now all menu keys are doubled

(to enable keyboard and joystick keys)

+ usepausekey true/false removed (it is always used same as exit key)

+ #winactivateforce added again

+ memory leak found in hp on win7 if used in comp. mode - USE NATIVE MODE

+ taskbar problems - auto hide taskbar HAS TO BE OFF in windows

+ some images updated

+ instruction card menu item changed to instructions

+ improved error handling (winwait removed, mouse moved out of the loop)

+ jukebox support added

+ instructions moved a bit down so more of a playfield is visible

+ swf instructions will be on same position as jpg or png

+ antar bug - word (Play) makes problems - solved in vp 445

+ comments in settings are allowed

+ double focus - in script and in focus.exe

+ useFocus internal/external/both/none added to settings

+ hiscores for EM games copied from VP\user\hiscore.txt

+ options added to ledcleat.bat

+ sound is played after pf or bg images is saved

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...