Jump to content
samwyze

FPLaunch MOD: Pause and Loading screens...

Recommended Posts

Thank you for that new version, blur. It did fix the focus problem I have been having. Now on to installing the jukebox software. Thanks again!

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

I cannot, for the life of me, get the screenshot feature to work. For example, I load up the B2S Version of AFM, wait for the table to load, and press 'o' and u'. I get a flipper/solenoid "click" sound on each keypress, but no screenshots are taken and nothing appears back into hyperpin. I've restarted hyperpin, I've rebooted the computer, I've re-installed FPLaunch, I've changed the keys from 'o' and 'u' to completely different keys and it still doesn't work. Unless the pictures are being diverted into another directory somewhere, I'm completely lost.

All other features of FPLaunch work great except for the screenshot features. I've also tried with Future Pinball tables with no luck there also.

Any help from anyone would be greatly appreciated.

Share this post


Link to post
Share on other sites

where are you looking for screenshots?

they go to hyperpin media folder and you can see them as soon as you get out of table and go to next table in hyperpin and then back

Share this post


Link to post
Share on other sites
where are you looking for screenshots?

they go to hyperpin media folder and you can see them as soon as you get out of table and go to next table in hyperpin and then back

I've looked there, and no image is ever in those folders. I've even done a search on the C: Drive for *.png to see if they are being exported somewhere else, but nothing comes up with that either.

Could this be a video driver issue of some sort? It's strange because I've tried all the other buttons listed in the .ini file (such as flyer, instruction card, etc.) and they all work great. I get the flipper click sound after pressing 'o' and 'u' but nothing ever happens.

Would rolling back to a earlier version of FPLaunch be a good idea to try?

Thanks!

Share this post


Link to post
Share on other sites

If you are using win7 it won't work for you and you need different methods to screen cap. I've covered what works for me in an earlier post in this thread.

Share this post


Link to post
Share on other sites
If you are using win7 it won't work for you and you need different methods to screen cap. I've covered what works for me in an earlier post in this thread.

Yes, I'm using Windows 7, so I guess that explains that.

Thanks for the help!

Share this post


Link to post
Share on other sites

on some rigs it works on some it doesn't

i also have win 7 and it works

you can press printscreen button and check if you get image in clipboard

Share this post


Link to post
Share on other sites
on some rigs it works on some it doesn't

i also have win 7 and it works

you can press printscreen button and check if you get image in clipboard

Can't remember if we covered this before, are you running Nvidia or ATI and single or multiple monitors? Was thinking this issue was strictly Nvidia...but..

Share this post


Link to post
Share on other sites

nor nvidia nor ati - it's a laptop with plain sandy bridge GPU (actually no GPU - CPU IS GPU :) name is intel HD graphics - intel is not so intelligent after all - he doesn't even know how to name his cards properly so that people can know what they have)

multi screen config for cab, but everything works better with one screen - no black and white screens flashing, faster load and exit from table ...

Share this post


Link to post
Share on other sites

Hi,

So i decided to take the plunge into fplaunch 1.295 WIP10 and all is working better than expected except for this error thats been brought up before but not resolved.

"I'm having an issue with accessing instructions from within a game via the Exit menu. " FPLaunch crashes, See attachment

I have Flash installed and shockwave and java. Flyers are working fine from the exit menu triggered by 'e'. I can access instructions and flyers no problem on the Hyperpin wheel screen and I am using the Enter button to select menu options. Just no Instructions from the Exit menu??

Please help this is doing my nut in.

Thanks

webster.

post-33942-142870586728_thumb.jpg

Share this post


Link to post
Share on other sites

post-33942-142870586738_thumb.pngHi Guys,

So my bad, forgot i uninstalled adobe cs3 and it also took off flash player. All working OK except for one niggling issue.

On first boot up into Hyperpin, none of the Exit menu's work at all. E is mapped to in game menu and escape mapped as hyperpin shutdown.

When the escape (mapped button) is pressed i get the start menu pop up and task bar invisible. (image 1).

When i close Hyperpin with task manager and immediately restart it everything is perfect.

I have listed my settings file below, please someone take a look and see if anything stands out or anyone any ideas, same feelings.

Settings.ini

-----------------

[Main]

Version = 0.5.0.0

Starting_Genre = All Games

[Video]

Playfield_Monitor = Primary

Playfield_Rotation = 270

Backglass_Monitor = Secondary

Quality = BEST

Table_Video_Enabled = true

Table_Video_Offset = 0

Use_Backglass = true

Backglass_Image_x = 0

Backglass_Image_y = 0

Backglass_Image_w = 1280

Backglass_Image_h = 1024

Backglass_Image_r = 0

Backglass_Delay = 0

[Future Pinball]

Show_Games = true

Exe = Future Pinball.exe

Path = C:\Hyperpin\Future Pinball\

Table_Path = C:\Hyperpin\Future Pinball\Tables\

Table_Video_Path = C:\HyperPin\Media\Future Pinball\Table Videos\

Table_Image_Path = C:\HyperPin\Media\Future Pinball\Table Images\

Backglass_Image_Path= C:\HyperPin\Media\Future Pinball\Backglass Images\

Exe = Future Pinball.exe

[Visual Pinball]

Show_Games = true

Path = C:\HyperPin\Visual Pinball\

Table_Path = C:\HyperPin\Visual Pinball\tables\

Table_Video_Path = C:\HyperPin\Media\Visual Pinball\Table Videos\

Table_Image_Path = C:\HyperPin\Media\Visual Pinball\Table Images\

Backglass_Image_Path= C:\HyperPin\Media\Visual Pinball\Backglass Images\

Exe = VPinball.exe

[Wheel]

Speed = medium

Text_Font = Style2

Text_Stroke_Size = 8

Text_Stroke_Color = 0x000000

Text_Color1 = 0xe10008

Text_Color2 = 0xFFFFFF

Text_Color3 = 0xe10008

Color_Ratio = 100

Shadow_Distance = 0

Shadow_Angle = 45

Shadow_Color = 0x000000

Shadow_Alpha = 1

Shadow_Blur = 0

[intro Video]

Use_Intro = true

Skip_On_Keypress = true

[intro Image]

Use_Intro = True

Skip_On_Keypress = true

[sound]

Master_Volume = 100

Video_Volume = 100

Sound_FX_Volume = 50

Wheel_Sound_Volume = 50

[AttractMode]

Active = true

Time = 60

MaxSpinTime = 10

[Press Start Text]

Enabled = true

Text1 = Free Play

Text2 = Press Start

Color = 0xe10008

[Keyboard]

Key_Delay = false

Start = 13

Exit = 27

Up = 150

Down = 149

SkipUp = 191

SkipDown = 90

Flyer = 70

Instruction = 73

Genre = 71

Service = 9

[Pinball Wizard]

Joy = 0

Start = 9

Exit = 8

Up = 2

Down = 10

SkipUp = 3

SkipDown = 11

Flyer = 4

Insruction = 5

Genre = 7

Service = 15

[Flyer]

BottomX = 300

CenterY = 360

[instruction]

Width = 600

BottomX = 250

CenterY = 360

[Exit]

Enable_Exit_Screen = true

Exit_HyperPin = true

Shutdown = true

Enable_Shortcut = true

Shortcut_Action = exit

Shortcut_Time = 1

[startup Program]

Executable =

Parameters =

Working_Directory =

WinState = NORMAL

[Exit Program]

Executable =

Parameters =

Working_Directory =

WinState = NORMAL

[FPLaunch]

exitScriptKey=~q & ~s

exitKey=e

exitKey1=p

enterKey=1

enterKey1=Enter

upKey=LShift

upKey1=LShift

downKey=RShift

downKey1=RShift

toggleCursorKey=t

hideCursor=true

hideDesktop=true

hideTaskbar=true

useLoadingScreen=true

useExitScreen=true

useExitAsPause=true

useExitMenu=true

fadespeed=25

pauseFPKey=RButton

saveFPTables=true

editTableKey=!F4

printScreenKey=o

printBGKey=u

pfScreenNum=1

bgScreenNum=2

flyerKey=f

instructionsKey=i

hyperScale=0.75

debugMode=file

ledwiz=false

toggleLedwizKey=1

hyperpinexe=hyperpin.exe

focusSleep=500

useFocus=both

[LastLoad]

system=Visual Pinball

table=AbraCaDabra_FS_B2S

---------------------------

Thanks in advance,

Webster.

Share this post


Link to post
Share on other sites

tried putting the task bar on the backglass, after restarting made no difference. Forgot to mention i run XP 32bit. Maybe its a service thats starts and interferes??

Share this post


Link to post
Share on other sites

so you have problems with hp, not with fplaunch?

what is your controller? what does it mean esc is mapped button? - you should not use any mapping software since hp, vp, fp and fplaunch can recognize joystick buttons directly

this what you are getting looks like "control-escape" combo to me - so if you get it just by pressing escape - it looks like your control key is stuck or windows think it is pressed - try to press all control keys once to see if windows will register that control is not pressed any more

for using esc in hyperpin and e in fplaunch - you should configure same key in both application, preferably e because esc makes problems - but you can use joy# buttons also directly in hp and fplaunch - check manual

Share this post


Link to post
Share on other sites
so you have problems with hp, not with fplaunch?

HI,

I thought this maybe the issue:

---------------

[Keyboard]

Key_Delay = false

Start = 13

Exit = 27

Up = 150

Down = 149

SkipUp = 191

SkipDown = 90

Flyer = 70

Instruction = 73

Genre = 71

Service = 9

---------------

Since i have found conficting information about key codes.

But like i said when i restart Hyperpin after closing with task manager it works perfect. I have Ipac2 and have mapped buttons this way. One for E and one for Escape, as per manual.

I close hyperpin and test each button in the winipac editor and they all work fine no conflicts or combos.

Thanks

webster

Share this post


Link to post
Share on other sites

you have to configure exit to e not escape - you have codes in manual

still that doesn't explain why you get ctrl-esc when you press esc - maybe you have ctrl on ipac and it is pressed all the time?

but if you change exit key to e that ctrl should not make problems any more - still it would be good to find why windows think ctrl is pressed

Share this post


Link to post
Share on other sites

Hi,

the escape was using ctrl as well, dont know why but mapped to another key ok.

E was already mapped as Exit but only works when at the hyperpin wheel menu not in game. P for Pause brings up the service/flyer menu in game as E should. But no keys work. (flippers cant move menu up or down, E does not work or Enter)

I have made this 'useExitAsPause=true' flase in Settings.ini and Fp but get error.

Please someone attach your WORKING FPlaunch and settings.ini mapped to e for exit.

Thanks,

Webster

Share this post


Link to post
Share on other sites

Blur - thoughts on how one would run a wrapper in place of the "Future Pinball.exe" in the latest FPLaunch? Would it just be a case of putting in the exe into the AHK or maybe renaming the wrapper (BAM in this case) to Future Pinball.exe and setting the path to the BAM folder instead of FP? BAM is a new launcher for FP that allows you to play with 3D depths. It launches FP itself. More info at GOP and VPF and Author's website http://www.ravarcade.pl/

thanks

Share this post


Link to post
Share on other sites
Blur - thoughts on how one would run a wrapper in place of the "Future Pinball.exe" in the latest FPLaunch? Would it just be a case of putting in the exe into the AHK or maybe renaming the wrapper (BAM in this case) to Future Pinball.exe and setting the path to the BAM folder instead of FP? BAM is a new launcher for FP that allows you to play with 3D depths. It launches FP itself. More info at GOP and VPF and Author's website http://www.ravarcade.pl/

thanks

Open - have a look here..http://www.vpforums.org/index.php?showtopic=23791&page=4

This option works if you want to always use bam, would be nice to have a way of choosing between bam and FP.

Share this post


Link to post
Share on other sites

you can use different fp exe setup to set which tables to use fploader?

Share this post


Link to post
Share on other sites
you can use different fp exe setup to set which tables to use fploader?

Of course! fptables.txt, I did think of that later - will try that today and thanks blur for creating the solution before the need had even arrised:D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...