Jump to content
rhzucal

Light gun issues in hyperspin

Recommended Posts

I installed my light gun and it works great loading directly from MAME.  When I try to load the same game in hyperspin it loads but my crosshair doesn't move. I notice its picking up my hlsl settings.....everything looks great. But my light gun wont work. Please help!

Share this post


Link to post
Share on other sites

After you set up your settings set you mame.ini file to read only so that rocketlauncher doesnt change them and you should be fine.

 

Share this post


Link to post
Share on other sites

I guess that kinda worked.  I tested aliens 3 and it worked but still other games didnt. I have one of those 8tb hyperspin setups so it has a lot of collections. Would it make sense that one game will work in mame but not in a collection? Would their be more files i would need to put to read only? Also, I notice booting right from mame has no hlsl settings applied visually at least. Is it possible rocketlauncher is reading a different ini?  I did update a while ago to mame 185 and pointed rocketlauncher to that but only the mame emulator. Do any other mods need to be changed when updating mame? Thanks for the help. 

Share this post


Link to post
Share on other sites

If the lightgun is a mouse emulator probably you should activate mouse as lightgun device

image.png.d81a25105c489d0ca65b9d0c51e73378.png

Share this post


Link to post
Share on other sites

I figured it out...modified the wrong mame ini. One other issue I noticed...and I have bezels..I cant do offscreen reload even though I have it marked as 1 in the ini. Testing in mame directly works fine. Through hyperspin it seems when it gets near the bezel edge the crosshair switches to a mouse pointer. Anyone else see this issue? Any solution?

Share this post


Link to post
Share on other sites
14 hours ago, dark13 said:

If the lightgun is a mouse emulator probably you should activate mouse as lightgun device

image.png.d81a25105c489d0ca65b9d0c51e73378.png

set lightgun Device to lightgun thats what I have mine set to I have no issues. I would also update you mame to the current. If I remember there were some changes to the guns in 190 or so

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...