Jump to content
gunit

AAE Emulator in Hyperspin

Recommended Posts

Evening Guys, I have two issues I need help with:-

1) Hyperspin loads in AAE fine but when I browse through the games I can't select to play ? I see the videos etc but I cant enter them ? tried pressing every button but cant get in. Tested in RocketLauncher and selected an indivdual game which works fine ?

2) When I quite out of testing an AAE game in roicket Launcher I am left with a VERY over exsposed desktop of colours in windows ?

Can anyone assist please

Share this post


Link to post
Share on other sites

Point 1) Fixed:- Execution: Need to set to HyperLaunch.

Any ideas on point 2) ? I have to restart the machine when I quite out of a game as all the colour and graphics are missed up.

Share this post


Link to post
Share on other sites

Sounds like windows is being set to a low res by the emulator. Why not use mame to run those games?

Share this post


Link to post
Share on other sites
31 minutes ago, gigapig said:

Sounds like windows is being set to a low res by the emulator. Why not use mame to run those games?

Anyway to set it back on game exit ? I know mame has come a long way but from the sounds of things AAE emulator is still very good.

Share this post


Link to post
Share on other sites

Every AAE game works perfectly well using MAME, so no need to use AAE emulator.

Share this post


Link to post
Share on other sites

press "Tab" in AAE and in the video options try to choose a resolution that has x32 at the end.

Admittedly, graphics are much better in AAE for these Vector games. However, the version I had said "coming soon" for joystick support. Maybe I have an old version??? I could easily get around this with JoyToKey but you would lose the analog part of movement (mapped to the arrow keys) in the process.

For now I run them through Mame as well.

Share this post


Link to post
Share on other sites
11 hours ago, Spawk said:

press "Tab" in AAE and in the video options try to choose a resolution that has x32 at the end.

Admittedly, graphics are much better in AAE for these Vector games. However, the version I had said "coming soon" for joystick support. Maybe I have an old version??? I could easily get around this with JoyToKey but you would lose the analog part of movement (mapped to the arrow keys) in the process.

For now I run them through Mame as well.

Great idea but it did not work :( Its strange as when I quite each AAE game the overexsposed colour, low res graphics appear but then when I select another game in AAE it flicks back to normal again on load. It must be a global setting to apply to all of the AAE emulator.

Share this post


Link to post
Share on other sites
6 minutes ago, gunit said:

Great idea but it did not work :( Its strange as when I quite each AAE game the overexsposed colour, low res graphics appear but then when I select another game in AAE it flicks back to normal again on load. It must be a global setting to apply to all of the AAE emulator.

* Just tried Global setting in emulator but did not work. After I quite emulator windows was overexposed and lowres :(. Restart needed again!

Share this post


Link to post
Share on other sites

Often RL needs to be told what settings to use regardless. Is there a spot in the module for selecting resolution?

Sent from my SM-A520W using Tapatalk

Share this post


Link to post
Share on other sites
48 minutes ago, Spawk said:

Often RL needs to be told what settings to use regardless. Is there a spot in the module for selecting resolution?

Sent from my SM-A520W using Tapatalk
 

Yes in RocketLauncherUI / AAE / Main Settings / Settings. Set Resolution

- tried both 32 and 8 bit depth (1280x1024, 60 frame)

and also did the same in the emulator resolution like you explained earlier

Still the same :(

Share this post


Link to post
Share on other sites

Just testing the Emulator on its own with the same issues makes me think its a graphic card driver issue ?

I'm using an up-to-date - AMD Radeon Vega 8 Graphics

Share this post


Link to post
Share on other sites

Have you tried the "General "settings in Rocketlauncher? There should be a restore windows on exit check box or similar. 

Share this post


Link to post
Share on other sites
2 minutes ago, gigapig said:

Have you tried the "General "settings in Rocketlauncher? There should be a restore windows on exit check box or similar. 

The suspend/restore frontend option may refresh the resolution upon return as well, if you find something that works, do post it please.

Share this post


Link to post
Share on other sites
2 minutes ago, Spawk said:

The suspend/restore frontend option may refresh the resolution upon return as well, if you find something that works, do post it please.

PLayed with this earlier:-

In RocketLaunch / Settings / Exit

Restore Frontend On Exit = Restore
Restore Resolution On Exit = True

But no good :(

* When just testing the emulator on its own in windows it does the same over coloured low-res effect when I quite so im thinking its something else ?

Share this post


Link to post
Share on other sites

This is what happens in Hyperspin when playing or in windows when testing the Emulator.

2019-07-07-23_33_42.jpg.776fd51c5daf134fc28e2b4cecd248e0.jpg

Share this post


Link to post
Share on other sites

Do you use esc as your exit key? I just had a quick look at the module settings. There is not a spot to choose resolution but there is a spot to choose "windowed fullscreen". Also the exit mode can be changed which may or may not help.

To get there go to the Modules tab in RLUI, highlight AAE, and then click the "edit global module settings" button along the top. There are not a lot of options for this particular system but other systems have a lot of useful settings in here.

Share this post


Link to post
Share on other sites
10 minutes ago, gunit said:

This is what happens in Hyperspin when playing or in windows when testing the Emulator.

Yes I've seen this type of thing before. Usually colour bit change or it doesn't like to switch between certain resolutions. Maybe it doesn't like to be windowed??? The AAE module notes that true fullscreen is not compatible with pause so... 

Share this post


Link to post
Share on other sites
5 minutes ago, Spawk said:

Do you use esc as your exit key? I just had a quick look at the module settings. There is not a spot to choose resolution but there is a spot to choose "windowed fullscreen". Also the exit mode can be changed which may or may not help.

To get there go to the Modules tab in RLUI, highlight AAE, and then click the "edit global module settings" button along the top. There are not a lot of options for this particular system but other systems have a lot of useful settings in here.

no good, did look at this. I reckon its something to do with Windows 10

Share this post


Link to post
Share on other sites

Yeah I am still win7 so cant help there, sorry my friend. I say run them from mame for now  :)

Share this post


Link to post
Share on other sites

This makes sense to me:-

  • The Emulator has changed the video mode to be something that it needs;

  • And it did not restore the video mode when it finished;

  • And Windows wasn't made aware of that;

  • So Windows doesn't know what to do or doesn't think that anything has changed and continues to treat the display as if it's in the original mode, not the mode that the game left it in.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...