Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Announcement

    Sorry for the recent downtime. Still much to do but we have the site updated, secure and back online.  Expect more changes.

Hypersync and the FTP are currently down to change servers. Thank you for your patience.

Joy To Key


rick101
 Share

Recommended Posts

Hi Guys,

I recently lost some of my settings for unknown reasons and now when I launch Joy to key is running as per my windows startup and associated to Hypersin as an application all fine. Enter a game its fine, but then return to menu..it stops running. I can CTRLALTDEL and see its stopped running, if i double click the joytokey.exe shortcut on desktop it runs again and stick resumes

How can I tell Joy To Key to stop disconnecting when I return to main menu?

Please help!

Link to comment
Share on other sites

Hello Rick,

JTK can be really tricky to get working just the way you like. Fortunately once you do get it, you are good for life LOL. If you followed the tutorial I wrote, it was written some time ago. And it was also submitted (and edited) by the person in charge of the tutorials section. Therefore I have no way to directly update it myself. Here are some things to consider:

1. The "associate program" feature is probably not really needed. I only used this at the time because I was setting this up on my main PC and was worried about sending "Enter" and "Escape" to windows applications when NOT using HS. Sounds like it's loading fine on first launch though so this is probably not your issue, I just wanted to stress that it is more important to have it configured correctly in RL as it will be the one loading all profiles after very first game launch. It's important that RL knows that HS is your FE so that it can load the HS JTK profile you made in RLUI.

2. People sometimes have an issue that the INI is apparently not being saved. The problem might be this: JTK (at least the version I run) stores some settings in the registry!!! The issue is that it will create these entries in the registry from the very first location you run JTK. So in my case, I DL'd JTK, opened it from C:\Desktop just to look at it and see what the GUI looks like or whatever, then I copy it to my R:\Arcade setup. Even though I am running it from an entirely new location, windows will find the registry entries and always use the ini in that path (even if it doesn't exist). Only way to remedy this is to manually delete JTK entries from the registry and then run from the location you want.

I don't think #2 is your issue, just thought I'd include it just in case. They may have even fixed that in a more recent version of JTK. I think I run 5.2 or something.

In your case it sounds like RL isn't taking over the loading of JTK profiles at all. I tell people to make JTK profiles in RLUI for all situations even if they are just left blank! RL maintains control by closing the currently running JTK and loading it again with the reference to the profile it expects through command-line. If it fails to find the profile then JTK will fail to load, breaking the control from that point forward. MAME is a good example for this. There is zero need to use JTK for a MAME game. All controls can be directly mapped to any button you like. Unlike most emulators you can even directly map an exit emulator key in MAME itself. But if the JTK profile doesn't exist in RLUI, it breaks the chain so to speak. JTK will fail to load... and then JTK won't be loaded for RL to be able to close it when it comes time to return to HS and load that profile. Yes RL NEEDS to close JTK first.

Double check all your settings in RLUI, "path to JTK", etc. Keep me posted if you find out what's wrong.

Link to comment
Share on other sites

Hi Spawk,

The only Joy To Key path I could find was on this page. Also I have two menus on the left, one for Global and one for MAME. These have different settings on some areas. Should I be using two or one?

Also noticed if I CTRLALTDEL there are two instances running once I go into a game, one Hyperspin the other MAME. Hyperspin has sound, MAME doesnt. When I return to menu, it only shows the Hyperspin instance.

I've taken screenshots of several other areas in hope I can get you to take a look for any other reason that could be causing JTK to bail out.

No description available.

 

No description available.

 

 

Link to comment
Share on other sites

Hi Spawk,

No luck unfortunately. I did as you said but it made no change. I then tried changing the path as I have a standard and an _en folder and got an error. Now it won't open a game in HS (wheel still goes up and down using stick) nothing happens when I hit the action button that used to start a game (the error hasnt come back since the first time I launched a game)

Tried putting back to how I had it but same thing doesnt start a game anymore.

I checked in JTK and the 'Start' button is still mapped highlighting, so I am more thinking this isnt a JTK issue, its more its not launching the MAME emulator now?

I have a few joytokey folders not sure why:-

D:/Hyperspin/Arcade/Joytokey/joytokey.exe (this was what it was on)

D:/Hyperspin/Arcade/Joytokey_en/joytokey.exe

D:/Hyperspin/Utilities/Joytokey/joytokey.exe

D:/Hyperspin/Utilities/Joytokey_en/joytokey.exe (this is what I tried changing the JTK path in RL to then got the error and no longer opens a game)

Anyway I could pay for your time to remote onto my box to take a look yourself? Nothing on there other than my HS setup.

No description available.

No description available.

Link to comment
Share on other sites

UPDATE

So I went back to the video I watched when setting up HS JTK and copied the guys settings, restarted the box..and everything fixed including JTK not disconnecting going back to HS menu! Cant tell you what part but suggest anyone with similar issue follow this guys steps (maybe Spawk can identify the part specifically) 

Peace out 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...