Jump to content
Sign in to follow this  
BadBoyBill

HyperSpin 1.3 Update Release

Recommended Posts

Well, Circo is talking about using Keymappers such as Xpadder, as opposed to the internal joystick support of HS to navigate the HS menus. This is applicable to both 1.2 and 1.3. By far, the most popular Keymapper out there is Xpadder. Check out this thread for starters. The first post is an introduction to Hyperlaunch 2, which has many useful features built into it. It's main purpose is to provide ideal configurations for pretty much every decent emulator out there, but it also has some built-in nifty features, one of which being Keymapper support. I suggest you read the entire first post as a primer to Hyperlaunch 2.

Basically, a Keymapper takes your controller and turns it into a mini-keyboard. Why is this useful? Generally speaking, supporting keyboards is generally easier than supporting joysticks. The other main advantage is that it allows you access to unique solutions to interface problems. For example, programming all your emulators using their internal joystick plugins can be confusing and lead to problems. Sometimes, something as simple as unplugging your controllers and plugging them back in can reset the way the controllers are read, and then you'll have to go back to that emulator and reconfigure it. Instead, use Xpadder to manage your controllers, and it keeps these settings from changing. I recommend you use Xpadder for all emulators in which the native system does not use joysticks on their controllers (ie. NES and Sega Genesis). For controllers with native joysticks (MAME, Atari, N64), Xpadder is still quite useful for maintaining static controller settings. I have found that setting up a blank profile for a system with joysticks, and then using that emulator's internal joystick setups to configure the controllers has helped make sure that my p1 controller will always be my p1 controller. Xpadder is just good like that.

The Hyperlaunch forums in are a good place to get info on setting everything up properly. Generally speaking, if you post in there, you'll get the help you need.

Share this post


Link to post
Share on other sites
It seems some of my wheels no longer work. My Sega Saturn wheel now crashes Hyperspin. When I try to enter Dreamcast, Playstation, and another wheel i cant remember, it looks like it tries to load and then brings me back to the main wheel.

Ok I think I figured out what's going on with this. I was using the Roms Only filter that BBB put in this release, and disabling it for the above systems allowed me back into those wheels. So my guess is that the filter has trouble with .7z and/or subfolders?

Share this post


Link to post
Share on other sites

About my startup and exit scripts for launching Xpadder and HyperSpin together take a look ad my post on this topic http://www.hyperspin-fe.com/forum/showthread.php?18255-HyperLaunch-2-lose-focus-when-closing-emulator&p=212538#post212538

I've included my scripts over there. I hope you find them useful.

It happens with every subwheel theme I've tried. All my main wheel themes work fine, though. But yeah, once in a game wheel, the first game the theme loads on is the only game it will show up for, and then both game videos and artwork won't work in that wheel for any game. For the record, I have tried both 1.3 and 1.3.1. It's also worth noting that if a game has it's own theme, that will load, and then the first game I select after that will load, but beyond that, nothing loads.

You are indeed correct, as djvj pointed out. I forgot to load my little ahk script on startup of HS to start Xpadder.

Yeah I've been using a script similar to that. I have a startup script that launches Xpadder, and an exit script that closes it. If I listed Hyperlaunch as a startup program for Hyperspin, would it accomplish this for me? I only use Xpadder for Hyperspin, so I don't want it open unless Hyperspin is open.

EDIT: It seems some of my wheels no longer work. My Sega Saturn wheel now crashes Hyperspin. When I try to enter Dreamcast, Playstation, and another wheel i cant remember, it looks like it tries to load and then brings me back to the main wheel.

Share this post


Link to post
Share on other sites
BINGO my friend, it ain't that hard of a fix or that big of a deal. I think we would all be better if Joystick support were removed altogether until the plugin is fixed.

A big reason that I haven't switched to using Xpadder instead of built in joystick support is that pressing any keyboard key makes all of my buttons controlled by LEDBlinky flash with each press. It's really annoying and not something I want.

Share this post


Link to post
Share on other sites

it may not be 2.0 but any and all bug fixes and improvements even in incremental stages are most welcome thanks BBB!

Share this post


Link to post
Share on other sites

it seems a few themes make hyperspin crash and also some videos dont appear to pop up anymore has anyone else had this problem

Share this post


Link to post
Share on other sites

Hyperspin seems to crash out and return to desktop when selecting certain systems. Not sure if its a theme issue or the fact i have 'Roms only' selected. Will try again tonight with that option off.

Thanks for the new version update guys! It does run a lot smoother and looks great!

Share this post


Link to post
Share on other sites
Hyperspin seems to crash out and return to desktop when selecting certain systems. Not sure if its a theme issue or the fact i have 'Roms only' selected. Will try again tonight with that option off.

Thanks for the new version update guys! It does run a lot smoother and looks great!

I think brolly and I may have figured that one out. Are these wheels set to "Roms Only" and do you have ALL of those roms in subfolders? That happened with my Saturn and Turbografx CD wheels. It seems to wig out if it can't find any roms in the base folder even if you have it set to search subfolders.

Note that this is NOT specifically caused by subfolders as my Playstation wheel works fine having a mix of foldered and non-foldered roms. It's only when it can't find any files with the rom extension directly in your rom folder while having the "Roms Only" flag on.

Share this post


Link to post
Share on other sites
A big reason that I haven't switched to using Xpadder instead of built in joystick support is that pressing any keyboard key makes all of my buttons controlled by LEDBlinky flash with each press. It's really annoying and not something I want.

You know you can turn off that feature in the ledblinky configuration screen right?

Share this post


Link to post
Share on other sites
I think brolly and I may have figured that one out. Are these wheels set to "Roms Only" and do you have ALL of those roms in subfolders? That happened with my Saturn and Turbografx CD wheels. It seems to wig out if it can't find any roms in the base folder even if you have it set to search subfolders.

Note that this is NOT specifically caused by subfolders as my Playstation wheel works fine having a mix of foldered and non-foldered roms. It's only when it can't find any files with the rom extension directly in your rom folder while having the "Roms Only" flag on.

Dr Money....

All fine when deselecting 'roms only' but the roms are not in subfolders. As long as thats the case....thought i screwed my setup... :hmmmm2:

Share this post


Link to post
Share on other sites

Weird, what was the system you had trouble with? Are all the roms for it the same extension?

Share this post


Link to post
Share on other sites

It was Neo Geo Pocket Color. All files are .ngc extension. If it is selected as 'roms only' it crashes out every time. Turn off the option and the wheel appears normally and all is fine.

Share this post


Link to post
Share on other sites

Well I've pretty much exhausted my ideas but at least it's mostly isolated for whenever BBB gets to working on that.

Thanks for the info.

Share this post


Link to post
Share on other sites

Hey !

I just wanted to say that hyperspin 1.3 didn't solve the audio bug for me :

- If I connect my pc on a HDMI TV, with sound, hyperspin is working.

- If I connect the same pc on a DVI TV (so there's no sound), the audio bug is back :

When I choose an emulator on the system wheel and click, nothing happens : the games wheel isn't displayed. Instead I just go back on the system wheel again and again.

Evil eye told me this was the "audio bug" and that it should have been fixed in Hyperspin 1.3, sorry but it didn't worked for me.

Tell me if you need any log, system informations or anything.

Share this post


Link to post
Share on other sites

With this version, in HyperHQ, I can't seem to uncheck the option for "Last System Used". When I deselect it, the next time I start up HyperHQ, it's always selected again. It's not possible to turn the option off.

Anyone else experiencing this?

Share this post


Link to post
Share on other sites
With this version, in HyperHQ, I can't seem to uncheck the option for "Last System Used". When I deselect it, the next time I start up HyperHQ, it's always selected again. It's not possible to turn the option off.

Anyone else experiencing this?

I am too and I was told "it works"... I don't know how to fix it. Also when I load Mortal Kombat 4 PC game, it loads in the background instead of in front of HS. I don't use hyper launch for my PC games.

Share this post


Link to post
Share on other sites
A big reason that I haven't switched to using Xpadder instead of built in joystick support is that pressing any keyboard key makes all of my buttons controlled by LEDBlinky flash with each press. It's really annoying and not something I want.

FYI in case anyone has wandered upon this in a search for LEDBlinky questions, the buttons flashing is an option you can toggle off in LEDBlinky under the FE Option. Who knew. :)

Share this post


Link to post
Share on other sites

Hey Guys,

I almost miss this :(.... Can we post this to the download section??

And as always BBB keep up the amazing work.

thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...