Jump to content
Sign in to follow this  
BadBoyBill

HyperSpin 1.3 Update Release

Recommended Posts

This weekend I will open things back up and try to fix any current issues, on a side note I forgot to mention that I had added roms only filter, you can check the box in hq to only show games that you have a

Rom for, based on your rom path and rom extensions.

Also if HS feels laggy then double check that you do not have quality set to Best, this option affects HS a lot with no considerable difference in rendering appearance from the High setting, everyone should do this if possible

Share this post


Link to post
Share on other sites

I had that "Roms Only" part checked and it caused a crash on my Sega Saturn and Turbografx CD wheels when I tried to enter them but works fine if I turn those two off. Any helpful info I could give you on that?

Share this post


Link to post
Share on other sites

I can't test now to check it, but maybe some issue related with the roms being inside sub-folders? Just saying this since it's happening on 2 CD based systems.

Share this post


Link to post
Share on other sites

@bent98

Yes I already played with it. But no differents for me. So I switched back to HS1.3 and everything is fine now for this moment. I'm going to be patient for BBB's next release. I think he knows enough now. Thanks for helping ;-)

Share this post


Link to post
Share on other sites

Nice and smooth. The only issue I have is that it asks me for PCLauncher.ini when I try to play a pc game. What's changed from previous version? Thanks a lot.

Share this post


Link to post
Share on other sites

Do a search for pclauncher there have been a couple of threads already and a new hyper launch module even. You should be up and running in no time.

Share this post


Link to post
Share on other sites

FWIW, I was able to make progress. I uninstalled/re-installed flash and my catalyst drivers.

It's working now except in full screen its windowed.

Seems like my setup is full of warts... likely of my doing from months of tinkering. ;)

Share this post


Link to post
Share on other sites

Thanks for the update

Seems slower now in Windows 8 than with 1.2. I even tried the 1.3.1 update but no difference. There is a definite delay when it first starts up.

It seems to still play the flv and transitions.

Does HyperSync now pull the MP4 videos or give us the option to do so? Will it remove the duplicate flv videos?

Thanks

Edited by BladeZX

Share this post


Link to post
Share on other sites

@BladeZX

Yes HyperSync will pull the MP4 videos (Circo removed the FLV's upon the HS 1.3 release). Duplicates should also be removed from your video folder.

Share this post


Link to post
Share on other sites

The controls for horizontal wheel is acting weird.

What it is doing now:

I press down a single time it goes to the next game in Z to A order, and if I hold down it goes to the next game in A to Z order.

I press up a single time it goes to the next game in A to Z order, and if I hold up it goes to the next game in Z to A order.

Left skips by letter in A to Z order, and right skips by letter in Z to A order.

Summary of the now: Compared to the normal wheel style up is down, down is up, left is right and right is left. (now vs normal)

What horizontal style should do: (most intuitive)

I press right a single time it goes to the next game in A to Z order.

I press left a single time it goes to the next game in Z to A order.

Down skips by letter in A to Z order, and up skips by letter in Z to A order.

Summary of the should: Compared to the normal wheel style up is left, down is right, left is up and right is down. (should vs normal)

Edited by ghutch92

Share this post


Link to post
Share on other sites
Also if HS feels laggy then double check that you do not have quality set to Best, this option affects HS a lot with no considerable difference in rendering appearance from the High setting, everyone should do this if possible

I was getting worried as the update made HS very slow compared to 1.2 but checking high instead of best cleared this up (mostly). Still slightly slower than 1.2 but knocking it back to medium cleared that up with only a slightly noticeable loss of quality. It even made my animation heavy themes run at the intended speed which I'm very happy with!

Share this post


Link to post
Share on other sites

Thanks BBB,

Haven't noticed any lag and my startup time remains the same (Alienware Aurora i7-3930K) , and the wheel smoothing is awesome, Thanks Again !

Share this post


Link to post
Share on other sites
Nice and smooth. The only issue I have is that it asks me for PCLauncher.ini when I try to play a pc game. What's changed from previous version? Thanks a lot.

Did u figure this out. I get the same thing and I am using the 1.5 version of the script.

Thx

Share this post


Link to post
Share on other sites
Did u figure this out. I get the same thing and I am using the 1.5 version of the script.

Thx

If you have a system named pc games. HyperSpin will send the system name "PCLauncher" to HyperLaunch instead of "PC Games". so here is what changed

your settings (settings folder) and your modules.

Settings Folder

PCLauncher.ini contains the settings for HyperLaunch. (it's under [exe info] in your pc games.ini)

PC Games.ini contains the settings for HyperSpin.

A quick fix would be to copy your PC Games.ini and rename the copy as PCLauncher.ini .

HyperLaunch's next version is going to separate its settings files from HyperSpin's settings files.

Modules Folder

You need to create a new folder in the modules folder named PCLauncher .

Place the PCLauncher.ahk and its settings file in the folder you just created.

If the System Name is PC Games or PC Launcher HyperSpin and HyperLaunch will not perform a filecheck for an emulator or roms. Meaning no more dummy.exe or blank txt files.

Share this post


Link to post
Share on other sites
FWIW, I was able to make progress. I uninstalled/re-installed flash and my catalyst drivers.

It's working now except in full screen its windowed.

Seems like my setup is full of warts... likely of my doing from months of tinkering. ;)

Ok... more experimenting. I'm afraid I'm on an island with my setup, however I thought I would share.

I have 1.3.1 running full screen. It has no audio though. I also cannot select a system. It actually behaves as if it has 'no speakers quirk' that I've discovered searching the forums.

1.2 works with audio just fine.

I suspect it has something to do with it picking the wrong audio device. I have built in audio on the MB and a secondary on the HDMI connector on my radeon card. I've not connected anything to that HDMI port and I have the default audio source set to the internal realtek audio device. All other sounds work on the pc, it just appears as if hyperspin has not selected the default (or perhaps there is something wrong with my PC's default configuration that I am not aware of).

Anyway... that's where I am with this version. It really looks great though and I can't wait to get it working :)

Thanks again.

Share this post


Link to post
Share on other sites
If you have a system named pc games. HyperSpin will send the system name "PCLauncher" to HyperLaunch instead of "PC Games". so here is what changed

your settings (settings folder) and your modules.

Settings Folder

PCLauncher.ini contains the settings for HyperLaunch. (it's under [exe info] in your pc games.ini)

PC Games.ini contains the settings for HyperSpin.

A quick fix would be to copy your PC Games.ini and rename the copy as PCLauncher.ini .

HyperLaunch's next version is going to separate its settings files from HyperSpin's settings files.

Modules Folder

You need to create a new folder in the modules folder named PCLauncher .

Place the PCLauncher.ahk and its settings file in the folder you just created.

If the System Name is PC Games or PC Launcher HyperSpin and HyperLaunch will not perform a filecheck for an emulator or roms. Meaning no more dummy.exe or blank txt files.

Thank you. That seemed to get it running.

I was not aware this changed.

I just need to figure out the exit from the PC game now since ESC seems to not work anymore. It used to. Do I need to specify for each game in the Settings.ini that I want to use ESC or is there a default somewhere.

Share this post


Link to post
Share on other sites
Ok... more experimenting. I'm afraid I'm on an island with my setup, however I thought I would share.

I have 1.3.1 running full screen. It has no audio though. I also cannot select a system. It actually behaves as if it has 'no speakers quirk' that I've discovered searching the forums.

1.2 works with audio just fine.

I suspect it has something to do with it picking the wrong audio device. I have built in audio on the MB and a secondary on the HDMI connector on my radeon card. I've not connected anything to that HDMI port and I have the default audio source set to the internal realtek audio device. All other sounds work on the pc, it just appears as if hyperspin has not selected the default (or perhaps there is something wrong with my PC's default configuration that I am not aware of).

Anyway... that's where I am with this version. It really looks great though and I can't wait to get it working :)

Thanks again.

I tested 1.3 fine on my setup, with a HDMI connected with a radeon card.... no sound issues for me.... windows 7.... it should natively select the sound that window's has selected... all apps run this way, I don't see this being any different.... :x

Share this post


Link to post
Share on other sites
Thank you. That seemed to get it running.

I was not aware this changed.

I just need to figure out the exit from the PC game now since ESC seems to not work anymore. It used to. Do I need to specify for each game in the Settings.ini that I want to use ESC or is there a default somewhere.

This issue is related to the PCLauncher Module not Hyperspin.

How to fix it

Set ExitKey = Process and it should work 9 times out of 10.

If the game uses a proxy executable or you don't want to do a hard close change FadeTitle to equal ahk_class "Whatever the Window Class of this Game is" and ExitKey = WinClose. You can get your game's class name using ahk's window spy, djvj's window logger, or dustind900's PCLauncher Settings Creator.

Edited by ghutch92

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...