Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Announcement

    Sorry for the recent downtime. Still much to do but we have the site updated, secure and back online.  Expect more changes.

How To Set Up HyperSpin on the Nvidia Shield (Beginners Guide)


Recommended Posts

Also remember that Android doesn't like XML code for any symbols / punctuations. Android also will not read "&" symbols at all. You can fix xmls to and remove it's code for punctuations and just use them like apostrophes. A simple find and replace will fix them all. "&" Unfortunately... unless someone has found something differnt... you need to change to "and" on XML,rom, and all media... yea it sucks lol so I am kind of hoping someone found something different.

Also something you can do is change your Android settings file for each system to only show roms you have. You won't get errors but you will be missing Roms not spelled correctly or have these symbols in them.

Link to comment
Share on other sites

  • 2 weeks later...

Question on naming convention for .ini files, database files, and media files.

​So I'm a bit confused on how things need to be named.  I'm guessing Hyperspin is looking for a specific name of the .ini (settings) file for each system... What name should it be? 


Emulator: SNK Neo Geo

Should settings.ini be = SNK Neo Geo, or Neo Geo?


Also based on what the answer above is, I'm guessing that the database file needs to match the .ini file name, as well as the Media folder name for that system?   


The Emulator folder and rom folder don't matter as long as the .ini file has that proper directory added.  So the main question is again what names do the .ini, database and media files/folders need to be for Hyperspin to find them?

Link to comment
Share on other sites

So the simple answer is you can name them whatever you like so long as they all match.

The reason is that most things "official" use the more specific names.

So if you use sync programs or get you database from HyperList they will most likely come like that. You can rename them but then things like main menu themes, videos etc will all need renaming to match.

Use HyperList for your names mainly.

Link to comment
Share on other sites

  • 1 month later...

Hi, I am new to this. I have made a small hyperspin project on pc in the past so have a small amount of knowledge however I am struggling getting a setup to work on my NVidia shield tv.

I started off small and just went for a NES setup. I have all the videos, artwork and main hyperspin setup working however the first problem I encountered was it not finding roms. They where extracted and I had put correct rom types on XMLS and so on, I found that removing the path from xml solved my problem and it now finds the roms.

The problem I'm coming across now is when I click a game hyperspin flickers and it goes straight back to the game I have tried to start in hyperspin, retroarch doesn't seem to be starting up, I assumed maybe I didn't have the right cores so I uninstalled retroarch, tried hyperspin without and it showed up that retroarch was missing so I know originally it was finding it, I then reinstalled retroarch downloaded all the cores however same scenario hyperspin just flickers.

If anyone could possibly point me in the right direction of what maybe wrong that would be great. I am using hyperspin 1.4.

Link to comment
Share on other sites

Your rompath sounds incorrect

in the Nes ini settings file leave the "roms only" filter set to true. 

where are your roms located?

get retroarch setup again and test some Nes roms with it directly before moving on to Hyperspin setup.

search this forum for (tutorial) I have one one Hyperspin settings

Link to comment
Share on other sites

I'm just leaving my house for work sadly as I'm really looking forward to getting this sorted. Here is what my ini has in it. I will remove the / from the end of roms and I will also set roms only filter to true. Thanks for that I didn't even think about doing that, hopefully it will help me sort it.

[exe info]
rompath=Emulators/Nintendo Entertainment System/roms/

Link to comment
Share on other sites

Ok just only had a chance now to try this out, they launch fine in retroarch, I removed the / and also put true on roms only filter. Roms still show however still same thing screen just flashes when I try to launch a game ?


Ive even just tried a complete fresh install using the your HS Android Base Pack, again just nes, no extra artworks or vids just inserted roms edited ini and same thing all roms show but when clicked screen flickers then back to same point.

Link to comment
Share on other sites

Thanks for the help, I do appreciate it, and yes it is driving me mad :rofl: Ive been looking a lot through the forum and on youtube videos etc but I cant seem to figure out where im going wrong. I was even thinking about factory resetting my NVidia shield tv and starting again :unknown:.


Haha just after writing this I've just been looking on forum again and came across basically the same problem but it involved the marshmallow update, they resolved this problem by installing a nightly of retroarch... wondering if you think this might help ? also could you point me in the right direction to download a nightly build of retroarch ?

Link to comment
Share on other sites

I doubt it's the RA version if everything runs well outside of HS. Just to cut out the simple problems you are testing in RA with the nestopia core?

be aware that RA and HS use different retroarch.cfg files aswell so it does all make for hard work in the beginning.


concentrate on your file extension, exe & parameter lines in the HS setting file for NES. Check the all capitals are correct as its case sensitive

Make sure the setting file is named the same as it is in the main menu.xml, folder in Media and NES database all matching (case sensitive)

for the nightly configs have changed so full config per core are out and overrides are fully supported but I have not switched yet but testing on my PC and it looks sweet. Retroarch 1.4 is soon to be released so gonna wait for that .

For the nightlies go here and grab one of the dated retroarch files. Then uninstall your current ra and side load the nightly


i have some info on my website http://emulationguide.com/my-guides

Link to comment
Share on other sites

I did everything you said went through all of the lines and they was all perfect still no joy. I unistalled retroarch and hyperspin. Installed the latest nightly build of retroarch, reinstalled hyperspin, copied the same files over that ive been using and good news all working great. Ive got 3 systems working now. 

Just wondering on the nvidia shield controller what button do people use to exit a game ? Ive set mine to r3.


Thanks for all your help

Link to comment
Share on other sites

Good news.

I use the hotkey function. I set enable hotkey as R2 then exit as back key. I had trouble using the thumbstick press.

Badhemi uses just the back key mostly I believe, not seen many other posts about it.

I like then hotkey function as it gives you more options. Only downside is it takes a little getting use to for timing and you have to hit the enable key befor the shield button to get into the menu.


Link to comment
Share on other sites

1 hour ago, mako1200 said:

Sorry, I must be blind.  Where did you find the latest nightly of RA?  I couldn't find one in http://buildbot.libretro.com/nightly/android/.

I'm having the same issue on my shield TV. My inis looks solid, but still get a screen flicker when I try to launch a rom. No error messages :-/

your not blind, they seem to have gone.

Maybe they are updating just have to check back another time or post in their forum

Link to comment
Share on other sites

  • 2 weeks later...
On 10/3/2015 at 8:12 PM, reznnate said:

Another thing to confirm is that your usbdrive is named USBDRIVE*... I've seen a few scenarios where Android names a drive something odd.

Yes! I am trying to avoid my sd cards getting assigned random names as I suspect this is my issue with getting HS to run on Android. I assume HS cannot "see" any intended path of internal, sdcard1, or sdcard if, for example, I have a path like:


I've tried a simple "rename" in Android, it says it did it successfully but then all file browsers still show it with the strange naming.  Anyone have a fix?

Also, I am trying to set up my Android build for both a Shield TV and a tablet. Is there anything different one must do for both to work or are they interchangeable? 

Link to comment
Share on other sites

Wow this is hard. I am hoping someone releases a pre-config folder setup for shield or regular android. I've spent many intensive months with HS on PC but cannot get this loaded up on Android.  On a Marshmallow tab, loading HS only backs right out. This is on a rooted Cyogenmod build and using the Hyperspin apk from https://apkpure.com/hyperspin/com.shieldcade.hyperspin.

On the shield tv, I've gotten previously as far as the HS video loading and the wheels, but nothing loads... now I'm not even getting that. I've watched every tutorial and read the forums here. Roms and paths match perfectly, case sensitive correct, and even tested with one game and one system for minimal troubleshooting. I've tried loading it in RetroArch first, and the "eject card out and put back in again" trick. My roms are not zipped except for mame. I don't understand why the path starts with H:\ but deleting it or keeping it still won't work. I've even "fixed" the strangely wrong default paths like "master system' to 'Sega Master System' ... it is most frustrating when instead of providing an error message like RocketLauncher, Android just bumps out leaving you guessing from the HS log file.  Anyone have a lifeline to throw?

  • Upvote 1
Link to comment
Share on other sites

hey thatman84,

That guide of yours is fantastic especially the added detail and pre-config files.  I would caution that the ini files in the Settings_Android zip file (optional step) can replace your initial GOOD changes with the old bad habits again:
"path=H:\hyperspin\emulators\master system\"  

I have heard that Android ignores this line, but the replacement also erases your good "rompath=Emulators/Sega Master System/roms" with "rompath=ADD YOUR ROMPATH" which defeats the troubleshooting- one shouldn't mess with alternate paths until they have everything working with the defaults.

Still, ignoring that optional step, the guide is great and gets me much farther... HS loads and wheels turn. I'm using Sega Master System as an example.  When loading a game, it bumps me right back.  If I go load it in Retroarch first and then load HS, loading the game takes me over to my game already in progress. Also, if I stop the game and leave Retroarch in the blue menu, HS will bring me to THAT point when loading a game.  Seems loading a game in HS just brings me to whatever current state of Retroarch it is in...if not loaded at all, HS just bumps the game selection back to the HS game selection.

Is there a setting to USE retroarch rather than LINK to Retroarch?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...