Jump to content
Fromlostdays

How To Set Up HyperSpin on the Nvidia Shield (Beginners Guide)

Recommended Posts

29 minutes ago, garyb3529 said:

If I format the drive to internal storage will it allow me to plug back into my PC and edited .ini files?

No. That's why I edited my last post fella to tell you how to transfer files and access them remotely to do edits

Share this post


Link to post
Share on other sites
29 minutes ago, Honosuseri said:

No. That's why I edited my last post fella to tell you how to transfer files and access them remotely to do edits

Thanks for all your help! Just transferring everything over FTP right now. Once completed, will edit the .ini and upload those back. Will keep you updated!

  • Like 1

Share this post


Link to post
Share on other sites
10 minutes ago, garyb3529 said:

Thanks for all your help! Just transferring everything over FTP right now. Once completed, will edit the .ini and upload those back. Will keep you updated!

If you're using filezilla (like I do). You can edit the .ini files that are stored on the Shield TV. Filezilla will open notepad, make the changes then save and close notepad. Filezilla will ask to send the file back to the Shield TV to complete the change.

Share this post


Link to post
Share on other sites

Hyperspin booted properly

media is all there

i select a game from my games list, the screen just refreshes.

using the Shield game pad, I’m guess “A” should just launch the game no?  Or, like hyperlaunchHQ on the pc, do those controls need to be set?

Share this post


Link to post
Share on other sites

Hello Forum,

 

I'm a longtime MAMEr, that I used to just run on my PC - but I just recently downloaded hyperspin, and and the MAME set to run on my shield, and tried to follow this tutorial.  I've run into some issue as I'm learning as I go.  Hyperspin starts, but there's nothing really going on.  My only options are to exit really. So I figured if I can get MAME going, I'll figure the rest out.  I've read through all 15 pages of this thread, and I still have a few questions.

  1. The instructions say to download and install both Retroarch and Hyperspin, but there's nothing in the tutorial about retroarch configuration.  Is that correct?  If not, where are the instructions for configuring retroarch?
  2. I downloaded the Settings_Android-10May2015 pack.  Is this the latest?
  3. If I'm only working on MAME right now, what ini files have to be configured?  I'm assuming Android and MAME, but maybe settings.ini and main menu.ini as well?
  4. The MAME.ini in the Settings_Android-10May2015 pack references mame4droid in the exe= line.  Should that be changed to retroarch ( exe=com.retroarch/com.retroarch.browser.retroactivity.RetroActivityFuture)? Nobody actually specifies which ini file they're editing.  They're like 30 of them.  This is not that intuitive.

Answers to these questions should point me in the right direction.

Thanks in advance.

Share this post


Link to post
Share on other sites

@grymace welcome to the fold, I'm sure you will enjoy it once you Have MAME going.

 

Check out my pinned post on How to Setup Hyperspin It links to the Settings guide at the bottom.

My android base pack has some settings also and I may look at updating those next month as Retroarch has more cores.

 

For MAME emulator you have choices mame4droid works best v139 romset and is probably the most solid emulator but stuck with 2010 working games.

I have had better luck with Retroarch mame2010 core for things like cps2 for the above reason over the MAME current version core but that plain core from Retroarch is the only current MAME emulator on offer and is usually playable.

Take your core names from the libretro buildbot/Android/arm7 folders

thats where the online updater points to take the whole core_android_libretro.so name for your settings file parameter

and the exe line is the same for all cores. Lift that from one of the files you download settingsmay2015.

yes Retroarch needs some setup but there's plenty of info around on that

Share this post


Link to post
Share on other sites

What's the best MAME choice for the latest ROM set 0.193, or are those newer games even playable?  Are we limited to the v139 as the latest working set under Hyperspin on the Shield?  I have the .193 set, but just don't know which core to go with (MAME 2010 in Retroarch)?  Does the MAME core in Retroarch that is listed with no label/year run the .193 set or should I use MAME4DRIOD and skip Retroarch?

Share this post


Link to post
Share on other sites

MAME with no Year is latest and basically falls inline with official MAME so long as r-type updates the core which he has been doing quickly.

that core is commonly known as MAME Git

you will have to test newer games and let people know. I usually only play old games.

 

also afaik MAME in general has become more of a resource hog in last few years just because their priority is accuracy. Better accuracy tends to mean slower performance.

have  a play with some games and make a decision.

always good to report back so others can share the experience. :)

  • Super Like 1

Share this post


Link to post
Share on other sites

@thatman84

Thanks for the feedback.  I installed the Hyperspin Android base pack, and have two issues:

  1. Hyperspin loaded, but there is no video, or transition after the intro video.  If I move up or down, and hit the select button, I enter a game menu - but I'm flying blind.  I can switch it to single mode - since I'm only installing MAME at this time - but eventually I will add other games.  Is there a video missing for the main menu?
  2. Sometimes when I select a game in MAME, it will briefly go blank and return back to the game selection.  Other times, it will take me to RetroArch settings.  I assume this is because the retroarch isn't configured.  Is there a comprehensive tutorial for integration with Hyperspin?

Thanks again..

 

Share this post


Link to post
Share on other sites

No probs,

1. You have to grab video snaps yourself and place them in the relevant folders. Media/Main Menu/Vieos/MAME.mp4 etc

or media/MAME/videos/game name.mp4

PS transitions may be off in the main menu ini file see the pinned posts about settings for details

2. Not really a full guide because you need to just go through and configure the emulator 1st then Hyperspin will perform 100%. So long as your game names are the same in the xml all Hyperspin is doing is sending "launch-this game" 

it can be tricky but most games work fine

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...