Jump to content
HyperSync, HyperList and FTP are now back online ×

Archived

This topic is now archived and is closed to further replies.

iceman1981

hyperspin crashing

Recommended Posts

If i leave hyperspin running, after about 8hrs or so i get a white screen with a grey exclamation point.  when i look in the log it shows nothing that indicates what happened.  Does anyone have any experience with this issue?  its in a bartop, no other processes running, windows 7 64bit.  power settings are to never turn the hard disks off, i am pretty sure display turns off after 5 hours, but with this program running i don't know if its ever technically inactive.  Any time i come home to the white screen the computer is not asleep so i do not think thats the cause.

 

any help would be much appreciated

Share this post


Link to post
Share on other sites

I believe that could be it stopping on a bad video. Happens if using flv vids instead of mp4 too I think. Good luck.

Share this post


Link to post
Share on other sites

Dougan nailed it, switch over to .mp4s

 

Is there any other way to fix it?  Happens on occasion with my setup.  Seems totally random though, which is kinda weird.

Share this post


Link to post
Share on other sites

Follow up question:

 

So it looks like the only remaining FLV files I have are all transition animations.  I quite enjoy most of them so I'd like to continue using transitions but the grey exclamation issue persists.  I tried reencoding a couple of the .flv files into .mp4 (tried both mpeg4 and h264) but HyperSpin won't use those files.  I renamed from x264/.mp4 to .flv and that played the transition, but it disables any backgrounds in the actual theme, so that's a no-go.  

 

I'm getting close to just killing all the transitions unfortunately.  I can't seem to find a way to make them play nicely without relying on flash and thereby inducing the grey exclamation of death.

Share this post


Link to post
Share on other sites

Update:

 

It seems that disabling hardware acceleration in flash helps reduce the crash frequency a little.  In addition I found that the .mp4 file format does not inherently support transparencies so getting a true mp4 in place for a transition flv is basically impossible right now.  

Share this post


Link to post
Share on other sites

My install on an old IBM Thinkpad was stable under Windows 7, but I started getting the white screen error after a few hours in attract mode. I don't get it if I leave a game running. My research seems to show it's a Flash error, but other than suggestions of needs more RAM, reinstall or remove transitions I haven't seen anything that actually fixes the issue. The reinstall Flash doesn't seem to be much of an option in Win10 as its built in. Even though Win 10 seems to work on the old Thinkpad, I'll likely revert to. Win7 as that had no issues.

Hopefully someone finds a fix before I find the free time to reinstall...

Share this post


Link to post
Share on other sites

My install on an old IBM Thinkpad was stable under Windows 7, but I started getting the white screen error after a few hours in attract mode. I don't get it if I leave a game running. My research seems to show it's a Flash error, but other than suggestions of needs more RAM, reinstall or remove transitions I haven't seen anything that actually fixes the issue. The reinstall Flash doesn't seem to be much of an option in Win10 as its built in. Even though Win 10 seems to work on the old Thinkpad, I'll likely revert to. Win7 as that had no issues.

Hopefully someone finds a fix before I find the free time to reinstall...

 

Yeah it's a flash error.  According to the admins there's a memory leak in Hyperspin which makes the flash crash inevitable - at least for the time being.

Share this post


Link to post
Share on other sites
On ‎8‎/‎28‎/‎2016 at 10:40 PM, scoodidabop said:

 

Yeah it's a flash error.  According to the admins there's a memory leak in Hyperspin which makes the flash crash inevitable - at least for the time being.

I built a new Win7 PC, upgraded to HS 1.5.1, and it still crashes with the white screen after ~30 hrs.  I'm surprised no one else is flagging it as an issue if the admins have confirmed it's a memory leak.  I may end up making the PC kill and restart the process @4AM so I can leave it on, and avoid the issue :(

Share this post


Link to post
Share on other sites

I've read lots of things while making aeon nox, lots of people complain about flash memory leaking itself, I don't think it is hyperspin related.
Flash don't delete things when you remove them from stage, just flag unused stuff as "garbage" and time by time the garbage collector runs and delete stuff from ram. If you open task manager and run HS you'll see ram usage increasing and decreasing while browsing games.

The problem is at a certain point problems occurs and ram leaking starts, so yeah, if it is a 24/7 rig just plan a reboot everyday.

Share this post


Link to post
Share on other sites

Good point about it being a Flash issue, not a HS issue.  Highly plausible!  

Solutions are to make sure you don't have much running in the background (to free up RAM) and add as much RAM to the PC as you can afford.  30 hours is pretty good though!  Nothing to sneeze at!

What about a script or Windows Task Scheduler to close and reopen Hyperspin after 12 or 24 hours? Anyone tried that yet?

 

Share this post


Link to post
Share on other sites
On 12/27/2018 at 11:20 AM, scoodidabop said:

What about a script or Windows Task Scheduler to close and reopen Hyperspin after 12 or 24 hours? Anyone tried that yet?

Good to see you again, it's been a while!

You might have missed this utility: 

 

Share this post


Link to post
Share on other sites

HyperRefresh, funciona por tiempo asignado en su "conf" por mili segundos, si estas jugando en un determinado tiempo se cerrara y volvera abrir HS, Yo uso un refresco cada vez que ingreso a una categoria sub-wheel (Scritp de terceros) es así que constantemente puedo tenerlo todo el día encendido en mi maquina arcade.

 

Share this post


Link to post
Share on other sites
8 hours ago, DomusdelCapo said:

HyperRefresh, funciona por tiempo asignado en su "conf" por mili segundos, si estas jugando en un determinado tiempo se cerrara y volvera abrir HS, Yo uso un refresco cada vez que ingreso a una categoria sub-wheel (Scritp de terceros) es así que constantemente puedo tenerlo todo el día encendido en mi maquina arcade.

Seguir

Yes, but by using HyperRefresh, you can have the machine running even when no one's playing it. Set it to a 12 hour restart and let it go.

Share this post


Link to post
Share on other sites
4 minutes ago, griffin518 said:

Sí, pero al utilizar HyperRefresh, puede hacer que la máquina funcione incluso cuando nadie la está jugando. Establézcalo en un reinicio de 12 horas y déjelo ir.

Claro su función es cerrar y volver abrir HS en un determinado tiempo. el refresco también puede darse cuando cierra HS y lo vuelve abrir al ingresar a una categoría si no uso mi arcade en 5 min de inactividad se hiberna y continua el ciclo.

Share this post


Link to post
Share on other sites
On 12/30/2018 at 2:38 PM, DomusdelCapo said:

HyperRefresh, funciona por tiempo asignado en su "conf" por mili segundos, si estas jugando en un determinado tiempo se cerrara y volvera abrir HS, Yo uso un refresco cada vez que ingreso a una categoria sub-wheel (Scritp de terceros) es así que constantemente puedo tenerlo todo el día encendido en mi maquina arcade.

 

Hola Domus! podrias decirme que script usas y si podes adjuntar algun link o algo con una breve explicacion sobre la intalacion?, estare muy agradecido!

Share this post


Link to post
Share on other sites

×
×
  • Create New...