Jump to content
newoski

HyperSpin.exe + NVIDIA VSync?

Recommended Posts

Hi Guys,

 

Where necessary, I have unique application settings in NVIDIA Control Panel to prevent tearing in emulators. IE MAME, Mednafen. 

 

At this point, the only screen tearing I still have is in HyperSpin themes. 

 

If I turn on VSync in NVIDIA Control Panel for HyperSpin.exe, the problem goes away. 

 

My question is... since HyperSpin runs in the background during emulator usage, will that force VSync for ALL games... or just when HyperSpin has focus?

Share this post


Link to post
Share on other sites

Jeremy,

How does this reply benefit anyone, yourself included? I've seen 2 replies like this from you this week, and I just don't understand the point...

I have tried it out, but it's hard to tell. However, after speaking with NVIDIA, they have told me that this solution will work. It will turn vsync on when HS has focus, and off when it doesn't.

Sent from my HTC6535LVW using Tapatalk

Share this post


Link to post
Share on other sites

Try it out and see for yourself.

Seriously, you are of no help. If your not willing to contribute any useful knowledge to his problem, then go away. Posting a smart a** comment isn't necessary.

Share this post


Link to post
Share on other sites

My point, and I can only speak for myself, is that your comment provides no benefit to anyone, yourself included. I asked a question, because despite "trying it out for myself," I was uncertain what the impact was. Thus, I asked a question on the forum. 

 

Looking at recent threads you've started...

 

 

Anyone know how to make a MAME xml with no clones? Any of the 3rd party apps that can handle this?

 

 

 

Or I guess I don't really need a database as much as a way to remove all clones from a folder and have only parents.

 
 

Imagine if we as a community responded "try it out for yourself" instead of providing an answer...

Share this post


Link to post
Share on other sites

That doesn't make any sense

 

Which part? My point is simply, if you don't have anything productive to add, simply telling someone to test it on their own is not helpful. Period.

Share this post


Link to post
Share on other sites

That doesn't make any sense

If that doesn't make any sense, then go try it out for yourself. Sorry, I had to do it.

Share this post


Link to post
Share on other sites

My question was straight up which program can do this thing. It would have been different if I asked say, if I use so and so program to remove clones will it take the Clones out of my database. At that point it gladly could have been said to try it out and see.

 

No hard feelings, bro. Let's close this thread. I think it has more than run its course...

Share this post


Link to post
Share on other sites

I was searching for screen tearing problems and found this topic.

 

I just can't get rid of screen tearing in Hyperspin, even when i force vsync with Nvidia panel. All the themes and such look terrible because of this.

 

Is there any other way to force it somehow?

Share this post


Link to post
Share on other sites

Yes, per application settings in NVIDIA

I already did this (i thought i was clear in my post) and it doesn't work. I do have VSYNC ON as default for all programs but even if i select "ON" specifically for Hyperspin, i still get screen tearing with it.

Share this post


Link to post
Share on other sites

I already did this (i thought i was clear in my post) and it doesn't work. I do have VSYNC ON as default for all programs but even if i select "ON" specifically for Hyperspin, i still get screen tearing with it.

 

Thought so, but wanted to be sure. Try setting it to OFF via a per application setting for HyperSpin only

Share this post


Link to post
Share on other sites

Thought so, but wanted to be sure. Try setting it to OFF via a per application setting for HyperSpin only

Well, oddly this seems to work better. I still get some minor screen tearing every now and then but overall, it's pretty good. I wonder why this happens though.

 

Edit: No, scratch that, it still has the same problem, it just goes away randomly sometimes.

Share this post


Link to post
Share on other sites

Bump.

 

Problem still exists after all this time. No Driver settings fix the horrible screen tearing. I even tested a different monitor and the problem persists.

 

The emulators/games themselves don't have this problem. It's only the Hyperspin UI and themes.

Share this post


Link to post
Share on other sites

I've never had any screen tear in HyperSpin itself.

I'm wondering why you both have the issue in the first place. Are you running actual arcade monitors with odd or extremely low refresh rates or something?

EDIT: It's also always funny reading a thread after Jeremy was exorcised from it. Ha!

Share this post


Link to post
Share on other sites

I've never had any screen tear in HyperSpin itself.

I'm wondering why you both have the issue in the first place. Are you running actual arcade monitors with odd or extremely low refresh rates or something?

EDIT: It's also always funny reading a thread after Jeremy was exorcised from it. Ha!

 

I have two monitors, an old, standard PC CRT and an LCD samsung TV. I get screen tearing in the theme screens (not the emulators) in both, even at standard 60hz. I tried all settings in Nvidia panel and i tried both fullscreen and windowed. There is no difference. Hyperspin completely ignores any setting and just likes to tear the themes. This problem persists after several driver updates as well.

 

Maybe it's a graphics card specific problem? But Hyperspin is the only program that does this to me and it's annoying to use. It also kinda defeats it's purpose since Hyperspin is all about the visuals.

Share this post


Link to post
Share on other sites

You tried my recommendation, right? That fixed the exact problem on my ASUS GPU

Sent from my HTC6535LVW using Tapatalk

Share this post


Link to post
Share on other sites

My recommend was to turn sync OFF for HyperSpin via per app setting

Sent from my HTC6535LVW using Tapatalk

Share this post


Link to post
Share on other sites

Ah. Bummer. I'm out of ideas. I spent so much time troubleshooting and that's what worked for me

Sent from my HTC6535LVW using Tapatalk

Share this post


Link to post
Share on other sites

Well, i couldn't fix the issue so i did something else. I modified the xmls in most themes so that the assets move faster on the screen. For instance, instead of the box art scrolling for 1.5 seconds to reach it's destination, i changed it to 0.4. This way the box comes into place almost immediately so even when the image tears, it's too fast for the eye to concentrate on it, thus it's much less annoying.

 

So i will modify most of my themes this way. It's better anyway since it feels more "snappy". If anyone is bothered by the same issues, i recommend this "fix". I assume you can modify the time to "0" so your assets appear on the screen without scrolling (thus no tear at all).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...