Jump to content

Honosuseri

User
  • Content Count

    786
  • Joined

  • Last visited

  • Days Won

    4

Posts posted by Honosuseri


  1. Yes helpful.  I have a fully working PC setup in my cabinet but this android build is giving me issues.  I have all the stuff setup but when i hit a rom for a system the screen flashes quick and nothing happens.  Roms open fine direclty in retroarch.  NES and Genesis roms are zipped but i did have this working at some point so dont think thats the issue.  Has to be something in the .ini file but i can't find any issues.  Roms are found, media and everyting is there, database files match the same name as roms so not sure.....

     

    Perhaps your parameters line is incorrect in the .ini file, this determines which retroarch core is used. It could just be a typo or maybe you haven't downloaded that particular core in retroarch's online updater. Yes I know the games are working in Retroarch but you could be say using picodrive in RA when your Sega Megadrive.ini has genesis_plus_gx set to load and hence no dice when lauching from Hyperspin. Long shot but anything is possible, it's always a silly little mistake that trips us up.

    I have a USB HDD attached as adoptive storage to the Shield TV, my Roms folder is inside the Hyperspin folder. It definitely works so I'll give you a snippet from my Sega Megadrive.ini if it helps you.

     

    path=/storage/emulated/0/Hyperspin/Roms/Sega Mega Drive/
    rompath=/storage/emulated/0/Hyperspin/Roms/Sega Mega Drive/
    userompath=true
    exe=com.retroarch/com.retroarch.browser.retroactivity.RetroActivityFuture
    romextension=zip
    parameters=cores/picodrive_libretro_android.so
    searchsubfolders=true
    pcgame=false
    winstate=HIDDEN
    hyperlaunch=true
    • Upvote 1

  2. I don't know why you are laughing...I can read ;)

    http://www.hyperspin-fe.com/topic/14158-android-hyperspin-patch-files-for-hfsbox15k-starter-pack/
     

    "The mame2014 core should be faster than the mame core (which is why I suggested it).The retroarch buildbot is broken but I do expect the core will return soon." Rezznate

    That thread was started in January...Mame 2014 is still missing. Rezz had hoped it would return soon but it hasn't. As this is a recent thread Rezz would tell someone to use Mame Git as at least some of the games do work with it. The Capcom 1&2 systems work with Mame Git, yet they are set to use Final Burn Alpha....quite possibly as it doesn't have the default nagging warning message, just loads the game directly. Rezz also confirmed that Mame2014 was needed for Capcom 3 and Sega ST-V runs slow on Mame Git. Rezz has done the hard work for me....so I choose to follow his preferences rather than just use Mame Git for all.

    I'm not wasting my time if I am helping others. I was a "noob" once and it's nice to give something back :)


  3. Sting, I'm not uploading a video any which way lol It's not to prove you right or wrong, just help others...I can only test what I own. I am not convinced it is a "hardware issue"....

    Rezz provided files to patch the HFSBOX pack I am toying with for Android. CAVE was set to use Mame 2014 not Mame Git, Capcom 3 was also set to use Mame 2014. I've tested Mame Git it won't run the Capcom 3 roms, Mame 2014 must run it or why else would Rezz set the .ini files to use it? So I am under the impression that Mame 2014 is just better optimised than Mame Git for the hardware. The roms are compatible with both of the cores as I tested them on my HTPC.

    I've set CAVE to use Mame Git as at least some of the games will load...something is better than nothing for now. Deathsmiles behaves exactly like the Capcom 3 roms do....so maybe....just maybe it would load under Mame 2014. I don't need to see a video as proof, I someone has tested it and knows for a fact it won't load under Mame 2014 on the SHIELD TV....I shall remove the incompatible games from the CAVE wheel.


  4. just to clarify!!!! Sorry if I misled anyone by my post . I am not selling any android setups. I am a newbie and There are plenty of people that have these for sale and I am not stepping on anyone's toes. I just meant that I will have one soon that has every system possible that can be emulated by android. Sorry guys!!!! I can help with ini Files if anyone needs them.

    I've only just seen this as I was typing out my post above!

    I didn't think you were selling a setup, just making one available to download....much like the free HFSBOX15K I mentioned. Shame as I was looking forward to seeing what you've been working on...maybe you could just do a video walkthrough to demo it then? :)


  5. Connorsdad

    I just got a shield its great. Although I'm only a beginner, think I'll wait for that package badhemi. While I figure out retroarch

    I look forward to seeing what Badhemi has done too! :)

    I've recently modified the HFSBOX15K starter pack for android use, one of the members here Rezznate mentioned it in a thread on the forum. I've removed what was Junk, replaced the French with English and added in a couple of extra wheels (N64 & Master System). Everything has a theme (I changed a few), artwork and video etc...I'm pretty happy with it as including roms it's just under 40GB.

    Retroarch isn't very user friendly but you'll soon pick it up. More often than not it makes sense to use it, I didn't have much luck with the Mupen core for N64 though. I installed the Mupen64 Alpha V3 apk on the SHIELD and I've set the N64.ini to use this emulator instead of Retroarch for that wheel.

    If you want to kill some time while you wait to see what Badhemi has done. Might I suggest you try installing KODI or SPMC from the Google PlayStore, I use it basically as a home screen/Dashboard for the SHIELD TV. I launch my most common apps from it, so the Arcade, Netflix, PS4 remote play etc. It will access and play my videos and music and provide the box art for the menu, I don't want to get into third party addons too much...however there is an ITV player addon which you could use until they add the official android app to Google TV.

    All the best with your Hyperspin setup on SHIELD :)


  6. I thought (MAME) core was (MAME2014) and (MESS) together as one??? I can even run (SEGA M2) with the (MAME) core, not at a speed you can play it, but the roms load. All my arcade wheels are running through (MAME) core. And has anyone got Deathsmiles running on an Android device???

    As I understand it...

    2000 = 0.37b5

    2003 = 0.087

    2010 = 0.139

    2014 = 0.157

    Mame git = current rom set

    Mame4droid has two versions (0.37b5 & 0.139u1) for certain Rom sets, so one is basically Mame 2000 the other Mame 2010. I tested my Deathsmiles Roms on my HTPC with both those Mame cores, it crashes Retroarch so I wouldn't expect any joy with Mame4droid either. Mame Git and 2014 will run them on my HTPC, Mame Git appears slow on android which is most likely why the roms aren't loading right.

    You're asking if somebody has Deathsmiles running on Android. Some people probably do because they installed the Mame 2014 core when it was available.....sadly that doesn't help you as it's not available on Android's Retroarch core updater currently. If your device is rooted you can try and add the mame2014 core manually.

    So as I've already said...On my SHIELD TV, Retroarch with Mame Git will launch some CAVE Roms but not all, ideally you want Mame 2014. DeathSmiles 2 doesn't load on either of those cores even on PC, the HFSBOX15K pack for Windows uses GroovyMame to emulate CAVE and CAPCOM Systems. At some point I'll try game streaming my PC version of Hyperspin to the SHIELD TV to access Wheels that Android can't do well or at all.


  7. Just had a play with it, the earlier ROMs load no problem, but the later ones crash. I'd say this seems more like an hardware issue than BIOS issue, but if anyone has later game ROMs like Deathsmiles I'd like to see a video with it loading and of there settings and ROM set.

    I'm not uploading a video but I tested Deathsmiles and Deathsmiles Black label with my HTPC, using Retroarch and the Mame2014 core. Both loaded fine to play, as I said the Mame2014 core is missing from the android version of Retroarch. Rezznate has said this missing core has stopped some of his favourite wheels working, he is waiting for the 2014 core to return....I shall follow his advice :)


  8. I tried and they all load to 100% then kick back to game wheel. Bummer

    We are in danger of hijacking the thread! lol

    I dunno Hemi. I know my Windows setup uses Mame & CHDs 0.161. I have no idea what's on the SHIELD TV as it's from the HFSBOX starter pack I'm toying with. If you have the 0.161 romset, I can try copying some over and see what happens for you. The OP said he has 0.164 so I'm not much help to him.

     

     

    Someone post me a list of Cave games!!! I've not got a cave wheel, and it's not a machine I've ever been familiar with. I'm pretty sure they need BIOS files though, the mame packs usually come with the BIOS files included, so try putting the BIOS files in with your ROMs.

    My WIndows Cave and HFSBOX15K pack seem to be using the same XML file. It's available here (http://www.hyperspin-fe.com/files/download/8069-cave-hyperbase-database-official/). Rocket Launcher (easier to read) tells me there are 43 roms, not sure if the XML is complete but that's a good start.


  9. I tried running thru mame and it crashes. Do you have to put roms in system folder of retroarch

    Sorry, I thought I included the rom path, edit has been made. They are located in my Hyperspin folder, I use a 500GB USB drive as adopted internal storage.

    I'm definitely using the MAME Git. I've just had a quick spin through the wheel, most load, some do launch into mame but crash when loading. Maybe you're launching one of these "duff roms", perhaps try a few others. I'm not going to faff around as more than likely using MAME 2014 is the solution. I understand that I could add that core manually....but I don't want to root the device and mess around. I'll just wait it out and see if MAME 2014 returns to Retroarch.

     


  10. I've recently setup CAVE as I was having a play with the HFS15KBOX Rezz recommended. I'll include some of my cave.ini below regarding the cores.

    rompath=/storage/emulated/0/Hyperspin/Roms/Cave
    exe=com.retroarch/com.retroarch.browser.retroactivity.RetroActivityFuture
    romextension=zip
    parameters=cores/mame_libretro_android.so

    The Mame2014 core is still missing from Retroarch's online updater....pity as I really need that for some other wheels (Capcom System 3,Sega ST-V)

  11. First off not all your wheels may be able to be used. It's dependent on whether there is a compatible emulator for android.

    Reznnate has already done a very good setup guide (http://www.hyperspin-fe.com/topic/8304-setup-hyperspin-for-android/). I'd suggest you install Retroarch (it's free) and use its online updater to download the cores (i.e emulators) that you need. Your .ini files will need tweaking, Rezznate's 3rd post in that forum thread will help you out with that.

    You might well want to use different emulators to Retroarch in some situations...I use Mupen64 Plus AE (V3 Alpha) for the N64 as an example. More often than not I'm using retroarch though. I wish you all the best with it, I'm sure you'll have plenty of other members pitching in to help you out :)


  12. I'm just starting out and agave a small PC setup that isn't really going to fit in to "home life" so moving over to shield tv.

    I think I have this themes problem so will check next time and use this topic to fix it hopefully!

    What is the HSFBOX15 pack? Sounds interesting I would certainly be greatful for some more info Honosuseri.

    I wish you all the best with your shield setup. Although I figured out the issue for myself in the end, it was great to get such quick replies and people willing to help here...I think you'll be in safe hands :)

    Reznnate actually already has a topic here on the forum about HFSBOX (http://www.hyperspin-fe.com/topic/14158-android-hyperspin-patch-files-for-hfsbox15k-starter-pack/)

     


  13. glad you got it going. Reznnate is a master!!! I had that problem too. I set my special art too true but set all defaults to false

    Now you tell me ;)

    I originally was porting over from my Windows version what was compatible with the Shield, that Main Menu.ini has Special Art set to true and defaults as true. That's what I've altered the android version to and it seems a ok now, I knew I'd have to change the Rom paths and make some tweaks...it's always something silly we miss that causes so much grief lol

    I'm very thankful to Reznnate & the guys who put together the excellent HFSBOX15K pack. I couldn't find an alternative starter pack to download, I'm converting it to English from the French locale. Maybe in time I can share it to help others who are starting out.

    • Upvote 1

  14. I've resolved it! The patched android files Reznnate provided needed more attention..../Settings_Android/Main Menu.ini

    Special Art A and Special Art B needed Active=True...they were set to false. Having made the change everything is now working as it should. The Joystick shows and the system themes are loading on first launch...PHEW!! :D

    Once again thanks to everyone who took time to look into the issue


  15. Oh I forgot to mention...the "Next System", "Previous System", "Free Play" artwork text and the joystick are clearly missing from the Main Menu too as you can see in the video. They don't appear even after entering and exiting a system. The swf files in Media/Main Menu/Images/Special were in French, I just copied over the English version I already had.

    Luckily as I said the whole setup isn't very big at 40GB. It's not the end of the world if I have to start again and copy stuff back over, I just wanted to make sure it wasn't a known issue or if anyone had a "quick fix"


  16. I have the same problem with Nintendo game cube system wheel. It has regular text but when I click on then back out to system wheel It has the correct game wheel image. This is in pc and not android for some odd reason

    Sorry to hear you have some niggling problems too Badhemi :(

    My wheel art work is absolutely fine and I have changed them from the rounded HSF15K ones that came supplied. It is literally the system themes, if they all misbehaved the same it might help but each system theme is missing something different until they are reloaded after entering any system. I just thought it might be an issue with loading the SWF files on android.

    If we can solve it, I do hope it puts you on the path to fixing your system. Many of the .ini settings aren't valid when using the Android version so what fixes yours might not help me and vice versa.


  17. I've never seen this issue and cannot even imagine what would cause it.  Maybe it's something weird with overlay videos?

    I don't even know what else I would suggest you test.    Which device is this?

    Thanks for the reply Reznnate....I was hoping you might :) Yes it's stumped me too as I can't see any obvious reason for it either.

    I am using the Nvidia Shield TV but I do have more experience with the Windows version of Hyperspin to be fair. I have an extensive PC setup but I wanted something much smaller that could fit on a 64GB memory card for the Shield.

    So basically what I have done is use the HFS15K Box "starter pack" then patched it for android with the download you kindly supplied. I removed the "junk files" e.g for systems that aren't android compatible. As you know much of it is in French so I have changed the artwork/games to English versions. I added the N64 and Master System and it works great apart from the systems that need Mame2014...Retroarch still hasn't brought that core back yet it seems.

    It's a pretty solid collection and it all weighs in at just under 40GB. I'm very happy with it, so thank you for all the help you've already provided for us. It's just bugging me that the main menu themes aren't loading properly on first launch. As I scroll down through each system the theme will either be missing the background or a character artwork won't display. As soon as I enter a system and return to the main menu, they load fine. I soon cottoned on that the 16:9 themes don't play nice so I've used 4:3...the themes are fine I'm just puzzled why they don't load properly on first boot.

    Being new to the android version I didn't know if it was a bug or something I'd have to live with until an update came around...if it has you stumped, I don't feel quite so stupid anymore :)

     


  18. Hey there Spinners! Looking for a little advice/help if anyone has encountered this...

    Basically whenever I first launch Hyperspin (on Android) the Main Menu isn't loading the themes properly. It will either be missing the background or artwork, varies from system to system as I scroll through. If I select a system, the game themes load just fine....when I back out and return to the main menu the missing assets load and every system theme looks as it should.

    It's not the end of the world but it would be nice if the main menu themes would load fully first time around. If anyone has any idea why this might be or can point me in the right direction that would be fantastic! Of course I'm willing to provide any extra info deemed to be needed.

    Thanks for your time reading my woes

     

×
×
  • Create New...