Jump to content
Welcome Guest!

Join us now to get access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, and so, so much more. It's also quick and totally free, so what are you waiting for?

Recommended Posts

Yes, two wireless xbox360 controllers.  I had to also setup xpadder for windows 7 compatibility mode.  I found this, which did the trick:

 

 

 

Now, about this exe - is windows defender just seeing this as a false positive?  Much appreciated.

Share this post


Link to post
Share on other sites

I tried to download this fix/exe file and I keep getting Windows defender trojan horse issues... Specifically:

You mean for this Killer Instinct fix? Yes, Windows Defender see's it as a threat for some reason. Does it on mine to. Flags it everytime I back up my machine.

Share this post


Link to post
Share on other sites

Thanks for this thread everyone.  I've got it all setup and working except for 2 player controls.  I've got this running on via my cab that has an IPAC, so I need 2 player controls working via a keyboard.  I tried setting up AHK as described but when I set it up, it doesnt work.  Are you using AHK internal or external.  Mine was set to false but when I change and try to setup via internal, it seems to cancel my buttons out.  EG) I just setup enter to be the '1' key to try it out and I couldnt get that to work.... I use vjoy for MKX... xboxce for SF4... Is their another method people have had success with as my AHK seems to not be working correctly...I dont know why...

Share this post


Link to post
Share on other sites

Thanks for this thread everyone.  I've got it all setup and working except for 2 player controls.  I've got this running on via my cab that has an IPAC, so I need 2 player controls working via a keyboard.  I tried setting up AHK as described but when I set it up, it doesnt work.  Are you using AHK internal or external.  Mine was set to false but when I change and try to setup via internal, it seems to cancel my buttons out.  EG) I just setup enter to be the '1' key to try it out and I couldnt get that to work.... I use vjoy for MKX... xboxce for SF4... Is their another method people have had success with as my AHK seems to not be working correctly...I dont know why...

It works just setting it up using RocketLauncher's AHK Keymapper.

RLUI>System>Keymapper>AHK create a new game profile.

What exactly are you typing in to remap it?

For example to setup your "1"key to be "enter" on a single line you would put: 1::enter

To make your X button send P1 light punch (which is "u") you would put: x::u

ALSO: I'd suggest adding this line at the top: #MaxHotKeysPerInterval 200

As I found KI through iPac sometimes spams a button press hundreds of times for some reason, that line should keep the game from locking if/when it does

Share this post


Link to post
Share on other sites

Thank you! This is gonna come in handy when I build my cab in the next few months. My favorite game of all time!

You're welcome.

And for everyone that doesn't know they released Eyedol as the final character of season 3 yesterday. So now every character from KI 1 & 2 are in the new installment.

Here's hoping they do at least 1 more full Season next year.

Share this post


Link to post
Share on other sites

It works just setting it up using RocketLauncher's AHK Keymapper.

RLUI>System>Keymapper>AHK create a new game profile.

What exactly are you typing in to remap it?

For example to setup your "1"key to be "enter" on a single line you would put: 1::enter

To make your X button send P1 light punch (which is "u") you would put: x::u

ALSO: I'd suggest adding this line at the top: #MaxHotKeysPerInterval 200

As I found KI through iPac sometimes spams a button press hundreds of times for some reason, that line should keep the game from locking if/when it does

Ok, so I got some of the remapping working.  Can you post your AHK config?  I have a standard ipac layout.  I've got player1 working fine but when I setup player 2, it is using some of player1 controls and it doesnt seem right.  One thing i've noticed is that the AHK is kind of finicky.... where I had to past Medium kick and hard kick buttons at the top of the AHK lines... i just happened to move them up because I wasnt getting any response...  I'm wondering if that's why my player 2 isnt working right.  Any suggestions?  Appreciate it.

Share this post


Link to post
Share on other sites

Here's what i've got and player1 works.  Player2 does not:

 

#MaxHotKeysPerInterval 200
Z::K
X::L
1::Enter
5::Space
Up::W
Down::S
Left::A
Right::D
Lcontrol::U
Lalt::I
Space::o
LShift::J
 
2::Numpadadd
R::Up
F::Down
D::Left
G::Right
A::Numpad4
S::Numpad5
Q::Numpad6
W::Numpad1
I::Numpad2
K::Numpad3

Share this post


Link to post
Share on other sites

Okay, I've learned that AHK works better if you let it auto-configure the keys - everything works if i let AHK discover and build out.  I have an Ipac with 8 buttons, so some of these cancel out used keys so that player 2 wont interfere with player 1.  

I've got it working and if i save someone the hours i've spend - here ya go:

 

#MaxHotKeysPerInterval 200
1::Enter
5::Space
Up::W
Down::S
Left::A
Right::D
Lcontrol::U
Lalt::I
Space::o
LShift::J
2::Numpadadd
a::Numpad4
s::Numpad5
q::Numpad6
w::Numpad1
i::Numpad2
k::Numpad3
r::Up
f::Down
d::Left
g::Right
z::k
x::l
6::Numpad0
j::Numpad7
l::Numpad8

Share this post


Link to post
Share on other sites

So I'm trying to run this game offline with no luck.  I bought Season 2 on Xbox a long time ago and when I sign in on my Win10 PC all the S1 and S2 characters show up just fine.  When I unplug from the internet the game goes into "free"/basic mode with only Riptor available and all other characters locked.  Anyone else having this problem?

Share this post


Link to post
Share on other sites

So I'm trying to run this game offline with no luck.  I bought Season 2 on Xbox a long time ago and when I sign in on my Win10 PC all the S1 and S2 characters show up just fine.  When I unplug from the internet the game goes into "free"/basic mode with only Riptor available and all other characters locked.  Anyone else having this problem?

 

I would guess that since PC wasn't your platform of purchase, it requires you to be online to cross reference with your xbone purchase.  Otherwise you could log onto windows on a bunch of different computers and just unplug and they would have the full version of the game.

Share this post


Link to post
Share on other sites

Anybody else having problems getting this game to close without error since the most recent update to the PCLauncher module?

 

I still have KillerInstinct_UWPx64_r.exe setup for the AppWaitExe 

I can's say as I reverted my entire RL build to the prior version from before 4/19/2016

Do you have it set to close "in-game" in the PCLauncher module settings?

Share this post


Link to post
Share on other sites

What are the new settings?

 

FadeTitleTimeout which allows you to change the amount of time before it will look for the window title and throw the Fade Title error and FadeTitleWaitTillActive which you can set to make it so it won't wait until the fade title window is active.

Share this post


Link to post
Share on other sites

FadeTitleTimeout which allows you to change the amount of time before it will look for the window title and throw the Fade Title error and FadeTitleWaitTillActive which you can set to make it so it won't wait until the fade title window is active.

Nice. Both of those would help with MKX which has a weird, hellishly long initial load time.

Share this post


Link to post
Share on other sites

Anybody else having problems getting this game to close without error since the most recent update to the PCLauncher module?

 

I still have KillerInstinct_UWPx64_r.exe setup for the AppWaitExe 

I just tested it for you and the game is working just fine for me (Win 10 latest updates). So whatever caused your issue it isn't Win or the game itself.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ceekay011
      Hi Arcade fans,
      1 year a member of this forum, but have still not much posts on my name , but found much usefull tips to read: D
      As each Member I have put much money in Arcade cabinets and always wanted one for my self , especially a KI or MK cabinet...
      4 year ago i buyed a killer instinct cab with myhtpc and mamewah interface.
      Since a few months(hyperspin not included) I have made some updates.....

      Black T-moding replaced by light blue T-molding, its a bit scary at first


      New plexi and all pushbuttons + joysticks replaced.

      old black T-molging used for the edges on the side of the marquee and top of the monitor bezel. (The lights in the bezel are of the led PCB(aimtrack)

      2usb connections for the attachment of aimtrak gun or usbstick.

      7-Pin lock + tumbler switch + led lighting with soundsensor in the inside of the cabinet.

      Running hyperspin(1 year work) of course
      high resolution pictures : http://imageshack.us/photo/my-images/36/14998645.jpg/
      Thats it.....i guess
      Greetings
      Chris
×