Jump to content
Guest rynoman03

Need Help Getting DEMUL 0.7a to work with Hyperspin.

Recommended Posts

Guest rynoman03

Hello Hyperspin Community

 

I'm having some issues getting Hyperspin to load my Sega Naomi games.

(Placed some images below, not sure if I put them on the page correctly but if you right click and open link in new tab they are very readable.)

  • I am running Demul 0.7a with Demul 0.7a roms downloaded from a reputable source. 
  • Using the Database XML from HS provided by Circo
  • Games Launch with Demul and I can fully play them.
  • Games Launch with RocketLauncher even though a game audit shows every rom red.  
  • All of my CHD files are in their respected unzipped folders. 

post-118195-0-01828500-1471708466_thumb.png

  • All of my Rom files are Zipped still.

post-118195-0-07650300-1471708572_thumb.png

  • I'm not 100% positive I have my Hyperspin HQ setup correct for this Emulator.

 

post-118195-0-76171000-1471708210_thumb.png

  • I'm probably missing something simple but this is the error i'm getting. I have tried to change the chd file name to match what it is asking for but then it says it can't find the ini file with the original file name associated with it. 

post-118195-0-62243100-1471708750_thumb.png

 

 

Any help would be greatly appreciated and I can provide any other info needed. 

Share this post


Link to post
Share on other sites
Guest rynoman03
Logs Below:

(I've tried enabling "Use Full Path to Roms:" & "Search Subfolders:" Neither setting helped. 

 

04:50:51 PM |  HyperSpin Started 

04:50:51 PM |  Going FullScreen 

04:50:51 PM |  Checking for updates 

04:50:51 PM |  Update Check Complete 

04:50:51 PM |  Startup program unavailable 

04:50:51 PM |  Playing intro video 

04:50:54 PM |  Menu Mode is multi 

04:50:54 PM |  Loading Main Menu.xml 

04:50:54 PM |  Main Menu.xml successfully loaded 

04:50:55 PM |  Main Menu wheel loaded successfully 

04:50:56 PM |  Loading Sega Naomi.xml 

04:50:56 PM |  Main Menu.xml successfully loaded 

04:50:56 PM |  Sega Naomi wheel loaded successfully 

04:50:57 PM |  Launching Game 

04:50:57 PM |  Using HyperLaunch

04:50:57 PM |  Getting Launcher path 

04:50:57 PM |  Launcher located at K:\RocketLauncher\RocketLauncher.exe

04:50:57 PM |  Running Launcher 

04:50:57 PM |  Launcher Command Line is: K:\RocketLauncher\RocketLauncher.exe "Sega Naomi" "cvs2gd"

04:51:07 PM |  Loading Main Menu.xml 

04:51:07 PM |  Main Menu.xml successfully loaded 

04:51:07 PM |  Main Menu wheel loaded successfully 

04:51:10 PM |  Exit program unavailable 

04:51:10 PM |  Quiting Hyperspin 

04:51:10 PM |  Bye! 

Share this post


Link to post
Share on other sites

You should never rename CHDs or MAME rom files. For Naomi you should have the "Skip Checks" setting in RocketLauncherUI set to "Roms Only". That way RL won't look for the rom file avoiding the error and Demul will load the game just fine. Also make sure that you have the "7z enabled" setting set to false on the Settings tab, that's another common cause of problems for arcade based systems.

 

If you're still not able to launch the games set your "Logging Level" to Troubleshooting on the General Settings -> RocketLauncher tab in RLUI, run a game, and post the RocketLauncher.log file which is created in your RocketLauncher folder.

 

Some other things to note: since you're using RL you don't need to fill in the "Executable" field in HyperHQ because it will never be used. You also don't need to fill in the "Rom path" or "Extensions" fields in HyperHQ unless you're using the Roms Only filter. None of those 3 settings are used for launching games because you're using RocketLauncher.

Share this post


Link to post
Share on other sites
Guest rynoman03

I think i'm getting closer on this. I deleted the entry I made for Sega Naomi in HyperHQ. Now at least I can get a game launched. It just takes forever. 

Share this post


Link to post
Share on other sites
Guest rynoman03

You should never rename CHDs or MAME rom files. For Naomi you should have the "Skip Checks" setting in RocketLauncherUI set to "Roms Only". That way RL won't look for the rom file avoiding the error and Demul will load the game just fine. Also make sure that you have the "7z enabled" setting set to false on the Settings tab, that's another common cause of problems for arcade based systems.

 

If you're still not able to launch the games set your "Logging Level" to Troubleshooting on the General Settings -> RocketLauncher tab in RLUI, run a game, and post the RocketLauncher.log file which is created in your RocketLauncher folder.

 

Some other things to note: since you're using RL you don't need to fill in the "Executable" field in HyperHQ because it will never be used. You also don't need to fill in the "Rom path" or "Extensions" fields in HyperHQ unless you're using the Roms Only filter. None of those 3 settings are used for launching games because you're using RocketLauncher.

See I would have thought that I needed to have the 7z option enabled. 

 

I typically don't use the "Executable field but I thought i'd see if it made any difference. 

 

Good info on the Rom Path as well. 

 

You are a wealth of knowledge agent47

 

I did re-grab the Database xml file from here and placed it in my HS database folder again. Now 100 of 174 games are showing green vs red. Woohoo. 

Share this post


Link to post
Share on other sites
Guest rynoman03

One last question... Is there a bezel for Naomi. If so i'm not finding it. 

Share this post


Link to post
Share on other sites

Not for arcade systems. The 7z setting in RLUI is used for compressed archives (zip, 7z, rar, etc) to extract the game when emulators can't load the archives directly. When that setting is on RL looks for a rom file matching the name of the archive which has a valid extension that the emu is able to load.

 

In the case of arcade roms, they are comprised of many files in the archive and the emulator is able to load those archive files directly, so the 7z setting isn't necessary. If you have it on you will get an error saying it cannot find a rom file with a valid extension inside the archive.

 

So for any arcade based system (MAME, Naomi, Atomiswave, Sega Model 2 and 3, etc) you always want 7z disabled.

Share this post


Link to post
Share on other sites
Guest rynoman03

Good to know agent47. Thanks for taking the time to explain that. 

Share this post


Link to post
Share on other sites
Guest rynoman03

I appreciate that agent47. 

 

Issue I am experiencing now: I have my controller settings setup within DEMUL 0.7a but for some reason when I select the game within HS all of the XB360 ctrl settings I setup in DEMUL aren't working. Any idears?

Share this post


Link to post
Share on other sites

You have to copy/paste the control settings from your padDemul.ini (I think) into the Demul module settings in RLUI.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...