Jump to content

tpedge

Platinum Member
  • Content Count

    17
  • Joined

  • Last visited

Community Reputation

2 Neutral

1 Follower

About tpedge

  • Rank
    Member

Profile Information

  • Gender
    Male
  • Location
    Walthamstow, London

Converted

  • Location
    London, UK

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Excellent work! I aspire to produce something of a similar quality!
  2. I'm such a muppet. parameters=mame_libretro_android.so Missed out the beginning of the parameters. It should have been: parameters=cores/mame_libretro_android.so Thanks @thatman84 sorry for being such a n00b.
  3. The issue I'm having is that when I launch a game from the MAME wheel in Hyperspin the window drops back like it's going to launch another application and then moves back to fill the screen again. I'm sure I've missed something really simple but I have no idea what it is and it's driving me crazy. Potentially helpful information... This is on an NVIDIA Shield Portable running Android 5.1 with a 128Gb Micro SD card My Hyperspin folder is at the root of the SD card which android sees as: /storage/sdcard1/Hyperspin/ The Hyperspin install works fine running Megadrive, Nintendo 64, Gameboy Advance and Playstation games My MAME roms are inside: /storage/sdcard1/Hyperspin/Emulators/MAME/roms The roms are from a non-merged 0.182 romset stored as zip files The roms play fine when loaded manually from inside RetroArch My full MAME.ini file looks like this: [exe info] path=H:\hyperspin\emulators\MAME\ rompath=Emulators/MAME/roms/ userompath=true exe=com.retroarch/com.retroarch.browser.retroactivity.RetroActivityFuture romextension=zip parameters=mame_libretro_android.so searchsubfolders=false pcgame=false winstate=HIDDEN hyperlaunch=true Per_Game_Modules=false Skipchecks=false Hide_Cursor=use_global Hide_Desktop=use_global Hide_Taskbar=use_global CPWizard_Enabled=use_global CPWizard_Delay=use_global CPWizard_Params=use_global Fade_In=use_global Fade_Out=use_global Fade_Color=use_global Fade_In_Duration=use_global Fade_Out_Duration=use_global Fade_In_Delay=use_global 7z_Enabled=use_global 7z_Extract_Dir=use_global 7z_Delete_Temp=use_global Keymapper_Enabled=use_global Keymapper=use_global MultiGame_Enabled=use_global MultiGame_Background_Color=use_global MultiGame_Side_Padding=use_global MultiGame_Y_Offset=use_global MultiGame_Image_Adjust=use_global MultiGame_Font=use_global MultiGame_Text_1_Options=use_global MultiGame_Text_1_Text=use_global MultiGame_Text_2_Options=use_global MultiGame_Text_2_Offset=use_global MultiGame_Use_Sound=use_global MultiGame_Sound_Frequency=use_global MultiGame_Exit_Effect=use_global MultiGame_Selected_Effect=use_global MultiGame_Use_Game_Art=use_global MultiGame_Art_Folder=use_global [filters] parents_only=false themes_only=false wheels_only=false roms_only=true [themes] use_parent_vids=true use_parent_themes=true animate_out_default=false reload_backgrounds=true [wheel] alpha=.15 small_alpha = 1 style = normal speed = high pin_center_width = 500 horz_wheel_y = 512 vert_wheel_position=right y_rotation = right norm_large = 360 norm_small = 230 vert_large = 400 vert_small = 240 pin_large = 500 pin_small = 200 horz_large = 240 horz_small = 150 letter_wheel_x = 800 letter_wheel_y = 384 text_width = 700 text_font = Style2 small_text_width = 260 large_text_width = 400 text_stroke_size=6 text_stroke_color=0x000000 text_color1=0x00BFFD text_color2=0xFFFFFF text_color3=0x00BFFD color_ratio=139 shadow_distance = 0 shadow_angle = 45 shadow_color=0x000000 shadow_alpha = 1 shadow_blur = 0 [pointer] animated=true x = 975 y = 384 [video defaults] path=H:\hyperspin\Media\MAME\Video\ [sounds] game_sounds=false wheel_click= true [navigation] game_jump=50 use_indexes=false jump_timer=400 remove_info_wheel=false remove_info_text=true use_last_game=true last_game=thunderl random_game=false start_on_favorites=false [Special Art A] default=true active=true x=512 y=720 in=0.4 out=0.4 length=3 delay=0 type=normal start=bottom [Special Art B] default=true active=true x=512 y=740 in=0.4 out=0.4 length=3 delay=0 type=fade start=none [Special Art C] active=false x=512 y=384 in=0 out=0 length=3 delay=10 type=fade start=none [Game Text] game_text_active = true show_year = true show_manf = true show_description = true text_color1 = 0xFFFFFF text_color2 = 0xFFFFFF stroke_color = 0x000000 text_font = Style3 text1_textsize = 26 text1_strokesize = 7 text1_x = 32 text1_y = 610 text2_textsize = 36 text2_strokesize = 8 text2_x = 30 text2_y = 640
  4. No worries dude. Thanks for your help so far. I'll keep fiddling and see what I can do. I'll post the fix when/if I find it. Sent from my iPhone using Tapatalk Pro
  5. I'm not wedded to RetroArch. To be honest I used it as it had been so simple to setup for the other systems. If you'd suggest a different emulator I'd be happy to try that instead. I'll try copying some roms there and see if it helps though.
  6. The roms are on the SD card: /storage/sdcard1/Hyperspin/Emulators/MAME/roms/mshvsfu.zip I'm using the same format of rompath for the other systems that I've managed to get working so I'm a bit stumped.
  7. We seem to be getting closer. When I choose load and detect core. It gives me the choice of a whole bunch of emulators. Arcade (MAME) launches the game fine - the controls don't work but it's progress. Launching from HS with the settings as above still doesn't work though. Sent from my iPhone using Tapatalk Pro
  8. Thanks @thatman84. I hadn't noticed I had themes_only set to TRUE in the MAME settings file, it's always the little things... So now I can get into the list of Games within the HyperSpin launcher but if I select one the screen moves backwards as if it's trying to load and then moves forward again. I assumed this was because RetroArch couldn't find the core. So I tried launching the game directly in RetroArch from the Load Content option. This crashes RetroArch. I've tried using the Online Updater to install the cores and it seems to be installing them. Is there a way to check which cores are installed? As I said I'm new to Android but going to /storage/emulated/Android/data/com.retroarch/files/system/ gives me an empty folder and I thought I'd find the installed cores there?
  9. Hi all, This is my first post (please be gentle ). I've been lurking for a while, reading a lot and I've managed to get HyperSpin setup on my PC with a whole bunch of systems. I've also got HyperSpin installed on my NVIDIA Shield Portable. So far on the shield I've got MegaDrive/Genesis, GBA, PSX and N64 working through RetroArch but I'm getting no where with MAME. I'm using a 0.182 romset, I know this is the most recent so I wondered if that might be the problem? However launching the games manually in MAME4Droid works fine. I've tried editing the settings file with the instructions in this thread to work with MAME4Droid. That didn't work so I tried setting it up through RetroArch which also isn't working for me. If I open HyperSpin and select MAME from the Main Menu the Main Menu just refreshes, I never get to the list of games. I think I have the settings file set up correctly and I've copied over the database that works fine on the PC over to the shield. Here are my settings: [exe info] path=H:\hyperspin\emulators\MAME\ rompath=Emulators/MAME/roms/ userompath=true exe=com.retroarch/com.retroarch.browser.retroactivity.RetroActivityFuture romextension=zip parameters=mame_libretro_android.so I'd usually consider myself fairly tech savvy but this is my first Android device so I could really do with some help. Any suggestions? Thanks in advance!
×
×
  • Create New...