Jump to content
Welcome Guest!

Join us now to get access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, and so, so much more. It's also quick and totally free, so what are you waiting for?

Sign in to follow this  
redtapemedia

Hyperspin as Shell: Easy Exit to Windows

Recommended Posts

You can just do what I did Sopht, which was my problem with xpadder. Just create a batch file to run as many exe's as you want, then compile that into exe, and then use instantsheller and point it to your exe. That way you can have everything start up before hyperspin on start up without issues, works great.

Doesn't a BAT file throw up a command window for sec? Even if echo is turned off. If you use AHK you will get no black windows. In my opinion shelling is done to hide windows os and a dos windows gives it away.

Try ahk I think you will find its like a bat file on steriods.

Share this post


Link to post
Share on other sites

ok here's a vid of my cab (don't laugh at it too much) from startup to shut down using Brian Hoffman's shell.exe, boot.bmp, and shutdown.exe. Manually shelled via registry. More info in the video description. If you're only interested in the startup / shutdown parts of the video then you should just watch the first 30 seconds and last 20 seconds, the rest kind of showcases the systems/themes and my (in)ability to play galaga with one hand while videotaping.

<object width="480" height="385"><param name="movie" value="http://www.youtube.com/watch?v=CM8zHgim3Ws&hl=en&fs=1&color1=0xe1600f&color2=0xfebd01"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/watch?v=CM8zHgim3Ws&hl=en&fs=1&color1=0xe1600f&color2=0xfebd01" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="480" height="385"></embed></object>

the only problem I have is trying to add cpwizard to startup. I have tried adding it to hyperspin's startup with the paramater -minimized (as in it's notation) and I've also tried creating a startup.exe in autohotkey with:

run, cpwizard.exe -minimized

(with it's path of course)

the problem I have with both of these is that when hyperspin starts cpwizard cpwizard steals focus (slightly?) the mame video still plays, and if left idle with enter attract mode, but none of my controls work, or a keyboard until I alt+tab and bring hyperspin into focus...

if anyone wants to know about the cab itself it's a former prisoners of war cab I bought off of craigslist. The cab was empty with no monitor and has a metal cp. I added joys, buttons and wired up the coinslots, all with a keyboard hack. 21" vga crt monitor I pulled out of it's housing and mounted to the bezel. Smoked glass overlay and custom taito/neogeo inspired paintjob (needs to be redone). Monitor, computer, speakers (2.1), and marquee light (turned off in video), all on smartstrip.

the computer is a 64x2 6400+ @3.6ghz on an asus crosshair w/ 4x2gb pc6400 ram (only 3gb recognized on xp32 sp3) 1.5tb seagate in an actively cooled external drive via esata, 2x radeon 8600gt in SLI

this system also has a 320gb drive with win7 so I can boot into that and manage my HS drive via a secondary 22" ws lcd and a wireless keyboard and mouse on my desk.

Edited by SophT

Share this post


Link to post
Share on other sites

I have to admit a lot of work went into it, but I know not nearly as much as you put into creating HS. I can't thank you enough for your work on this FE, having seen other FEs I know that I would not be happy and it just wouldn't have that authentic feel that I get with HS.

It's like this fe is the result of a PC10 and a neo-geo machine having sex in a nuclear power plant :P

Share this post


Link to post
Share on other sites

I'm going to try this once I've configured all my setting for my emulators e.c.t but my hyperspin is located on my D: drive how can I edit the sheller.exe to point to D: instead of C:

Or would it be easier just to copy hyperspin to c: ?

Thanks.

Share this post


Link to post
Share on other sites

hi,

i have a problem with hsshell.

when i boot the system with it and run mame, all the settings i made during gameplay in mamegui (for example rotate or button config) are gone after i boot the system new.

when i dont use hsshell and make the same, the settings are saved.

is there a solution for this?

Share this post


Link to post
Share on other sites

hello everyone,

I currently run GameEx and moving to Hyperspin. Doesn't Instant Sheller do all this already? I use it for GameEx and it works great. I'm assuming instead of GameEx I'll just point it to HyperSpin. Can anyone confirm?

thanks.

Share this post


Link to post
Share on other sites
hello everyone,

I currently run GameEx and moving to Hyperspin. Doesn't Instant Sheller do all this already? I use it for GameEx and it works great. I'm assuming instead of GameEx I'll just point it to HyperSpin. Can anyone confirm?

thanks.

You need to run instant sheller and point it to SHELL.EXE that I made, shelling to hs directly causes black screen.

Just check some of the threads about it.

Share this post


Link to post
Share on other sites
thanks!

I just tested it myself. You will need to install .net 2.0 to get it to work. Now If I can only make it shut down my PC..... Still learning!

=)

Dedos

Hyperspin has a launch on exit feature. I made a shutdown.exe that you can point to that will shutdown your pc on exiting HS.

Share this post


Link to post
Share on other sites

great, thanks Brian, It's funny, i think you helped me in GE as well.

Ok, so if the instant sheller works for me pointing directly at hyperspin, should I still point it to the shell.exe? btw, I can't find the download for it on this tread. Can you point me to the link? Might as well point me to the shutdown.exe =)..

Please don't hurt the noob!

Thanks for your help

Share this post


Link to post
Share on other sites

if instant sheller is working for you you don't need the shell.exe - some users have a problem shelling hyperspin directly so B_H made the sheller that shells hyperspin.

some users like to create their own shell in autohotkey so that they can launch multiple programs.

For example, Hyperspin can start 1 program when it starts, but what if I want to launch 2 programs on startup.

create an ahk script like this:

run, xpadder.exe
run, cpwizard.exe
run, mmagician.exe
run, hyperspin.exe

and shell to that program.

here's the shutdown.exe post:

http://www.hyperspin-fe.com/forum/showpost.php?p=22957&postcount=2

Share this post


Link to post
Share on other sites

Thanks for this.

I got the shell to boot successfully, and shutdown works when I exit HS.

However, I'm having a problem when using F12 to exit to Windows XP. When I press F12, HS exits and the 'My Documents' folder in Windows then opens. I can browse folders etc, but there is no TaskBar and Start Menu etc on the Desktop. If I close the My Documents folder, the I see my Desktop wallpaper but there is still no Start Menu and TaskBar.

Should I be able to see these after exiting the HS shell? If so, any ideas what is wrong?

Many thanks

Share this post


Link to post
Share on other sites

I'm not sure, I never actually tried the f12 version. try opening the task manager and do file -> new task... and type 'explorer' without the quotes.

Here's an alternative version for you:

Create another user with administrative privlidges called like 'manager' or something. Then when you logon with that user, it won't be shelled. Just make sure that the 'shelled' version is set to auto-logon. Then all you have to do is log off and switch users to manage your files without dealing with the shell.

Share this post


Link to post
Share on other sites

Having problems shelling hyperspin. I tried going directly to hyperspin and just got a blank screen. I made an autohotkey script as mentioned in this post.

run, c:\hyperspin\hyperspin.exe

I have instantsheller starting this shell.exe that I created and I still get a blank screen. If I open task manager hyperspin is running. Any ideas?

Share this post


Link to post
Share on other sites
Having problems shelling hyperspin. I tried going directly to hyperspin and just got a blank screen. I made an autohotkey script as mentioned in this post.

run, c:\hyperspin\hyperspin.exe

I have instantsheller starting this shell.exe that I created and I still get a blank screen. If I open task manager hyperspin is running. Any ideas?

You could try adding a delay before running HS. I found that (on my cab at least) if HS tried to launch too soon after booting up it caused issues. Try adding a delay in the script (either launch another program or add a wait in the script).

Share this post


Link to post
Share on other sites

Still no dice.

I tried 2000, 20000, and 60000. Also tried just hyperspin.exe. The script works fine when not run as the shell.

This is my current script. Shell.exe is in the hyperspin folder.

sleep, 60000

run, hyperspin.exe

Also attached screenshot of what I'm setting for instantsheller.

post-97-142870571111_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×