Jump to content

NEWBIE: Sega M2 in Hyperspin - configuring game controls (cabinet)

Recommended Posts

Hi everyone, my first ever post! 


I'm completely brand new to this, having just taken delivery of a Candy Cabs cabinet running lots of emulators under Hyperspin.


Therefore, please excuse the ignorance of this question, but then I hope it should be a simple one!


MY QUESTION: Quite simply: In the Sega model 2 emulator running in Hyperspin, how do you bring up a menu to configure the controls? I mean in MAME you would press Tab on the keyboard and select "Input - this game": What's the equivalent in Sega M2? 


REASON FOR ASKING: I absolutely adore the game "Top Skater" which I've found in the Sega M2 emulator. It fires up and launches into the demo mode OK, but it won't respond to any of the controls for "Insert Coin", so I can't play it! Aahhhh! The torture! The frustration! None of the controls or joysticks do "insert coin". I plugged in a keyboard and hit Tab, but it didn't respond. All I want to do is bring up the menu in which I can assign "insert coin" to one of the buttons: How do I do that, if it's one of the emulators in Hyperspin?


Many thanks in advance for any replies.



Share this post

Link to post
Share on other sites

You have to set controls up through the emulator it's self. go to the emulator load a game if it goes to fullscreen hit escape then go to the game tab and it will let you set controls.


I personally don't care much for this emulator so I don't know if the skating game works with joystick and buttons. I remember it being a stand up game on a skate board.

Share this post

Link to post
Share on other sites

Thanks so much for replying! I'll give that a try. That's right: It was a stand-up game, but I had a blast playing it with just keys on my laptop a while back. Happy to play it with a joystick and buttons, so hoping to get it to run on my arcade cabinet.


Incidentally, I also found the Top Skater ROM was in MAME but it didn't appear on the Hyperspin MAME "wheel" (I found it in the MAME ROMS folder just on the PC). When I eventually worked out how to launch the MAME one manually from Rocket Launcher, it was all glitchy and not running properly. The Sega M2 one runs fine, but I can't yet play it! Aaaahhhh!

Share this post

Link to post
Share on other sites

If I hit "escape" in a game, it just goes back to the wheel: I mean it just exits that game and returns to the list of games available under that emulator. I don't see a "game tab" at all. What am I missing here? How do I just bring up a configuration menu?


Should I come out of Hyperspin altogether and go via rocket launcher or delve into the folders on the PC or something?

Share this post

Link to post
Share on other sites

You need to forget about hyperspin and rocketlauncher and open the emulator and configure your controls from that program. Once that is done you can launch from hyperspin with the correct control configuration.

Sent from my XT1254 using Tapatalk

Share this post

Link to post
Share on other sites

I set the game exit hotkey in RL to use my tankstick preconfig with v. It works as expected. Then i set each game from the emulator. I just wish there was a way to configure all the games at once. Seems tough though due to the variety of shooters, drivers, ECT. 

Edited by KillaBLK

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By jevs
      Hi all.    very new to this, but a bit handy when it comes to building stuff. 
      A good friend of mine showed me his bartop machin that he was in the process of buillding and after looking at some of the games etc (running on pi) i was wowed.    decided to have a go myself as I was off work over xmas.....so it begins...
      Had a look around the web for the kind of machine I wanted to build but nithing really caught my eye so went with a standard kind of cabinet - no sizes or plans, just a little sketch on the back of a used envelope and away we go - only consideration I had to make was the screen size.   Popped to my local currys/pc world - had a look, wanted to have 4k - but whch size?  once its bought you cant go any bigger so I figured its all or nothing so picked up a 43" 4k LG smart tv. 
      Everything was build around it, so I only had to make sure the inside dimension of the cabinet was 40" had it all built and working in about 3 days - took another 5 days or so adding bits here and there...speakers and subwoofer, foot rail, hidden draw for keyboard /mouse etc.
      all worked out great - still learning config of hyperspin but will get there in the end
      Cant wait to build the MK2 now....
      video below  - compiled from pictures i took while maing the cabinet - all put together by apple iphone lol.  
      Jevs Arcade - youtube
      Taken this morning after fitting the footrail. pretty much finished now  hope you like!

    • By zanaga
      Hola como estan?
      estoy teniendo un problema con menu, baje un pack de n64 y cuando lo instalo el dibujo de anterior/siguiente juego no aparece abajo en el medio sino que esta en todo el centro de la pantalla y no se como acomodarlo (Adjunto imagen del menu al que me refiero)
      El otro problema que tengo es que cuando instalo los juegos del pack famicon de 550 juegos solo me reconoce 79, es la primera vez que me pasa, rehago la database y solo reconoce 79.
      Muchas gracias por su ayuda

    • By hawkfanz
      I use rocketlauncher to start mame64 games in hyperspin but the first game on a fresh windows startup takes 20 seconds to start.  After closing this game the next game will open almost immediately. I know others have asked this question but I can’t find a solution. I have no anti-virus running, no windows defender, no rocketlauncher fades or bezels. I updated the mame64 version to the 209 no nag from 197 no nag with no change. Any help or suggestions would greatly be appreciated!!
    • By roguen1
      Hello , i don't know if this is the correct place to post this , but i have a problem for a while that i have never figured out whats cause it , and is the fact of that in the transitions , from start to end, it appear this horizontal lines all over the screen , and it's bit annoying , i have done everything to trying to resolve this issue (update drivers , windows , download hyperspin again etc) and it still there , what could be? 
      (sorry if my english is bad)

  • Create New...