Jump to content
martijnsx

Where to update modules?

Recommended Posts

Hi,


Where can update the modules? I have the MAME 0.166 module now and want to update to 0.180.

Mame 0.180 will not run the games with the old module.

I thought that the updating was done in RLauncherUI but now i can't find it.


Thanks

Share this post


Link to post
Share on other sites

That may be the latest module as they don't need updating with every mame revision. Mine is working fine with mame 0.181 so maybe you have another problem. 

All updating is done automatically in RLUI as you know.

Share this post


Link to post
Share on other sites
20 minutes ago, martijnsx said:

Do you also use the nonag version of mame?

Yes i do.

Just checked that the module is 2.3.8 for mame version no lower than 0.166. The module can be used for older versions but it needs to be set to legacy mode but i know you don't need that.

Share this post


Link to post
Share on other sites

Well, the problem is somewhat weird.

I have the roms for mame located on a different harddisk. The emulator, hyperspin and mame are on F and the mame roms are on M.

The games that need a parent rom do not start, for example SF2CE (street fighter championship edition). I have found that the game does start if i place SF2CE.zip in the rom directory of mame itself. Weird. If i copy all roms to the mame rom directory the game does not start. Also weird.

I use a 0.151 version for the rom files and i tried different versions of mame (version 0.169 hqmame, version 0.179 and 0.180 nonag mame). 

Could it be caused by a difference of versions in mame and the romset?

Share this post


Link to post
Share on other sites

You definitely need a matching Rom set preferably the split set and the Chd set as well.

Share this post


Link to post
Share on other sites
5 hours ago, martijnsx said:

Ok thanks. I will try. What is the split set?

A split set has the clones in separate zips which makes the set bigger. A merged set has the clones in the parent zip thus making the set smaller but less convenient. 

Share this post


Link to post
Share on other sites

I have the same issue... launching parent roms is possible, but launching the clones give me an "AHK_Class MAME error". 

When launching the clones through MAME emulator, I have no issues. Only through HyperSpin...

Do I need to update my MAME module?

 

Another thing: how do I know what romsets I'm using? (sorry for the noobquestions...)

 

Share this post


Link to post
Share on other sites
8 hours ago, MajorWeirdo said:

I have the same issue... launching parent roms is possible, but launching the clones give me an "AHK_Class MAME error". 

When launching the clones through MAME emulator, I have no issues. Only through HyperSpin...

Do I need to update my MAME module?

 

Another thing: how do I know what romsets I'm using? (sorry for the noobquestions...)

 

If you don't know which set you're using you should go get the latest version and the latest mame. 

If you are using Rocket launcher then you will have the latest module. 

Share this post


Link to post
Share on other sites

Ok, thank you. I'm still using HL 3 with Mame 161.

 

Would I have to redo all configurations in Hyperlaunch again?  The parents are working now with arcade cabinet controls, but if I get the latest version romset and mame, would I have to redo the controls etc ?

 

And is there a way to upgrade from HyperLaunch to RocketLauncher without losing all of my actual configuration? (I will tear my hair out if I loose all my settings and controls)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×